Jump to content

[Tuto] Mario Kart DX Arcade GP 1.10, including banapassport save and online play, QR codes and LAN versus play !


Guest linglang
 Share

Recommended Posts

On 1/9/2021 at 12:45 AM, Cool Coyote said:

anybody have a clue or a better question is has anyone been able to get the 2 extra tracks up and running on mario kart arcade?  donkey kong and pac man and how did you achieve the unlock to it ?

 

3 hours ago, cogaita said:

I almost did. I installed a virtual cam and pointed to a image of the qr code. But the image shows streched on the game so doesn t work.

Installent different virtual cams got different results but never got one to read the code. I found a video on youtube of a kid unlocking the course with a web cam, so maybe if we ask him wich model of cam he used we can buy the same... Just search for mario kart arcade dx qr code on youtube

Those are updates / expansions, which we do not have in the version we got !

It was the April 21st 2016 update that added Pac-Man Stadium and Namco Circuit courses

https://www.arcadebelgium.net/t4447p25-mario-kart-arcade-gp-dx

 

Edited by petje
Link to comment
Share on other sites

Le 08/01/2021 à 10:49, petje a dit :

B)

Tested MKDX today, server is still down, no idea when it will be working again

 

 

hello, the same for me until i used the " MKDX Simulation server 1.0 " and all items , karts and characters are unlocked directly.

follow instructions below

 

au vu des problèmes pour ce connecter a son profile sur MKDX
je vous ai traduit le simulateur de serveur unlocker de profile créer par Harm
http://www.mediafire.com/file/ak7s3zikrx4dc7w/seveur_mario_kart_-v1.0%21.rar/file
lancer le simulateur
image.pngmettre ton pseudo
configurer le server adresss en 127.0.0.1
image.png
puis lancer MKDX Bon jeu

Link to comment
Share on other sites

On 11/01/2021 at 1:01 PM, petje said:

 

Those are updates / expansions, which we do not have in the version we got !

It was the April 21st 2016 update that added Pac-Man Stadium and Namco Circuit courses

https://www.arcadebelgium.net/t4447p25-mario-kart-arcade-gp-dx

 

ahh yes of course. we are in no position to do anything since the updates

Link to comment
Share on other sites

On 13/01/2021 at 5:39 AM, stuart2773 said:

 

Would it be possible to add the option to TeknoParorrot UI to Unlock ALL Characters & Karts?

yes it is i dont like that myself. but since i got the english translations and updates they were already unlocked. but why would u want to?

Link to comment
Share on other sites

It keeps telling me it's offline, can anyone confirm the servers are working for me?

Link to comment
Share on other sites

  • 4 weeks later...
Le 12/01/2021 à 10:35, PENTAGNOSTIQ a dit :

 

 

hello, the same for me until i used the " MKDX Simulation server 1.0 " and all items , karts and characters are unlocked directly.

follow instructions below

 

au vu des problèmes pour ce connecter a son profile sur MKDX
je vous ai traduit le simulateur de serveur unlocker de profile créer par Harm
http://www.mediafire.com/file/ak7s3zikrx4dc7w/seveur_mario_kart_-v1.0%21.rar/file
lancer le simulateur
image.pngmettre ton pseudo
configurer le server adresss en 127.0.0.1
image.png
puis lancer MKDX Bon jeu

Salut à tous,

super cet outil, pour se faire plaisir. Du coup, je cherchais un moyen de créer mon propre serveur local, afin de pouvoir jouer et sauvegarder ma progression, quelqu'un sait s'il est possible de trouver les specs du serveur banapassport, voire le code source de l'outil de Harm ? :)

Link to comment
Share on other sites

Any ideas on one cabinet constantly reverting to 1360x768? I have changed the settings on TP, AMIconfig and default config to 1920x1080 and it just goes back to 1360x768. I have two cabs networked and everything else is ok just cabinet 1 will not run 1080p.

Link to comment
Share on other sites

Il y a 7 heures, jayc001 a dit :

Any ideas on one cabinet constantly reverting to 1360x768? I have changed the settings on TP, AMIconfig and default config to 1920x1080 and it just goes back to 1360x768. I have two cabs networked and everything else is ok just cabinet 1 will not run 1080p.

 

same pc config on the two computer?

Link to comment
Share on other sites

  • 3 weeks later...

Hi Guys ! I don't know if this has been discussed yet but I noticed a weird graphical bug in my MKDX : Object roulette does not  appear in the upper middle object box when driving on a "?", it seems hidden behind the box....

I use 3840*2160 rez but I did try some other resolutions (1024*768 / 1280*720 / 1600*900 / 1920*1080) and still have some graphical issues similar to this in some menus and in this box.

Any way to fix this ?

 

Thanks in advance

Link to comment
Share on other sites

Guest petje
7 hours ago, stanleyyeh0205 said:

I was wondering if I could pass Authentication Check and Game Server Check by editing any configuration files without TKPT.

You try to do what, update the game on the official network ?

That will not work

 

Edited by petje
Link to comment
Share on other sites

On 20/01/2021 at 4:42 PM, neosketch said:

found this on youtube


it unlocked everything

false advertising that doesn't unlock everything, what so u have DK and pac-man tracks unlocked? nope

Edited by Cool Coyote
Link to comment
Share on other sites

hi i have a problem with mario kart as in the photo i get stuck in this error how can i solve it? and another problem may be due to the ip addresses that I have and which are 192.168.178.1 as the default gatawey? thank you so much

 

mario kart.jpg

Link to comment
Share on other sites

  • 2 weeks later...

Can anybody get telemetry output available for this game for simtools?

 

here is example

 

First, let’s make the game a settings file to hold the Telemetry settings for the game.
I’m suggesting a ‘Telemetry.cfg’ file that holds the motion configuration for the game.

You may already have a configuration file for the game that you want to put these settings in, this is just an example. (This also gives SimTools a file to patch for motion, and allows the telemetry outputting to be on or off as needed.)

The Telemetry.cfg file holds these 4 settings:
- Enable_Telemitry = False
- IpAddress = 127.0.0.1
- Port = 4123
- MS_OutputRate = 10

I wrote the following example code in VB.net, as its dead simple to read and see what I’m doing.
Basically thou, I’m creating a looping background thread that builds and sends the needed output with UDP.
Once you have ‘something like’ this code in the game, all you have to do is:
Call ‘Start_Telemetry_Output()’ when the game starts up.
And ‘Stop_Telemety_Output()’ when the game shuts down.

Ok, now some code:
Private Telemetry_Sender As New UdpClient
Private Telemetry_Loop_ms As Integer
Private
 Telemetry_Running As Boolean = False
Private
 Telemetry_Thread As Threading.Thread

'Starts up the Telemetry Sender.
Private Sub Start_Telemetry_Output()

'only startup if not already started.
If Telemetry_Running = False Then
'read from Telemtry cfg file.
Dim Telemitry_Enabled AsString = "Get Enabled_Telemetry value from the Telemetry.cfg file"
Dim IpAddress AsString = "Get IpAddress value from the Telemetry.cfg file"
Dim Port AsString = "Get Port value from the Telemetry.cfg file"
Dim MS_OutputRate AsString = "Get MS_OutputRate value from the Telemetry.cfg file"

If CBool(Telemitry_Enabled) = True Then
Try
'startup a new client.
Telemetry_Sender = New UdpClient
Telemetry_Sender.Connect(IpAddress, CInt(Port))

'set loop speed & start sending data.
Telemetry_Loop_ms = CInt(MS_OutputRate)
Telemetry_Running = True
Telemetry_Thread = New Threading.Thread(AddressOf Telemetry_Loop)
Telemetry_Thread.IsBackground = True
Telemetry_Thread.Start()
Catch ex As Exception
'Could not create the UDP sender, no need to do anything.
End Try
End If
End If

End Sub

'Send Telemetry
Public Sub SendTelemetry()

Try
'Collect the data.
Dim Roll As String = ""
Dim Pitch As String = ""
Dim Yaw As String = ""
Dim RollSpeed As String = ""
Dim PitchSpeed As String = ""
Dim YawSpeed As String = ""
Dim Vertical As String = ""
Dim Lateral As String = ""
Dim Longitudinal As String = ""
'add anything else you want to add, its easy now!
'Dim Rpm As String = ""
'Dim Speed As String = ""


'check the status to see if the game is being played (In Game, In Menus, Paused).
Dim Game_Is_Playing As Boolean = 'Get if the game is being played)

'game is actually being played check.
If Game_Is_Playing = True Then
 
'If game is actually being played (not in menus or paused).
Roll = "Get value from your game" 'in degrees - (-180 to 180)
Pitch = "Get value from your game" 'in degrees - (-180 to 180)
Yaw = "Get value from your game" 'in degrees - (-180 to 180)
RollSpeed = "Get value from your game" 'in (rad/sec)
PitchSpeed = "Get value from your game" 'in (rad/sec)
YawSpeed = "Get value from your game" 'in (rad/sec)
Vertical = "Get value from your game" 'in g's acceleration
Lateral = "Get value from your game" 'in g's acceleration
Longitudinal = "Get value from your game" 'in g's acceleration
Else
'If the game is paused or in the menus. (not actually being played)
Roll = "0" 'in degrees - (-180 to 180)
Pitch = "0" 'in degrees - (-180 to 180)
Yaw = "0" 'in degrees - (-180 to 180)
RollSpeed = "0" 'in (rad/sec)
PitchSpeed = "0" 'in (rad/sec)
YawSpeed = "0" 'in (rad/sec)
Vertical = "0" 'in g's acceleration
Lateral = "0" 'in g's acceleration
Longitudinal = "0" 'in g's acceleration
End If

'Build the output string. (The 'S~' and the '~E' is so the user can see if they have a complete string of inputs)
Dim WhatToSend As String = "S~Roll:" & Roll & "Pitch:" & Pitch & ":Yaw:" & Yaw & "RollSpeed:" & RollSpeed & "PitchSpeed:" & PitchSpeed & ":YawSpeed:" & YawSpeed & "Vertical:" & Vertical & ":Lateral:" & Lateral & ":Longitudinal:" & Longitudinal & "~E"

'Send the string
Dim bytCommand As Byte() = NewByte() {}
bytCommand = Encoding.UFT8.GetBytes(WhatToSend)
Telemetry_Sender.Send(bytCommand, bytCommand.Length)
Catch ex As Exception
'something went wrong, turn off telemetry output.
Stop_Telemity_Output()
End Try

End Sub

'Stop Telemetry Output
Public Sub Stop_Telemetry_Output()

'only shutdown if already started.
If Telemetry_Running = True Then
'turn output off.
Telemetry_Running = False
'let it finish what its doing.
Threading.Thread.Sleep(100)
'Close Client.
Telemetry_Sender.Close()
End If

End Sub

'Send Telemetry Loop
Private Sub Telemetry_Loop()

'Send Telemetry.
SendTelemetry()
'pause till next packet is needed.
Threading.Thread.Sleep(Telemetry_Loop_ms)
'loop again if needed.
If Telemetry_Running = True Then
Telemetry_Thread = New Threading.Thread(AddressOf Telemetry_Loop)
Telemetry_Thread.IsBackground = True
Telemetry_Thread.Start()
End If

End Sub

 

 

I really don't know how to do this.

 

if it is too hard to get it worked, sorry for asking :D

kindly forgive me.

 

Link to comment
Share on other sites

Is there a way to use the profile.bin save files with TP? I tried adding the SV folder but it does not work. TP has all my settings working well for network play and screen res. When I try and use Jconfig to play MK then I have the unlock working but screen res is wrong and network does not work.

Link to comment
Share on other sites

Guest tommiegunz
12 hours ago, pacooka said:

Does anyone know why Mario Karts run slowly (low fps) on windows 10 but works fine on Windows7?

(i7 GT1060)

it runs just fine for my win 10, i5, GTX 750TI

Link to comment
Share on other sites

If you have a laptop my only suggestion is maybe you're running it on battery mode and it's not on boost mode (something to do with power saving). Some gaming laptops have this boost feature when a game requires it's to perform correctly e.g. a typical Laptop might have on average 2.4ghz quad or 6 core processor to run as standard, but can boost to something like 4.2ghz which my laptop can do when overclocked. I had this issue with Tekken 7 FR (which uses the same board as MK GP DX) on battery, it ran slow and sluggish but when I put the charger in, the speed shot up and ran faster than it should have (144hz screen)

Link to comment
Share on other sites

  • 2 weeks later...
Le 12/01/2021 à 10:35, PENTAGNOSTIQ a dit :

 

 

hello, the same for me until i used the " MKDX Simulation server 1.0 " and all items , karts and characters are unlocked directly.

follow instructions below

 

au vu des problèmes pour ce connecter a son profile sur MKDX
je vous ai traduit le simulateur de serveur unlocker de profile créer par Harm
http://www.mediafire.com/file/ak7s3zikrx4dc7w/seveur_mario_kart_-v1.0%21.rar/file
lancer le simulateur
image.pngmettre ton pseudo
configurer le server adresss en 127.0.0.1
image.png
puis lancer MKDX Bon jeu

GENIAL,tout est débloqué sous TP...Merci à toi et a HARM...

 

Au préalable,faut dl la save de reaver ,créer un dossier sv ,dans lequel on met la save...

Une fois MK lancé sous TP,Suffit d'appuyer sur F2 ,ca scane et c'est good!

 

C'est ma fille qui va etre heureuse...:very-good:

Link to comment
Share on other sites

il y a 13 minutes, JustinCredible81 a dit :

I can find the original game several places, but I cannot find a working link of 1.10. Anyone have it? 

Available on thé TP topic...first page,méga link...👍

Link to comment
Share on other sites

15 minutes ago, meddu69 said:

Available on thé TP topic...first page,méga link...👍

 

Those mega links are not 1.10, look at it again. The only one that's 1.10 is that ipfs link and it doesn't work.  Or at least for me I get a blank page, and couldn't load it in jdownloader either. 

 

Even virus-man's site only has original from what I saw. 

 

I already have 1.10 but I'm having trouble calibrating with JConfig, and I can't load it in Teknoparrot because the exe was overwritten by Jconfig.  I set my analog stick that works in every other game in Jconfig, but it doesn't work in calibration. 

Edited by JustinCredible81
Link to comment
Share on other sites

  • 1 month later...

Hey guys.. hoping to get some help. I’m able to play online with banapass, however I cannot play local co-op. I have 4 computers setup wired into the same hub. It used to work before without any issues. The game would say 4 players in lobby.. but now nothing.. each player can can only race individually by themselves.. but we can’t race each other anymore.. any idea why?

 

Thanks!

Link to comment
Share on other sites

6 hours ago, Nitro0602 said:

Hey guys.. hoping to get some help. I’m able to play online with banapass, however I cannot play local co-op. I have 4 computers setup wired into the same hub. It used to work before without any issues. The game would say 4 players in lobby.. but now nothing.. each player can can only race individually by themselves.. but we can’t race each other anymore.. any idea why?

 

Thanks!

Probably IP address changed, make sure to exclude from dhcp and set manual IPs, 

Link to comment
Share on other sites

  • 3 weeks later...
En 19/5/2021 a las 15:39, OSX_MAC dijo:

hello

my error

respect usb

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...