Jump to content

HOW TO INSTALL INITIAL D ZERO VER. 2


computcon

Recommended Posts

Il y a 1 heure, Lesteph25 a dit :

hé oui... quelqu'un a déja eu le courage de d'enchainer le chapitre 2 complet j'usqu'au chapitre 3 ? peu etre que le bug ne concerne que le chapitre 2...

 

parce que j'ai remarqué quelque chose, l'autre jour, lors d'un de me test, j'ai chargé ma sauvegarde qui était sencé etre chapitre 2 2eme course.

et je me suis retrouvé dans le chapitre 1... MAIS... la 1ere course était déja gagné... donc => chap1 2eme course.

 

Depuis le début que nous avons la 2.11 j'ai du tout refaire 3 fois... Doncr franchement après ça tout enchaîner jusqu'au chapitre 3 faut avoir du courage...... 

 

Lors du dernier reset j'ai eu la même chose que toi et sur d'autres courses aussi après elles était déjà gagné 

Link to comment
Share on other sites

 
  • Replies 157
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Il y a 2 heures, soso92 a dit :

Depuis le début que nous avons la 2.11 j'ai du tout refaire 3 fois... Doncr franchement après ça tout enchaîner jusqu'au chapitre 3 faut avoir du courage...... 

 

Lors du dernier reset j'ai eu la même chose que toi et sur d'autres courses aussi après elles était déjà gagné 

tu m'étonnes, si c'es prévus d'etre réctifié pour la 2.30 alors c'est cool

Link to comment
Share on other sites

 
Il y a 15 heures, Lesteph25 a dit :

hé oui... quelqu'un a déja eu le courage de d'enchainer le chapitre 2 complet j'usqu'au chapitre 3 ? peu etre que le bug ne concerne que le chapitre 2...

 

parce que j'ai remarqué quelque chose, l'autre jour, lors d'un de me test, j'ai chargé ma sauvegarde qui était sencé etre chapitre 2 2eme course.

et je me suis retrouvé dans le chapitre 1... MAIS... la 1ere course était déja gagné... donc => chap1 2eme course.

 

J ai tenté, j ai donc fini chapitre 1 ET 2 pour arriver au 3 , j ai fais la première course du chapitre 3 , j ai save et quand j ai relancé , je suis toujours a la première course du chapitre 1

Link to comment
Share on other sites

 
  • 2 weeks later...
 
On 12/31/2021 at 10:30 AM, akiroz said:

@piotr25691 Let's move the convo here.

It's still under development, I want to be able to at least boot the game myself with e10s before letting you try it.

I'm compiling segatools myself now, will keep you posted.

ok
lets wait for idz support in e10s :sunglasses:

 

in the latest build there is an error

ReferenceError: Transform is not defined
    at Object.<anonymous> (C:\snapshot\e10s\src\idz\decode.js)
    at Module._compile (pkg/prelude/bootstrap.js:1794:22)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at Module.require (pkg/prelude/bootstrap.js:1719:31)
    at require (node:internal/modules/cjs/helpers:102:18)
    at Object.<anonymous> (C:\snapshot\e10s\src\idz\index.js)
    at Module._compile (pkg/prelude/bootstrap.js:1794:22)

 

i fixed by adding an import:

const { promises: stream, Transform } = require("stream");

 

but now i get a new error 6505

Edited by piotr25691
fixed but 6505
Link to comment
Share on other sites

 
Le 19/12/2021 à 11:31, stephaneh a dit :

J ai tenté, j ai donc fini chapitre 1 ET 2 pour arriver au 3 , j ai fais la première course du chapitre 3 , j ai save et quand j ai relancé , je suis toujours a la première course du chapitre 1

he ben, chapeau... et tu n'a rien débloqué en terminant le ch2 ? parce que, sauf erreur de ma parts, ce qu'on débloque on ne le perd pas. et je me suis toujours demandé si les voitures / capacité / conduite / etc... n'étaient pas bridés vu qu'on dépasse pas le ch1.

par exemple, dans cetain virage, il suffit de lever la pédale d'accélérateur pour partir en drift dans le virage (avec une sensation d'auto pilote) alors qu'il aurait clairement fallu un petit coup de frein pour ce résultat.

Link to comment
Share on other sites

 
6 hours ago, piotr25691 said:

but now i get a new error 6505

 

The idz implementation is not even finished yet XD

You can probably see a lot of TO-DO comments littered all over the idz code.

Be patient, the idz protocol is quite a beast compared to all the other games (which only took me a day or 2 to implement).

Link to comment
Share on other sites

 
23 hours ago, akiroz said:

 

The idz implementation is not even finished yet XD

You can probably see a lot of TO-DO comments littered all over the idz code.

Be patient, the idz protocol is quite a beast compared to all the other games (which only took me a day or 2 to implement).

I have updates to tell:

You no longer get error 6505, but after you enter your name the game stays for a while loading, then the network icon turns yellow, the game continues in offline mode, and your data doesn't save.

After you finish the game, the network icon turns back to green.

 

I hope you finish the idz api in e10s asap...

 

also i have a bunch of errors like

ReferenceError: crypto is not defined

and

ReferenceError: buf is not defined

Edited by piotr25691
Link to comment
Share on other sites

 
Le 02/01/2022 à 12:35, Lesteph25 a dit :

he ben, chapeau... et tu n'a rien débloqué en terminant le ch2 ? parce que, sauf erreur de ma parts, ce qu'on débloque on ne le perd pas. et je me suis toujours demandé si les voitures / capacité / conduite / etc... n'étaient pas bridés vu qu'on dépasse pas le ch1.

par exemple, dans cetain virage, il suffit de lever la pédale d'accélérateur pour partir en drift dans le virage (avec une sensation d'auto pilote) alors qu'il aurait clairement fallu un petit coup de frein pour ce résultat.

C'est directement lié au niveau de la voiture, il y as effectivement un espèce de flou,freinage/direction automatique, mais dès que tu l améliore ca s'estompe et ca fini par disparaître

 

Perso je modifie la sauvegarde pour monter la voiture au niveau maximum directement

Link to comment
Share on other sites

 
 
19 hours ago, akiroz said:

@piotr25691

 

e10s 1.6.beta0 is out, I have only tested it with idz 1.31.00

If there are issues, give me the game version, steps to reproduce, and the logs on the e10s console. cheers~

https://dev.s-ul.net/akiroz/e10s/-/wikis/Releases

yo ty, lets check it out

then ill also check it with idz 2.11.00 to see what happens

Link to comment
Share on other sites

 
21 hours ago, akiroz said:

@piotr25691

 

e10s 1.6.beta0 is out, I have only tested it with idz 1.31.00

If there are issues, give me the game version, steps to reproduce, and the logs on the e10s console. cheers~

https://dev.s-ul.net/akiroz/e10s/-/wikis/Releases

i have bugs to announce:

when you select a gamemode the network icon turns yellow

after you finish the course you get 8304 twice then the icon turns green again and the card saves

 

game version is 1.31.00

steps to reproduce:
choose time attack after making an aime card

 

logs on e10s console:
pmmUPeF.png
(no errors occurred)

 

ver.2 worked with no problems tho

choosing legend of the street in ver.1 does not cause the error even if the mission is a time attack mission

Edited by piotr25691
ok so legend of the street works
Link to comment
Share on other sites

 
5 hours ago, piotr25691 said:

i have bugs to announce:

when you select a gamemode the network icon turns yellow

after you finish the course you get 8304 twice then the icon turns green again and the card saves

Thanks

I also encountered this once during development but couldn't reproduce it again, guess I'll dig around

Link to comment
Share on other sites

 
 
 
 

How do you setup FFBn 2.11 I have the files in the IDZ package folder with start.bat and getting no force feedback on a G29.

I have the version from the VirusMans page.

Other games work fine.

 

Update: Got it working seems I had a couple of copies and was using the wrong one.

 

But FFB is very poppy for the g29 on all three settings.

Edited by drguild
Link to comment
Share on other sites

 
On 11/1/2021 at 6:01 AM, Noki39 said:

Hello, I tried to install the game for a few times now, but keep getting this screen when the game starts, after flashing "Initializing" for a fraction of second.
Does anyone have any idea on how to deal with it, or have anyone encounter this screen?

image.png.effce24d6d36804dc1dcdf90117f108e.png

image.png.e379e15e9d07dc1ce24317265c123a3d.png

I also encountered the same issue. Does anyone know how to solve it? Thanks.

Link to comment
Share on other sites

 
  • Modo
il y a 50 minutes, nelson a dit :

I also encountered the same issue. Does anyone know how to solve it? Thanks.

don't lose your time with V2 you can't save the game, after chapter 1 the game resets your savegame.

Edited by WildWolf
Link to comment
Share on other sites

 
Il y a 2 heures, WildWolf a dit :

don't lose your time with V2 you can't save the game, after chapter 1 the game resets your savegame.

exact, but the "gameplay / physics / etc" is really better i think.

 

Le 10/01/2022 à 18:13, Wingchundub a dit :

I get this when booting and it stays, no game boot

image_2022-01-10_171301.png

 

Il y a 3 heures, nelson a dit :

I also encountered the same issue. Does anyone know how to solve it? Thanks.

 

 

we can not read what is written on the screenshots (the resolution of the site system is too low)

 

show you segatools.ini

Link to comment
Share on other sites

 

hello,

i have a ultra wide screen and i like to run it as windows mode or something it works. i did the following change on renderer.ini and initialD.ini, There is no issue on minime ,i got "Startup OK", i try run it under TeknoParrotUi.exe or just run it alone with run as admin (SegaTools\minime\start.bat) + (package\start.bat). it run but i got black screen for 10 mins. i see the cursor is spanning but nth work. any idea?

 

initialD.ini

[ Graphics ]

;; ƒtƒ‹ƒXƒNƒŠ[ƒ“Ý’è(‚P‚Ńtƒ‹ƒXƒNƒŠ[ƒ“) yWin32”Å‚Ì‚Ý—LŒøz
;; (ƒfƒoƒbƒOƒrƒ‹ƒhŽž‚É‚ÍONó‘Ô‚Å‚à‘I‘ðƒ_ƒCƒAƒƒO‚ªo‚Ü‚·)
;;
FullScreen = 0
SyncMode = 0

;; ƒAƒvƒŠƒP[ƒVƒ‡ƒ“ƒEƒBƒ“ƒhƒEƒTƒCƒY
Width  = 2560
Height = 1440

renderer.ini:

[ FRAME_BUFFER_MAIN ]
Width			= 2560
Height			= 1440

segatools.ini

[vfs]
amfs=C:\Games\Initial D - Arcade Stage Zero\amfs
appdata=C:\Users\yesman\AppData\Roaming\TeknoParrot\IDZ\

[dns]
default=192.168.1.236

[ds]
region=4

[aime]
aimeGen=1
felicaGen=0

[netenv]
enable=1

[keychip]
subnet=192.168.1.0

[gpio]
dipsw1=1

[io3]
mode=tp
pos_shifter=0
autoNeutral=1
singleStickSteering=1
restrict=97

[dinput]
deviceName=
shifterName=
brakeAxis=RZ
accelAxis=Y
start=3
viewChg=10
shiftDn=1
shiftUp=2
gear1=1
gear2=2
gear3=3
gear4=4
gear5=5
gear6=6
reverseAccelAxis=0
reverseBrakeAxis=0

 

Edited by mryesman686
cont'd
Link to comment
Share on other sites

 
On 1/15/2022 at 11:53 AM, nelson said:

I also encountered the same issue. Does anyone know how to solve it? Thanks.

Try this:

start menu>regedit

 

change this:

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\Language]

"Default"="0411"

Link to comment
Share on other sites

 

I know that the game doesn't like E drive but tried with symlink but don't work I would have thought that it would  can run from C okay but would rather C since I need the space 

NVM

Got it

 

Edited by joe555
Link to comment
Share on other sites

 
 
Le 19/01/2022 à 08:13, mryesman686 a dit :

hello,

i have a ultra wide screen and i like to run it as windows mode or something it works. i did the following change on renderer.ini and initialD.ini, There is no issue on minime ,i got "Startup OK", i try run it under TeknoParrotUi.exe or just run it alone with run as admin (SegaTools\minime\start.bat) + (package\start.bat). it run but i got black screen for 10 mins. i see the cursor is spanning but nth work. any idea?

 

initialD.ini


[ Graphics ]

;; ƒtƒ‹ƒXƒNƒŠ[ƒ“Ý’è(‚P‚Ńtƒ‹ƒXƒNƒŠ[ƒ“) yWin32”Å‚Ì‚Ý—LŒøz
;; (ƒfƒoƒbƒOƒrƒ‹ƒhŽž‚É‚ÍONó‘Ô‚Å‚à‘I‘ðƒ_ƒCƒAƒƒO‚ªo‚Ü‚·)
;;
FullScreen = 0
SyncMode = 0

;; ƒAƒvƒŠƒP[ƒVƒ‡ƒ“ƒEƒBƒ“ƒhƒEƒTƒCƒY
Width  = 2560
Height = 1440

renderer.ini:


[ FRAME_BUFFER_MAIN ]
Width			= 2560
Height			= 1440

segatools.ini


[vfs]
amfs=C:\Games\Initial D - Arcade Stage Zero\amfs
appdata=C:\Users\yesman\AppData\Roaming\TeknoParrot\IDZ\

[dns]
default=192.168.1.236

[ds]
region=4

[aime]
aimeGen=1
felicaGen=0

[netenv]
enable=1

[keychip]
subnet=192.168.1.0

[gpio]
dipsw1=1

[io3]
mode=tp
pos_shifter=0
autoNeutral=1
singleStickSteering=1
restrict=97

[dinput]
deviceName=
shifterName=
brakeAxis=RZ
accelAxis=Y
start=3
viewChg=10
shiftDn=1
shiftUp=2
gear1=1
gear2=2
gear3=3
gear4=4
gear5=5
gear6=6
reverseAccelAxis=0
reverseBrakeAxis=0

 

if you launch it with TP, it will modify files in the game (segatools.ini), and you will no longer be able to launch it via "minime+start.bat"

 

your initiald.ini and renderer.ini is OK for 1440p windowed

 

 

my segatools.ini for minime+start.bat :

 

------------------------------------------------------------------------------------------------------------------------

[vfs]
; Insert the path to the game AMFS directory here (contains ICF1 and ICF2)
amfs=C:\JEUX\Initial D Zero V 2.11\amfs
; Insert the path to the game Option directory here (contains OPxx directories)
option=C:\JEUX\Initial D Zero V 2.11\opt
; Create an empty directory somewhere and insert the path here.
; This directory may be shared between multiple SEGA games.
; NOTE: This has nothing to do with Windows %APPDATA%.
appdata=C:\SEGA APPDATA

[dns]
; Insert the hostname or IP address of the server you wish to use here.
; Note that 127.0.0.1, localhost etc are specifically rejected.
default=192.168.1.103

[ds]
; Region code on the emulated AMEX board DS EEPROM.
; 1: Japan
; 4: Export (some UI elements in English)
;
; NOTE: Changing this setting causes a factory reset.
region=4

[netenv]
; Simulate an ideal LAN environment. This may interfere with head-to-head play.
; SEGA games are somewhat picky about their LAN environment, so leaving this
; setting enabled is recommended.
enable=1

[keychip]
; The /24 LAN subnet that the emulated keychip will tell the game to expect.
; If you disable netenv then you must set this to your LAN's IP subnet, and
; that subnet must start with 192.168.
subnet=192.168.1.0

[gpio]
; Emulated Nu DIP switch for Distribution Server setting.
;
; If multiple machines are present on the same LAN then set this to 1 on
; exactly one machine and set this to 0 on all others.
dipsw1=1

[aimeio]
; To use a custom card reader IO DLL enter its path here.
; Leave empty if you want to use Segatools built-in keyboard input.
path=

[idzio]
; To use a custom Initial D Zero IO DLL enter its path here.
; Leave empty if you want to use Segatools built-in gamepad/wheel input.
path=

[io3]
; Input API selection for JVS input emulator.
; Set "xinput" to use a gamepad and "dinput" to use a steering wheel.
mode=dinput
; Automatically reset the simulated shifter to Neutral when XInput Start is
; pressed (e.g. when navigating menus between races).
autoNeutral=1
; Use the left thumbstick for steering instead of both on XInput Controllers.
; Not recommended as it will not give you the precision needed for this game
singleStickSteering=0
; Adjust scaling for steering wheel input.
;
; This setting scales the steering wheel input so that the maximum positive
; and minimum negative steering inputs reported in the operator menu's input
; test screen do not exceed the value below. The maximum possible value is 128,
; and the value that matches the input range of a real cabinet is 97.
;
; NOTE: This is not the same thing as DirectInput steering wheel movement
; range! Segatools cannot control the maximum angle of your physical steering
; wheel controller, this setting is vendor-specific and can only be adjusted
; in the Control Panel.
restrict=128

[dinput]
; Name of the DirectInput wheel to use (or any text that occurs in its name)
; Example: TMX
;
; If this is left blank then the first DirectInput device will be used.
deviceName=G27
; Name of the positional shifter to use (or any subset thereof).
; Leave blank if you do not have a positional shifter; a positional shifter
; will be simulated using the configured Shift Down and Shift Up buttons
; in this case.
;
; Can be the same device as the wheel.
;
; Example: T500
shifterName=G27
; Pedal mappings. Valid axis names are:
;
; X, Y, Z, RX, RY, RZ, U, V
;
; (U and V are old names for Slider 1 and Slider 2).
; The examples below are valid for a Thrustmaster TMX.
brakeAxis=Y
accelAxis=V
; DirectInput button numbers to map to menu inputs. Note that buttons are
; numbered from 1; some software numbers buttons from 0.
start=4
viewChg=3
; Button mappings for the simulated six-speed shifter.
shiftDn=
shiftUp=
; Button mappings for the positional shifter, if present.
gear1=9
gear2=10
gear3=11
gear4=12
gear5=13
gear6=14
; Invert the accelerator and or brake axis
; (Needed when using DirectInput for the Dualshock 4 for example)
reverseAccelAxis=0
reverseBrakeAxis=0

-----------------------------------------------------------------------------------------------------------

Link to comment
Share on other sites

 

I need help having same issue as the above person only black screen and buffering symbol. 

I extracted the two 7zip files then installed choco and other stuff too. But, I never once got that error my direct 3d doesn't respond. I tried seeing the miniame installing preparing then after few minutes I think I closed it. Then copied Amfs file but, I don't exactly get what up one directory even means does it mean I have to put those two files in the root directory of the Initial D zero folder? Can someone tell me exactly where I am going wrong my graphics is Nvidia rtx 3050 Laptop. Though steps aren't mentioned do I have to download new sega tools folder and replace the old one even though I just downloaded TP just today.

 

Link to comment
Share on other sites

 
48 minutes ago, Takumik45664 said:

I just downloaded TP just today.

Forget about TP

Use Minime and SegaTools directly

Install Minime, the first time you install it it will download a bunch of needed stuff

Configure segatools.ini correctly

You can find your network settings with ipconfig /all in a DOS box

I recommend to use a static IP address on your PC, so the settings in segatools.ini do not have to be changed when your PC IP address changes, which breaks it

https://pureinfotech.com/set-static-ip-address-windows-10/

Example your PC IP address is 192.168.1.67 then your DNS setting in segatools.ini will be 192.168.1.1

Do not forget to edit correct folder paths in segatools.ini

Do NOT use (sub) folder names with spaces and strange characters, just a simple folder name will suffice IDZERO for example

Remember, progress will not be correctly saved after stage 2 !

 

Edited by Onkel
Link to comment
Share on other sites

 
41 minutes ago, Onkel said:

Forget about TP

Use Minime and SegaTools directly

Install Minime, the first time you install it it will download a bunch of needed stuff

Configure segatools.ini correctly

You can find your network settings with ipconfig /all in a DOS box

I recommend to use a static IP address on your PC, so the settings in segatools.ini do not have to be changed when your PC IP address changes, which breaks it

https://pureinfotech.com/set-static-ip-address-windows-10/

Example your PC IP address is 192.168.1.67 then your DNS setting in segatools.ini will be 192.168.1.1

Do not forget to edit correct folder paths in segatools.ini

Do NOT use (sub) folder names with spaces and strange characters, just a simple folder name will suffice IDZERO for example

Remember, progress will not be correctly saved after stage 2 !

 

Is my hardware good enough to run it and can I get segatools instruction on how to run it? I can't find minime or segatools to download so how can I install minime start.bat inside Teknoparrot Segatools?

Edited by Takumik45664
Link to comment
Share on other sites

 
7 minutes ago, Takumik45664 said:

Is my hardware good enough to run it and can I get segatools instruction on how to run it? I can't find minime or segatools to download so how can I install minime start.bat inside Teknoparrot Segatools?

See the arrow pointing right in the above picture ? :ennuyeux:

Here to make it easier on you :P

http://www.emuline.org/topic/1313-idmacx-jrconfig-jvsemu-spicetools-bemanitools-segatools-etc/

 

Edited by Onkel
Link to comment
Share on other sites

 
2 minutes ago, Onkel said:

See the arrow pointing right in the above picture ? :ennuyeux:

Here to make it easier on you :P

http://www.emuline.org/topic/1313-idmacx-jrconfig-jvsemu-spicetools-bemanitools-segatools-etc/

 

But what about my hardware is it fine to run? Cpu is intel but, gpu is nvidia.

Link to comment
Share on other sites

 
19 minutes ago, Takumik45664 said:

But what about my hardware is it fine to run? Cpu is intel but, gpu is nvidia.

:very-good:

Make sure the game .exe uses the dedicated GPU and not the Intel IGPU

https://support.serato.com/hc/en-us/articles/202305784-Changing-graphics-card-settings-to-use-your-dedicated-GPU-on-a-Windows-computer-

Edited by Onkel
Link to comment
Share on other sites

 
 
Just now, Takumik45664 said:

should I write subfolders like this This PC\DATA D:\IDZERO\opt?

Fine, capital letters does not matter, as long as you use the same folder path in segatools.ini

 

Link to comment
Share on other sites

 
1 minute ago, Onkel said:

Fine, capital letters does not matter, as long as you use the same folder path in segatools.ini

 

I hope this really works another thing do I really need to create an empty folder for one requirement in segatools ini

 

Link to comment
Share on other sites

 
4 minutes ago, Takumik45664 said:

I hope this really works another thing do I really need to create an empty folder for one requirement in segatools ini

 

RTFM the readme ?

Just create folders as instructed, game probably needs it 

Link to comment
Share on other sites

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
  • Create New...