Jump to content

[Arcade PC] Magicians Dead (Taito Type X4)


Recommended Posts

  • Team




Instruction here:



- First patch (and source code) by Ducon :



Here it the first version, full source code included: MAGEIO.7z

Make sure you backup your original MAGIDEIO.dll, then just extract the one from the attached archive into MaDead\BppGame\Binaries\Win64\MAGIDEIO.dll


Hard coded keys for now: 1,2,3,4,5,6 for the buttons 1,2,3,4,5,6. Tab for Start. WASD for the directions.


- Version 2: MAGEIO-v2.7z

- Version 2.1: MAGEIO-v2.1.7z
- Patch Freeplay + English + Nesica Online + All Check OK:  Patch.7z


1. No need for a patched executable anymore. You can just use the dll with the original executable and everything will work. So you can delete your patched executable

2. All inputs are now supported: Test, Service, Coin, etc.

3. There is an input to quit the game easily

4. All inputs can now be configured and remapped. Just edit MAGIDEIO.ini


Just extract MAGIDEIO.ini and MAGIDEIO.dll in MaDead\BppGame\Binaries\Win64

- Last patch version (use Ducon patch v1 by Flybit for JConfig) here.

Edited by 7zxkv
Link to comment
Share on other sites

Merci beaucoup ! :D :D :D


tu sais si le jeu fonctionne si l'on branche le panel original avec ses accessoires (dont le motion sensor qui reconnait la position de ta main droite dans l'espace et qui permet de contrôler la magie en jeu) stp ?

Edited by Kameha
Link to comment
Share on other sites

Great ive got the leap motion and the nunchuck setup and can confirm that they work fine in test menu, however it seems we need a start button as neither leap motion or controller allow the game to start, windows 10 also throws up an 'Application is requesting an updated version of Leap Motion V2 software' despite having the latest version installed, this can be fixed by downloading the 'Orion developer software' from here:





Edited by mozie
Link to comment
Share on other sites

So confirmed keys that work

THANKS @ducon2016

To get in test menu, first press the left shift key, hold, and then also press the right shift key


Arrow up and down keys to navigate

M and , (comma) are the button needed to confirm.

To exit a sub menu, press m and , (comma) toghether, or save the setting. (freeplay)

/ has also a function. (Pull lever)


A DInput joystick also works to navigate the test menu.

Left / right trigger, the LB button and also DPad are used.

Edited by Onkel
Link to comment
Share on other sites

Patch information to get past the nag screen BppGame-Win64-Shipping.exe, offset 84E650, 40 becomes C3.




We do NOT know yet how to make the game start. You can help us by fiddling with the Unreal config and script files if you want to help. You can set free play in the service menu, first option under the last Nesica option. Then change the option before the last to ON.

Edited by ducon2016
Link to comment
Share on other sites

A hotfix for this issue has been released, please update to version 3.2.1 of the Orion software available here: http://www.leapmotion.com/setup

Hey everyone,

With the Windows 10 Fall Creators Update, Microsoft made some changes to how they handle Imaging Devices, changing them to "Cameras." This has resulted in a bug with our software. While we work on a better solution to the problem, here's a quick fix!

Note: Only make this change if you have installed the Fall Creators Update. This will break the software in earlier versions of Windows.

Open up services.msc and pause or stop LeapService

Navigate to your Leap Motion software installation folder and go to the Core Services folder (default C:\Program Files (x86)\Leap Motion\Core Services)

Backup LeapSvc.exe and LeapSvc64.exe in a separate folder

For V2 users, download and unzip https://lm-public.s3.amazonaws.com/cs-resources/v2.3.1_Win10_FallCreator_hotfix.zip into the Core Services folder, replacing LeapSvc.exe and LeapSvc64.exe

Return to services.msc and restart LeapService

Launch a Leap Motion enabled application and test!

If you have any questions, let us know. As an alternative to step 4, you can open up LeapSvc.exe or LeapSvc64.exe and change them manually with a hex editor:

Search for C6 1F DD 6B 0F 81 D0 11 BE C7 08 00 2B E2 09 2F

Replace that with B9 7A 3E CA C3 B4 E6 4A 82 51 57 9E F9 33 89 0F


This is the latest version


Thanks @mozie

Edited by Onkel
Link to comment
Share on other sites

Leap Motion received and works in Magician Dead :very-good:

DInput joystick also works

In two modes ?


https://imgshare.io/image/magician-dead-io.QH8gS digital

https://imgshare.io/image/lm9.QHPlK analogue 

Look at the numbers below the square box

USB I/O board still gives a error in the test menu, because we do not have any fully working USB I/O emulation or patch

Leap Motion test software


Magician Dead test mode


When one holds a hand above the Leap Motion the game attract mode detects it



It detects both hands at once but i can not make a screenshot while ..... :furax:



Now we need to find / assign start :furax:


When one uses a non Leap motion hex patched BppGame-Win64-Shipping.exe


It hangs on the USB I/O board

So that patch removes not only the Leap Motion detection error

One can still get into the test menu, and Leap Motion works in the test menu but the game will not go in attract mode it goes back to the USB I/O error screen


So maybe we need to patch BppGame-Win64-Shipping.exe to get start to work ?

Edited by Onkel
Link to comment
Share on other sites

21 minutes ago, Kobe46 said:

Nice stuff @Onkel

So it seems that the USB I/O either will require patching or some type of emulation in order to get it working.


I wonder if someone might have or can find out what the original USB I/O device used in the original cabinet.

The original cabinet comes with a taito x4 fast i/o, not sure if its compatible with the older jvs i/o boards

Link to comment
Share on other sites

25 minutes ago, mozie said:

Pretty cool, so it seems we need 2 keys, one for start and one for melee

And some buttons are assigned through the USB I/O board ?


Test, service and coin

Test and service are left and right shift or m and , (comma) ?


This is for the control panel

I guess we can assign these keys in DefaultInput.ini 

But not 100% sure what does what .....

Only one edit needed on one location or multiple ?

Add lines ?

- before certain lines ?



Edited by Onkel
Link to comment
Share on other sites

13 minutes ago, mozie said:

I assumed that is for a regular control panel joystick 6 buttons and start.. probably for other Games on the same hardware ..

So we can assume we only need the standard control panel inputs ?

Which arcade games are also Unreal based and use DefaultInput.ini ?


Of any use ?


Edited by Onkel
Link to comment
Share on other sites

5 minutes ago, mozie said:

Really? Then someone has it working.. wonder would this be useful 


Or just patched it out, non working in game

IDmac64 somebody said use this and Jconfig ? :what:

Link to comment
Share on other sites

6 minutes ago, Onkel said:

School of Ragnarok is also Unreal based and use IDMacX ?

iDmacX special SOR: iDmacDrv64_School_of_Ragnarok_2018_10_10.rar

Tekken 7 also ?



I tried to add jconfig it does not work for the I/O out of the box. You need to add the import with CFF Explorer to your .exe. Putting the dll in the folder does not do anything. But again it does NOT work as is. 

Link to comment
Share on other sites

1 hour ago, mozie said:

Really? Then someone has it working.. wonder would this be useful 



To the left the icon is green

I thought  am sure there was a 4th picture with all four checks OK

Edited by Onkel
Link to comment
Share on other sites

29 minutes ago, Onkel said:


To the left the icon is green and it shows Nesica in the middle 

I thought  am sure there was a 4th picture with all four checks OK


Yes I got that, but it does not help unfortunately. Here is the patch info below if you want to try, but again, it does not seem to help.

Edited by ducon2016
Link to comment
Share on other sites

8 minutes ago, Onkel said:

So this one patch to "emulate" network connection or multiple patches to .....


This does nothing, just makes the game believe that Nesica is working. But it is NOT, it was just in progress patch that I used to debug. That is why I did not share it, it is a distraction.

Edited by ducon2016
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...