Jump to content

Extracted Sega Chihiro ROMs


Harry99710
 Share

Recommended Posts

1 hour ago, Onkel said:

@Progman

Why do you not use the link from post one ?

Those are already file / folder structure 

https://mega.nz/folder/AlZSTYbQ#8ExIFZonhTeJTSLxThWzPQ

https://imgshare.io/image/screenshot-2021-10-16-13-49-06.pgjs1u

 

What files do you use which are bin/cue , link ?

 

Because My redump set has one more chihiro game (mahjong) that is not in post one and i prefer to run games from redump set.

I downloaded it from the late Pleasuredome tracker. The site does not exist anymore.

Anyway, whatever, i use the games from post one for now and emuline is awesome emulation site, so i tried to run some .xbe files of games from post one and only VC3 seem to run with no error messages and it runs smooth. :)

Ghost Squad for example, gives this error:

image.png.826be527125c440a9443da3a40cdddf0.png

 

Edited by Progman
Link to comment
Share on other sites

3 minutes ago, Progman said:

Because My redump set has one more chihiro game (mahjong) that is not in post one and i prefer to run games from redump set.

I downloaded it from the late Pleasuredome tracker. The site does not exist anymore.

Anyway, whatever, i use the games from post one for now and emuline is awesome emulation site, so i tried to run some .xbe files of games from post one and only VC3 seem to run with no error messages and it runs smooth. :)

Ghost Squad for example, gives this error:

image.png.826be527125c440a9443da3a40cdddf0.png

 

play with xemu

Link to comment
Share on other sites

1 hour ago, Progman said:

I tried to run with xemu but the games won't load not in .iso form and not in .xbe form, how to run?

I guess not, because the game looks for all the hardware in a genuine arcade cabinet, I/O board, security dongles et cetera 

Link to comment
Share on other sites

  • 10 months later...
On 4/23/2019 at 12:47 AM, Harry99710 said:

I can get cxbx to boot outrun 2 beta but it has "minor graphical issues". i've seen VC3 running fine on cxbx and ollie king has been shown working.

Other games get stuck on a black screen or JVS error

outrun2.png

Looks to me like nowadays CxBx has ironed out most of the graphical bugs by now, except for the slightly broken shadow under the car, and Xemu runs it mostly correctly but is slower and can possibly cut off the track after the 1st stage. This is certainly better than how those emulations went previously though...

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
On 10/16/2021 at 4:31 PM, Progman said:

I tried to run with xemu but the games won't load not in .iso form and not in .xbe form, how to run?

I have the same problem, downloaded the extracted Ghost Squad ROM from first post and tried to build a working .xiso file for Xemu with extract-xiso.exe (and other tools) but these image are not accepted by Xemu, showing "Please insert an XBOX disc". Apparently july2779 got it working but won't tell us how.

 

Has anyone a Ghost Squad image that works in Xemu? :)

Link to comment
Share on other sites

14 hours ago, autositzer said:

I have the same problem, downloaded the extracted Ghost Squad ROM from first post and tried to build a working .xiso file for Xemu with extract-xiso.exe (and other tools) but these image are not accepted by Xemu, showing "Please insert an XBOX disc". Apparently july2779 got it working but won't tell us how.

 

Has anyone a Ghost Squad image that works in Xemu? :)

AFAIK you need a specific BIOS file for the arcade games to boot on Xemu, I'll find mine and send it here.

 

Not using that BIOS file would just give you the "Please insert an XBOX disc..." message, similar to this screenshot:
image.png.3f2f1aa583fc12be3665629a2f1221e9.png

Link to comment
Share on other sites

Thanks, that was a good hint! I found this thread, which was very helpful. Now I got Ghost Squad running but there were two other obstacles: vsg.xbe has to be renamed to default.xbe (actually this results in the "Please insert an XBOX disc" error) and tex_common.bin has to be removed (otherwise Xemu will get stuck at the AM2 logo) before creating the .xiso with the tool of your choice (I used C-Xbox). Apparently patching the XBE file is not required.

 

However, the game does not yet run smoothly as the FPS drop from time to time. I tried different BIOS versions and XBE patch on/off with latest Xemu.

Edited by autositzer
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...