Jump to content

[Arcade PC] Puzzle & Dragons Battle Tournament (Taito Type X3)


Recommended Posts




A TTX touchscreen game, requires jconfig to launch so make sure to download that first, also requires a modified debugging exe. once the game loads you have to press t to get to the test menu and click the 8th option and set the option which says off to on.

exit from test mode and wait for the game to get to the title screen and click the mouse to start, the game is a touchscreen game so it's played with the mouse

Game data: https://mega.nz/#!g6ZwhCaK!2swmBV4xuwQ_CbXyZbJ-U_e4rXryO8S-E-jIM23yNlE

Modified debugging exe: https://mega.nz/#!k2wxERpA!ke7uShRjD7ut8B3ufbuENJ8est8KPnlROU6lSrpa29A

(miroir: https://mega.nz/#!Vl0hSRjB!2swmBV4xuwQ_CbXyZbJ-U_e4rXryO8S-E-jIM23yNlE
Patch: https://mega.nz/#!k2wxERpA!ke7uShRjD7ut8B3ufbuENJ8est8KPnlROU6lSrpa29A)

Jconfig: http://8ch.net/1cc/res/3285.html

â–¶tac France 08/16/17 (Wed) 14:24:19 No.3397>>3399

it's Ma Dolomiti Dragon Solazur Kingdom -Puzzle & Dragons Battle Tournament ? on ttx3?


APPARENTLY is a touch screen game with F8 you insert credits but do not know the button to start , is playable with the mouse





Edited by 7zxkv
Link to comment
Share on other sites

  • Team

Et la source: http://8ch.net/1cc/res/3396.html

J'ai vu ca tout à l'heure, ca en fait le premier jeu TTX3 disponible, ca me parait étonnant mais bon vu qu'il est porté un peu partout il y a peut etre pas de vraie protection ou au contraire une faille est présente du au multi portage, bref aucune idée, c'est étrange attendons d'en savoir plus.

Link to comment
Share on other sites

  • Team

PD Debug

It hides the obstructive debug display etc. in the game screen.
Copy "d_game_nonag.exe" and "iDmacDrv32.dll" in this archive to the game folder (JConfig.exe is not used).
* Even if you do not use this file, it can be hidden from page 5 "Operation information" of F2 Debug Menu.
* Edit the following items in "Game folder \ Data \ System \ Config \ Config.csv" for resolution change etc.

In case of FullHD
[Screen] ,,

Easy starting method.
â‘  Please press "T" key on the No Loading screen ("Debug Top Menu" will be displayed if not pressing "T" key)).
â‘¡ When the TEST MODE screen appears, please press "Move on cursor".
â‘¢ When game screen is displayed please press "F8" key and input credit (It is possible to set free play from Test Mode.)
â‘£ When the title screen is displayed, please press the "left button" of the mouse to start the game.

Operation (partial)
F2: Debug Menu
F5: Debug Top Menu
F8: Coin
T: Test Mode
Up: Select Switch
Enter: Enter Switch
Link to comment
Share on other sites

I would need a tutorial on how to play this card game :)


apparently you must choose some cards but i can't choose them with the mouse


is there a tutorial to play this game with strategies and more ?

Link to comment
Share on other sites

Actually seems like a pretty fun game. Unfortunately with no English it's damn near impossible to play. Is there a way to turn off the Nesica portion of the game? Another helpful aspect would be being able to see the mouse cursor as it moved, because emulating the touch screen is a little tricky. All the same, pretty damn cool to see.

Link to comment
Share on other sites

  • 1 month later...
  • 9 months later...
Guest linglang

Nice game, worked fine for a few days, but now I get this error, specific to this game.


The Direct3D device has a non-zero reference count, meaning some objects were not released.

(Edit: After a few days, it decided to run the game, again. It works. But when I stop the game I get the same above error).


When the game "decides not to run".

It hangs on loading, on the first few moments of the loading screen, it loads a little bit and hangs.

Debug screen is running, and I can press F8 to up the credit.

All other games work fine, as far as I know nothing has changed in the last few days, blocked Windows updates et cetera.

Only started to use GameLoader All RH 332 for other games.

Anyone else encountered this problem, got a solution ?

I already tried a fresh install, does not help.

Thanks in advance for a solution.


Window$ 10 1803 - NVIDIA GPU


Edited by linglang
Link to comment
Share on other sites

  • 1 month later...
  • 10 months later...
  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...