Jump to content
sky2310

[Arcade PC] Star Wars: Battle Pods (Namco System ES3)

Recommended Posts

36 minutes ago, Safur said:

I am interested for your script.

Thanks ūüėä

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

here u go my friend ... just put in the tp root folder and set it to run as admin ... and i only tested it on win 10 ..

it does a proper auto hide taskbar and the game will start in fullscreen (1080p) and on esc u will exit the game and the taskbar will be restored as usual

Share this post


Link to post
Share on other sites

Apres la maj, les controls sont bons et plus inversé, le test mode sauvegarde, par contre toujours ces dossiers merdiques à la racine d'un DD

Share this post


Link to post
Share on other sites
1 hour ago, mamefan2018 said:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

here u go my friend ... just put in the tp root folder and set it to run as admin ... and i only tested it on win 10 ..

it does a proper auto hide taskbar and the game will start in fullscreen (1080p) and on esc u will exit the game and the taskbar will be restored as usual

Thanks for this , just set it to run thru rocketlauncher on my arcade and it works great !

Share this post


Link to post
Share on other sites
Il y a 1 heure, Trymado a dit :

Apres la maj, les controls sont bons et plus inversé, le test mode sauvegarde, par contre toujours ces dossiers merdiques à la racine d'un DD

 

 

no, impossible to start a game since the last update ....

 

i use win 10. ....  :gene:

 

 

EDIT : OK! i found!   we must set freeplay to ON in test menu (coin option)  ^_^

Edited by ginzu

Share this post


Link to post
Share on other sites
4 minutes ago, ginzu said:

 

 

no, impossible to start a game since the last update ....

 

i use win 10. ....  :gene:

when its on freeplay .. u just need to press the fire button

Share this post


Link to post
Share on other sites
4 hours ago, mamefan2018 said:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

here u go my friend ... just put in the tp root folder and set it to run as admin ... and i only tested it on win 10 ..

it does a proper auto hide taskbar and the game will start in fullscreen (1080p) and on esc u will exit the game and the taskbar will be restored as usual

Good job my friend, but here my game is muted, is it possible to correct this?

Share this post


Link to post
Share on other sites
13 hours ago, myarcade said:

 

i managed to get sound now, but the controls are a bit messed up, start isnt start and it exits the game?

 

cant get full screen no matter what i try??

The controls/input are not working with Xbox 360 gamepad on the very latest TP update. Anyone else noticed this? Is there a fix?

Share this post


Link to post
Share on other sites
Just now, arcade_power said:

The controls/input are not working with Xbox 360 gamepad on the very latest TP update. Anyone else noticed this? Is there a fix?

 

on the discord they say it was broken b4 the update and now its fixed after the update :gene: is xinput ticked ?

Share this post


Link to post
Share on other sites
1 minute ago, EmuAl said:

 

on the discord they say it was broken b4 the update and now its fixed after the update :gene: is xinput ticked ?

yes, I always have xinput ticket, but no dice. Tried the game on TP v237. It worked just fine yesterday before todays update.:gene:

Share this post


Link to post
Share on other sites
27 minutes ago, arcade_power said:

The controls/input are not working with Xbox 360 gamepad on the very latest TP update. Anyone else noticed this? Is there a fix?

 

yeah you are right no controls with xbox 360 controller, and i still get the camera error..

 

update, as @ginzu posted you need to get into the test menu and set free play to on and then controls work and seem to be fixed.. 

 

still get the camera error message but that dont affect the game.. 

 

 

Edited by myarcade

Share this post


Link to post
Share on other sites
28 minutes ago, myarcade said:

 

yeah you are right no controls with xbox 360 controller, and i still get the camera error..

 

update, as @ginzu posted you need to get into the test menu and set free play to on and then controls work and seem to be fixed.. 

 

still get the camera error message but that dont affect the game.. 

 

 

Thanks for helping! Will try to set the game to free play and try again!:very-good:

Share this post


Link to post
Share on other sites

Le contr√īle pour freiner a √©t√© ajout√©? On en a besoin dans la mission 3 lorsqu‚Äôun soldat saute sur notre v√©hicule ou alors j‚Äôai pas compris comment le virer‚Ķ

Assez déçu de ne plus pouvoir mettre des crédits et être obligé d’être en freeplay. J’espère que ça sera corrigé 

Edited by Safur

Share this post


Link to post
Share on other sites
1 hour ago, arcade_power said:

Thanks for helping! Will try to set the game to free play and try again!:very-good:


weird, yesterday ONLY xinput controls worked which was an issue for me since I use a keyboard encoder with my arcade cabinet. I’ve not updated or tried yet today but does directinput/keyboard work in the latest version?

 

Share this post


Link to post
Share on other sites
10 minutes ago, bojo5150 said:


weird, yesterday ONLY xinput controls worked which was an issue for me since I use a keyboard encoder with my arcade cabinet. I’ve not updated or tried yet today but does directinput/keyboard work in the latest version?

 

 

update and try it out.. ??

your find most people using xbox 360 or ps4 controllers

Share this post


Link to post
Share on other sites

If you're using any mounting software that Touchmote that plays around with Xinput/Directinput drivers - make sure you disable them.

Otherwise, start with a new dump and go from the start to avoid any corrupted files. 

Share this post


Link to post
Share on other sites

im finding i have to keep going into the test menu to set it to freeplay everytime i load the game.. pain in the arse

Share this post


Link to post
Share on other sites

Go to tp discord and you will find answers 

 

There was an oversight and controls aren't broken, we just fixed it to not use the native xinput controls that was conflicting with TP controls

 

You can modify file to have free play constantly 

Edited by Boomslangnz

Share this post


Link to post
Share on other sites

Anyone using Windows 7 64bit? I am seeing an issue with RSLauncher sitting in the upper left of screen and it stays there as a black box during gameplay. It is sitting on top of the gameplay window. If I hit alt + tab off the gameplay screen and back to it the RSLauncher black box goes behind and all is fine, but obviously do not want to have to alt + tab every time I load the game.. This does not happen on my Windows 10 test PC.

 

Otherwise, works perfectly with Win7 with TP fully up to date. I am currently using a PS2 controller with USB adapter. All buttons and controls work including throttle.

 

 

RSLaunchger.jpg

Gameplay.jpg

Share this post


Link to post
Share on other sites
22 minutes ago, Boomslangnz said:

Go to tp discord and you will find answers 

 

There was an oversight and controls aren't broken, we just fixed it to not use the native xinput controls that was conflicting with TP controls

 

You can modify file to have free play constantly 

 

do you think you might be able to do a dome fix patch like you did for mach storm? 

 

thanks :very-good:

Share this post


Link to post
Share on other sites
10 hours ago, seam said:

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

yes its dumped but its private :(

Oh, I thought it was a missing part of the original game.  No biggie then.  I'm just happy with this early xmas present.  Just awesome.  Maybe Terminator Salvation will appear working soon the way things are going with this.  Never know.

 

Share this post


Link to post
Share on other sites

Hey guys....  I am able to set all my buttons for shooting, missles, view change, test menu and all that.  One thing I cannot figure out is, I can only steer left and right.  I am using an xbox controller.  How  an I steer up and down also?  There is no choice in controller settings.  Rumble works which is cool, just the up and down is making me nuts.  Any help would really be appreciated.

Share this post


Link to post
Share on other sites

Je pense et j'espère qu'il doit être possible de rendre le jeu plus rapide et plus fluide pour les gens qui ont des petites configurations.
Comme de baisser la résolution en 720p et de diminuer le filtrage anisotropique et d'autres options gourmande

 

I think and i hope it must be possible to make the game faster and smoother for people with smaller setups.
Like to lower the resolution in 720p and decrease the anisotropic filtering and other greedy options

Share this post


Link to post
Share on other sites

would somebody be able to get this info from discord and post it here??

 

  1 hour ago, Boomslangnz said:

Go to tp discord and you will find answers 

Share this post


Link to post
Share on other sites

Hi, im new to Teknoparrot and have download it just to try out Battle Pod. I have a fresh install of TP and have pointed the TP to where the battle pod exe file is have configured my buttons for the game but when i load Battle Pod the game just sits on the attract screen and no buttons on my pad do anything, how do i start a game (its set to free play)?

 

Share this post


Link to post
Share on other sites
3 minutes ago, Safur said:

The change of the information in Test mode can't be saved with the new version of TP.

 

there is a way to edit the file so that it can be saved.. the info is on discord if you want to go get it and post it here, that would be helpful

Share this post


Link to post
Share on other sites
3 minutes ago, BlockABoots said:

Hi, im new to Teknoparrot and have download it just to try out Battle Pod. I have a fresh install of TP and have pointed the TP to where the battle pod exe file is have configured my buttons for the game but when i load Battle Pod the game just sits on the attract screen and no buttons on my pad do anything, how do i start a game (its set to free play)?

 

 

update, as @ginzu posted you need to get into the test menu and set free play to on and then controls work and seem to be fixed.. 

Share this post


Link to post
Share on other sites

Here is the xml file for free play enabled and no sound during attract mode.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites

!Are we supposed to be able to move up and down?  I can only go left and right

Share this post


Link to post
Share on other sites
6 minutes ago, ulysees76 said:

Here is the xml file for free play enabled and no sound during attract mode.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

thanks man, that sorted it!!

if we can get a dome fix, this will be complete :very-good:

Share this post


Link to post
Share on other sites
3 minutes ago, ulysees76 said:

Try pressing Shift+1 and see if it will stay flat. If not, then let me know.
If you want to run 4K, press F11 twice.

 

shift & 1 acts as a zoom, its a bit better. 

f11 twice crashes the game for me..

 

thanks for your help 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×