Jump to content
sky2310

[Arcade PC] Star Wars: Battle Pods (Namco System ES3)

Recommended Posts

@ducon2016 here is what i got with test

 

Microsoft Windows [Version 10.0.18363.535
(c) 2019 Microsoft Corporation. All rights reserved.
C:\WINDOWS\system32>C:\Users\USER\Downloads\test\test.exe
0: 2560
1: 1440
76: 0
77: 0
78: 2560
79: 1440
C:\WINDOWS\system32>
 
I patched SWArcGame-Win64-Shipping.exe both manually and with noob patcher but i still get 1920x1080 screen with desktop underneath
Edited by eathearty1
typed windows version no wrong

Share this post


Link to post
Share on other sites

Nice work as always ducon! The patch fixes the win toolbar issue (so I don't have to set it to auto-hide each time I play in fullscreen). Sweet!

Share this post


Link to post
Share on other sites
Il y a 17 heures, ducon2016 a dit :

Ok I found the issue, but cannot verify 100% since I do not have a high res expensive monitor.

 

Try to patch the original exe with this

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

You can find the NoobPatcher here http://www.emuline.org/topic/1251-utilitaires-pour-debutants-noob-tools/

 

Let me know if it works. It actually makes it better for 1920x1080 too, there was an error in my previous patch.

 

For those who want to do it manually in HxD

 

 

 

@ducon2016 

 

Avec noobpatcher jme souviens jamais, on selectionne d'abord le .exe et apres le patch ?

Si c'est le cas, j'ai preparé le exe deja patché, et j''ai rajouté ton nom en remerciement dans le Read-me (erreur de ma part sur la v1)

 

Fix Fullscreen v2:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by Trymado

Share this post


Link to post
Share on other sites
2 hours ago, HanzoHittori said:

Here is my output:

 

0: 1280
1: 1024
76: 0
77: 0
78: 1280
79: 1024

 

Thank you for your help!!

 

Your screen is only 1280 by 1024? If yes I tested and I can see your problem, but not sure I can fix it given the aspect ratio being different.

Edited by ducon2016

Share this post


Link to post
Share on other sites
2 hours ago, eathearty1 said:

@ducon2016 here is what i got with test

 

Microsoft Windows [Version 10.0.18362.535]
(c) 2019 Microsoft Corporation. All rights reserved.
C:\WINDOWS\system32>C:\Users\USER\Downloads\test\test.exe
0: 2560
1: 1440
76: 0
77: 0
78: 2560
79: 1440
C:\WINDOWS\system32>
 
I patched SWArcGame-Win64-Shipping.exe both manually and with noob patcher but i still get 1920x1080 screen with desktop underneath

 

Ok thanks, will keep looking

Share this post


Link to post
Share on other sites
55 minutes ago, ducon2016 said:

 

Your screen is only 1280 by 1024? If yes I tested and I can see your problem, but not sure I can fix it given the aspect ratio being different.

That's the resolution. It's a custom arcade machine with a 4:3 Dell monitor.

Share this post


Link to post
Share on other sites
Il y a 9 heures, Trymado a dit :

 

@ducon2016 

 

Avec noobpatcher jme souviens jamais, on selectionne d'abord le .exe et apres le patch ?

Si c'est le cas, j'ai preparé le exe deja patché, et j''ai rajouté ton nom en remerciement dans le Read-me (erreur de ma part sur la v1)

 

Fix Fullscreen v2:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

 

Juste pour info en archive compact (ou solid) avec winrar ou 7z:

CropImage.png

Ok c'est pas grand chose quand on à la fibre mais quand on a pas et qu'on réup régulièrement les archives (ou qu'on les pompes avec une connexion merdique) c'est pas négligeable :D

Sinon merci à Ducon et à toi pour ce/s patch/s ;)

Share this post


Link to post
Share on other sites
9 hours ago, Trymado said:

Fix Fullscreen v2:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Merci.

Thanks for the effort

But this still does not work at 1920x1200 full screen

Does it work for anyone with a higher resolution than 1920x1080 ?

Share this post


Link to post
Share on other sites
Il y a 3 heures, 7zxkv a dit :

 

Juste pour info en archive compact (ou solid) avec winrar ou 7z:

CropImage.png

Ok c'est pas grand chose quand on à la fibre mais quand on a pas et qu'on réup régulièrement les archives (ou qu'on les pompes avec une connexion merdique) c'est pas négligeable :D

Sinon merci à Ducon et à toi pour ce/s patch/s ;)

 

Effectivement j'ai pas le reflex d'utiliser 7zip

J'ai maj le lien du coup 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by Trymado

Share this post


Link to post
Share on other sites
9 hours ago, petje said:

Merci.

Thanks for the effort

But this still does not work at 1920x1200 full screen

Does it work for anyone with a higher resolution than 1920x1080 ?

 

Nope. I have been looking into it and it requires a lot more than just changing the things I looked at. Unfortunately I will not be able to look into it for a while because of work. Loader AllRH might be the best bet at this stage.

@djexpert might be able to help

 

Edited by ducon2016

Share this post


Link to post
Share on other sites

[edit] Solved! As @Trymado stated on the next messages, I should have replaced the original testmode.xml with the one he provided. [/edit]

 

Hi all, and thanks for all the patches and information shared here!

 

First of all, I've already read all fifteen pages of this topic. ;)

 

I'm running Teknoparrot 1.0.0.264 on Windows 7 64 bits. My GPU is a NVIDIA 1030 GT.

 

When running TP calling "SWArcGame...exe" (wait for it, I know already!), the game runs fine, on full screen, fixed. Just, as expected, with no sounds. I just stated this here to show that the game itself is running.

 

If I call RSLauncher from TP, the RSLauncher stops (with an "access violation" error). If I call RSLauncher directly, I got the "projector error" message, and the application refuses to die.

 

I've already deleted the UnrealEngine3 folder, with no effect. Every .exe involved has admin rights. What else could I try?

 

Thanks in advance!

Edited by fabricionk

Share this post


Link to post
Share on other sites
2 hours ago, fabricionk said:

Hi all, and thanks for all the patches and information shared here!

 

First of all, I've already read all fifteen pages of this topic. ;)

 

I'm running Teknoparrot 1.0.0.264 on Windows 7 64 bits. My GPU is a NVIDIA 1030 GT.

 

When running TP calling "SWArcGame...exe" (wait for it, I know already!), the game runs fine, on full screen, fixed. Just, as expected, with no sounds. I just stated this here to show that the game itself is running.

 

If I call RSLauncher from TP, the RSLauncher stops (with an "access violation" error). If I call RSLauncher directly, I got the "projector error" message, and the application refuses to die.

 

I've already deleted the UnrealEngine3 folder, with no effect. Every .exe involved has admin rights. What else could I try?

 

Thanks in advance!

 

Did you change the working folder and not just the .exe?

Share this post


Link to post
Share on other sites
Il y a 4 heures, fabricionk a dit :

Hi all, and thanks for all the patches and information shared here!

 

First of all, I've already read all fifteen pages of this topic. ;)

 

I'm running Teknoparrot 1.0.0.264 on Windows 7 64 bits. My GPU is a NVIDIA 1030 GT.

 

When running TP calling "SWArcGame...exe" (wait for it, I know already!), the game runs fine, on full screen, fixed. Just, as expected, with no sounds. I just stated this here to show that the game itself is running.

 

If I call RSLauncher from TP, the RSLauncher stops (with an "access violation" error). If I call RSLauncher directly, I got the "projector error" message, and the application refuses to die.

 

I've already deleted the UnrealEngine3 folder, with no effect. Every .exe involved has admin rights. What else could I try?

 

Thanks in advance!

Delete testmode.xml in game folder and copy the original file

Share this post


Link to post
Share on other sites

Bonjour à toutes et tous,

Star Wars est le 1er que j'essaie d'utiliser avec Teknoparrot et j'ai quelques soucis.

J'arrive à lancer le jeu, mais je n'ai pas de son et les boutons de mon pad Xbox One ne fonctionne pas en jeu.

J'ai pourtant configuré cela dans les paramètres.

J'ai lu et vu que d'autres personnes avait eu le même soucis que moi, mais mon anglais étant d'un très faible niveau, je n'ai pas trouvé la solution?

Un grand merci d'avance et mes excuses si la solutions a déjà été postée, mais je ne l ai pas vue.

SI quelqu'un pouvait m'indiquer ce que je dois faire, ce serait vraiment très gentil.

 

Bon dimanche

 

Edited by kalys2002

Share this post


Link to post
Share on other sites

Pareil pour moi impossible d'avoir du son dans le jeu malgré que j'ai enfin réussi a le lancer en plein écran.

Share this post


Link to post
Share on other sites

Je pense que @7zxkv devrait rajouter dans le 1er message que le fichier d'execution à pointer est Launcher\RSLauncher.exe et non SWArcGame-Win64-Shipping.exe

Ca en devient lourdingue de devoir le repeter tous les 5 messages parce que les gens ne prennent pas la peine de lire les messages précédents.

Share this post


Link to post
Share on other sites
Il y a 5 heures, Trymado a dit :

Delete testmode.xml in game folder and copy the original file

testmode.xml is the original file, dating from 2014. I haven't messed with it.

Share this post


Link to post
Share on other sites
il y a 18 minutes, Trymado a dit :

Je pense que @7zxkv devrait rajouter dans le 1er message que le fichier d'execution à pointer est Launcher\RSLauncher.exe et non SWArcGame-Win64-Shipping.exe

Ca en devient lourdingue de devoir le repeter tous les 5 messages parce que les gens ne prennent pas la peine de lire les messages précédents.

 

Citation

Just, as expected, with no sounds. I just stated this here to show that the game itself is running.

 

Bonjour Trymado, je suis d'accord avec votre sugestion. Mais ce n'était pas mon cas: j'ai dit que je réussi de lancer le jeu avec SWArcGame...exe seulement pour démontrer que le jeu lui-même fonctionne, et que le problème, je crois, serait quelque chose avec le lanceur. Comme je dit, j'ai déjà lu toutes les pages :). Merci!

Edited by fabricionk

Share this post


Link to post
Share on other sites
Il y a 8 heures, ducon2016 a dit :

 

Did you change the working folder and not just the .exe?

 

I'm sorry but I didn't get this. Do I have to change the working folder? I just pointed to RsLauncher where it already was. Just in case, I've searched again all instructions on this post, but failed to find anything related to changing a working folder.

 

Just for information, I'm calling from TP "Launcher\RsLauncher.exe"; the "SWArcGame...exe" is still on its "Binaries/Win64" folder. Should I move one of them? Change a path inside some XML or INI file?

Edited by fabricionk

Share this post


Link to post
Share on other sites
Le 05/01/2020 à 15:38, fabricionk a dit :

testmode.xml is the original file, dating from 2014. I haven't messed with it.

 

 

Remplace le par celui ci

Edited by Trymado

Share this post


Link to post
Share on other sites

@iAno

You have to link the RSLauncher in Teknoparrot and not the SWArcGame-Win64-Shipping.exe. Then the sound also works.

Share this post


Link to post
Share on other sites
Il y a 1 heure, Trymado a dit :

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Remplace le par celui ci

Bonsoir Trymado,

 

J'ai une question à te poser par rapport au mapping de la manette Xbox.

Y a-t-il une solution pour avoir le brake à la manette ? Sur TP je pense que ce n'est pas possible pour l'instant vu que la fonction n'est pas présente par contre sur Jconfig la fonctionne existe mais ça ne fonctionne pas ?

Share this post


Link to post
Share on other sites
Il y a 2 heures, Trymado a dit :

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Remplace le par celui ci

 

Ça marche! Merci beaucoup!

Share this post


Link to post
Share on other sites

But I also have a question. Is there a way to invert the Y axis? I don't get along well with the controls.

 

Mais j'ai aussi une question. Existe-t-il un moyen d'inverser l'axe Y? Je ne m'entends pas bien avec les commandes.

 

Edited by ichich56

Share this post


Link to post
Share on other sites
Il y a 3 heures, Trymado a dit :

Je pense que @7zxkv devrait rajouter dans le 1er message que le fichier d'execution à pointer est Launcher\RSLauncher.exe et non SWArcGame-Win64-Shipping.exe

Ca en devient lourdingue de devoir le repeter tous les 5 messages parce que les gens ne prennent pas la peine de lire les messages précédents.

 

Un tout, TOUT GRAND MERCI.

Maintenant tout fonctionne!!!

Quel jeu.

 

Kalys

 

 

Edited by kalys2002

Share this post


Link to post
Share on other sites
il y a 33 minutes, ichich56 a dit :

But I also have a question. Is there a way to invert the Y axis? I don't get along well with the controls.

 

Mais j'ai aussi une question. Existe-t-il un moyen d'inverser l'axe Y? Je ne m'entends pas bien avec les commandes.

 

hello

Pour inverser l axe Y j utilise UCR

 

Share this post


Link to post
Share on other sites
il y a une heure, Daytona91 a dit :

Bonsoir Trymado,

 

J'ai une question à te poser par rapport au mapping de la manette Xbox.

Y a-t-il une solution pour avoir le brake à la manette ? Sur TP je pense que ce n'est pas possible pour l'instant vu que la fonction n'est pas présente par contre sur Jconfig la fonctionne existe mais ça ne fonctionne pas ?

Sur la derniere maj il me semble que ca ete fixé, non ?

Share this post


Link to post
Share on other sites
il y a 16 minutes, Trymado a dit :

Sur la derniere maj il me semble que ca ete fixé, non ?

Apparemment ça n'a pas été fixé sur la dernière maj TP, impossible de mapper le brake.

Share this post


Link to post
Share on other sites
il y a 33 minutes, maximumstyle a dit :

hello

Pour inverser l axe Y j utilise UCR

 

Bonsoir,

Qu'est-ce que tu entends par UCR ?

Share this post


Link to post
Share on other sites

Guys I just wanted to ask again as all the previous discussion over the past few pages on this subject have just got too confusing :(

 

Using JConfig (Not Teknoparrot) is there now a way to play the game fullscreen at 2560x1440p using a modified .exe?

 

I downloaded the modified 'SWArcGame-Win64-Shipping.exe' that was posted on here a few pages back but when I run RSLauncher.exe the game is still displayed at 1920x1080p (And yes I did open HxD to check that offset: 9DE4BA was changed from '74' to 'EB')

 

Has anyone managed to get the game working in 'fullscreen mode' in either 1080p or 1440p using JConfig and can share the files needed here please?

 

I don't want to run 3rd party utils that hide taskbars\change the windows desktop resolution etc and just want the game to take up the whole of the screen when I play it!

 

Thanks in advance :)

Edited by POOTERMAN

Share this post


Link to post
Share on other sites
58 minutes ago, POOTERMAN said:

Guys I just wanted to ask again as all the previous discussion over the past few pages on this subject have just got too confusing :(

 

Using JConfig (Not Teknoparrot) is there now a way to play the game fullscreen at 2560x1440p using a modified .exe?

 

I downloaded the modified 'SWArcGame-Win64-Shipping.exe' that was posted on here a few pages back but when I run RSLauncher.exe the game is still displayed at 1920x1080p (And yes I did open HxD to check that offset: 9DE4BA was changed from '74' to 'EB')

 

Has anyone managed to get the game working in 'fullscreen mode' in either 1080p or 1440p using JConfig and can share the files needed here please?

 

I don't want to run 3rd party utils that hide taskbars\change the windows desktop resolution etc and just want the game to take up the whole of the screen when I play it!

 

Thanks in advance :)

 

My patch only works for 1920x1080 and lower resolutions with the exact same aspect ratio. It does NOT work for higher resolutions, and for differing aspect ratios unfortunately. For those I recommend using different patches/solutions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×