Jump to content
Harry99710

[Arcade PC] Steel Chronicle Victroopers (Konami)

Recommended Posts

I guess this is my first post here, thought I have made another one somewhere else... oh well.

 

Thanks to everyone who made this game playable, my little contribution is bypassing the need to create a batch file (.bat) to run the game using Spice Tools. Since EA Server Tool can be loaded using a program arguement, there isn't any need to create a batch file instead you can use a program shortcut instead. Create a program Shortcut by right clicking Spice.exe and then adding -ea to the end of the Target: section, make sure you press space after the end of the directory listing.

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

If there's interest for it, I can edit a short video setting the game up with Spice Tools... Haven't really looked at RH Loader yet.

Edited by athrun1234

Share this post


Link to post
Share on other sites
17 hours ago, rdan_85 said:

It works by changing the system locale to Japanese in Region and Language - Administrative.

Well hot damn, that sure made the game playable beyond the tutorial and restored the missing Japanese text.

I can confirm the game works via a Japanese system locale or using Locale Emulator and using a modified application profile but you may experience occasional freezes or crashes.Thanks for sharing with us Harry and everyone involved.

If this doesn't work for anyone else, I apologize but keep on trying! ~Inari. 

image.png.9491836a2203216f79d29da763e17c4d.png

 

Share this post


Link to post
Share on other sites
4 hours ago, Inari said:

Well hot damn, that sure made the game playable beyond the tutorial and restored the missing Japanese text.

I can confirm the game works via a Japanese system locale or using Locale Emulator and using a modified application profile but you may experience occasional freezes or crashes.Thanks for sharing with us Harry and everyone involved.

If this doesn't work for anyone else, I apologize but keep on trying! ~Inari. 

image.png.9491836a2203216f79d29da763e17c4d.png

 

from where we can download this tool Legui ?

 

Share this post


Link to post
Share on other sites
2 hours ago, spiderzsoft said:

from where we can download this tool Legui ?

 

Here ?

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Share this post


Link to post
Share on other sites
4 hours ago, linglang said:

Here ?

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Yeah that's the one!

Share this post


Link to post
Share on other sites

i made a autohotkey (ahk) script to launch victrooper with the locale emulator and close with escape-key.
 

Zitat

 

run, "C:\Tools\Locale Emulator\LEProc.exe" -run "D:\Steel Chronicle VicTroopers Ver. 3.9\contents\spice.exe"

Esc::
    WinKill, Graphics
    ExitApp
return

 

 

you only have to change the locale emulator path & victroopers path to your path.

 

sorry for my bad english ;-)

Share this post


Link to post
Share on other sites
12 minutes ago, adenin said:

the second vic.002 file cannot be extracted, is it only me?

???

What do you mean ?

Extract in sequence with .001 

So click the .001 file and the extraction program will extract the .002 in sequence automatically

 

Share this post


Link to post
Share on other sites
31 minutes ago, Onkel said:

???

What do you mean ?

Extract in sequence with .001 

So click the .001 file and the extraction program will extract the .002 in sequence automatically

 

i did that, just during the extraction, the 2nd part wasn't some how mentioned. And where can i find the spice tools/.exe?

Share this post


Link to post
Share on other sites
15 minutes ago, adenin said:

i did that, just during the extraction, the 2nd part wasn't some how mentioned. And where can i find the spice tools/.exe?

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Copy spicecfg.exe and spice.exe to root of game

Configure spicecfg.exe

Check you .ini files and change 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 to https://localhost:8080 ?

Use this to start the game

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by Onkel

Share this post


Link to post
Share on other sites

You are the man Onkel, i cannot locate the,ini file, where is it? The game starts and then it closes, is it.

Edited by adenin

Share this post


Link to post
Share on other sites
20 hours ago, Onkel said:

Sorry my fault ......

.xml files in your prop folder.

But first try it without editing.

 

Hi, the game starts (windows starts loading script) and it crashes in a few seconds, with AlRh loader i am gettin error messae, can you please advise?

Share this post


Link to post
Share on other sites
9 minutes ago, adenin said:

Hi, the game starts (windows starts loading script) and it crashes in a few seconds, with AlRh loader i am gettin error messae, can you please advise?

Here my game root files, backup yours and overwrite

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
13 minutes ago, adenin said:

Thanks, but it happens exactly the same, window closes immediately. How can i change the resolution from the spice.

Not that i know off

You got another problem.

You got MS visual C++ 2005 up to 2019 installed ?

Direct X 9C ?

NVIDIA gpu ?

 

Share this post


Link to post
Share on other sites
2 minutes ago, Onkel said:

Not that i know off

You got another problem.

You got MS visual C++ 2005 up to 2019 installed ?

Direct X 9C ?

NVIDIA gpu ?

 

Well everything up until the gpu, i have a ATI,didn't know nvidia is required.

Share this post


Link to post
Share on other sites
On 9/29/2019 at 9:47 PM, linglang said:

@rdan_85

How can one load spice.exe with GL 337, with the -ea parameter, or how can one start a .bat file with GL 337 ?

 

Is this the solution ?

image.png.4678afc5601a1f287ca626d9dc2941e6.png

 

With these settings I see this and GL stops.

image.png.f1579d6ae097c490435bc94d9b49c233.png

What parameters in what files need to be edited, because there is no ea3-config.xml in the Steel Chronicle Victroopers folder.

 

When I add <services __type="str">http://localhost:8080/</services> to eamuse-config.xml and start eaLocalserver, GL tries to boot but crashes.

Hi did you manage to run the game and were you able to access the settings from the screenshot in rh loader, mines are greyed out?

Share this post


Link to post
Share on other sites
16 hours ago, adenin said:
On 9/29/2019 at 8:47 PM, linglang said:

When I add <services __type="str">http://localhost:8080/</services> to eamuse-config.xml and start eaLocalserver, GL tries to boot but crashes.

 

Look for the same string in other .xml files

On which version Windows ? 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 try this in the /dev folder

Share this post


Link to post
Share on other sites
5 hours ago, Onkel said:

Look for the same string in other .xml files

On which version Windows ? 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 try this in the /dev folder

Checked in the xml files, no such string, added the nvram, same crash, btw i am with win7.

Share this post


Link to post
Share on other sites
2 hours ago, adenin said:

btw i am with win7.

I think that is the problem, on win 10 here works fine.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×