Jump to content

[Arcade PC] Target Terror Gold (RawThrills) - Vmware Image


argonlefou
 Share

Recommended Posts

 

 

Hey guys,

 

I made a minimalist VMware image to play Target Terror Gold (linux based arcade game, crypted files where posted here : https://8ch.net/1cc/res/457.html )

I'm not the one who succesfully decrypted those files, all credits goes to him.

 

There's a small configuration utility to choose window style/size and controls (1P mouse,  up to 2 players with Aimtraks) inside the VM.

And a Readme file in the archive with detailed instructions.

 

To make it short, create a new VMware machine (linux, 32 bits) and use the .vmdk disk file as HDD

 

------------------------------

 

Hello tout le monde,

 

Voici une image disque VMware minimaliste que j'ai conçue pour jouer a Target Terror Gold (la version arcade linux dont les fichiers ont été posté ici :  https://8ch.net/1cc/res/457.html )

Je ne suis pas à l'origine du décrypage des fichiers, donc je remercie cette personne qui nous permet aujourd'hui de jouer à ce jeu.

 

Il y a dans l'image un petit utilitaire qui permet de choisir le mode fenetré/plein écran et les controles (souris pour 1 Joueur, jusqu'à 2 joueurs avec Aimtraks)

Et un fichier Readme (en anglais) avec des instructions détaillées

 

En gros, il suffit de créer une nouvelle machine virtuelle VMware (linux, 32 bits) et de choisir l'image .vmdk comme disque dur

 

-------------------------------

 

Download : 

Edited by 7zxkv
titre
Link to comment
Share on other sites

 
 
 
 
 
  • Modo

je veux dire tu a utilisé les 2 liens qui sont sur 1cc ou c'était pas la peine?

ps: dans  le readme: Document:   Star Trek Voyager Arcade ^^

Edited by 7zxkv
Link to comment
Share on other sites

 

je veux dire tu a utilisé les 2 liens qui sont sur 1cc ou c'était pas la peine?

 

Non, je cite juste 1CC pour la source.

Les fichiers postés sur 1CC sont ceux du recovery disk, encryptés et inutilisables tels quels.

 

Ces fichiers ont été decryptés et l'image à télécharger est prête à l'emploi avec ces fichiers, le loader, les livbrairies qui vont bien etc, etc....

Les fichiers sont récupérables dans le répertoire /tt à la racine

Edited by argonlefou
Link to comment
Share on other sites

 
 
 
 

je veux dire tu a utilisé les 2 liens qui sont sur 1cc ou c'était pas la peine?

 

ps: dans  le readme: Document:   Star Trek Voyager Arcade ^^

 

Hahaha ^_^

Le copié/collé de la mort qui tue ... je fais la même chose pour star trek en parrallele ca va arriver sous peu

Link to comment
Share on other sites

 

Il est nul leur Readme!! Impossible à faire, je n'ai pas leur "existing disk" à choisir!

C'est bien gentil de nous donner leur jeu décrypté mais s'ils n'expliquent rien ça ne sert pas à grand chose! Autant ne pas le partager

Link to comment
Share on other sites

 

Il est nul leur Readme!! Impossible à faire, je n'ai pas leur "existing disk" à choisir!

C'est bien gentil de nous donner leur jeu décrypté mais s'ils n'expliquent rien ça ne sert pas à grand chose! Autant ne pas le partager

Le readme et l'image VMware sont de moi, donc c'est à moi qu'il faut se plaindre !

 

Lorsque tu crée une machine sous VMware tu arrives apres 3/4 click à cet écran :

image28.png

Edited by argonlefou
Link to comment
Share on other sites

 

Et bien écoute j'ai pris la même version que la tienne pour VMware et je n'ai pas cette fenêtre...

J'ai installé Ubuntu avec une image ISO mais je crois que ce n'était pas la peine.

Bref j'ai essayé de créer une nouveau Linux mais jamais il ne me propose ça. Je vais dans l'onglet Shared VMs puis "Create a new virtual machine" -> installation typical -> là je choisi Ubuntu Linux 32 bits et après plusieurs Next je n'ai pas d'autres choix que de créer un disque de 20GB. Une fois Linux créé j'arrive à rajouter le disque dur du jeu comme second DD dans Ubuntu, je navigue à l'intérieur mais aucun moyen de le lancer de cette façon...

Je dois louper un truc mais là je ne vois pas.

Link to comment
Share on other sites

 

Alors je suis loin d'être un habitué de VMware pour savoir pourquoi les menus de création ne sont pas les mêmes :-(

 

Ceci dit, si tu arrives a ajouter le vmdk comme un disque suplémentaire, je pense que simplement en supprimant le HDD crée à l'origine et/ou en modifiant l'ordre des port Sata (ou IDE) des disques, tu devrais pouvoir booter sur le disque de target terror

Edited by argonlefou
Link to comment
Share on other sites

 

Alors c'est bon je sais comment faire. En fait lors de la création d'un nouveau système il ne faut pas sélectionner l'installation Typical mais Custom! Et à partir de là il sera possible de choisir le disque dur!

Tu devrais le noter dans le Readme car je me suis fait avoir. J'ai tout mis par défaut comme indiqué dans le Readme.

Lors de la 1er utilisation du jeu comment faire la sélection dans la configuration utility? Je n'ai pas réussi à changer les paramètres. Cela dit le jeu s'est lancé en plein écran et les contrôles marchent bien.

Par contre je n'arrive pas à avoir le son. Ça ne vient pas du jeu car c'est la même chose sous Ubuntu. Quand je test le son ou regarde une vidéo sur youtube je n'ai rien. Pourtant dans Devices et Sound Card j'ai sélectionné manuellement ma carte mais rien. Le click droit sur Sound Card comme mentionné dans le Readme ne fonctionne pas. Une idée?

Voilà l'erreur du son qui apparait:

post-7523-0-56696600-1510271542_thumb.jpg

Edited by Safur
Link to comment
Share on other sites

 
 

Alors c'est bon je sais comment faire. En fait lors de la création d'un nouveau système il ne faut pas sélectionner l'installation Typical mais Custom! Et à partir de là il sera possible de choisir le disque dur!

Tu devrais le noter dans le Readme car je me suis fait avoir. J'ai tout mis par défaut comme indiqué dans le Readme.

Lors de la 1er utilisation du jeu comment faire la sélection dans la configuration utility? Je n'ai pas réussi à changer les paramètres. Cela dit le jeu s'est lancé en plein écran et les contrôles marchent bien.

Par contre je n'arrive pas à avoir le son. Ça ne vient pas du jeu car c'est la même chose sous Ubuntu. Quand je test le son ou regarde une vidéo sur youtube je n'ai rien. Pourtant dans Devices et Sound Card j'ai sélectionné manuellement ma carte mais rien. Le click droit sur Sound Card comme mentionné dans le Readme ne fonctionne pas. Une idée?

Voilà l'erreur du son qui apparait:

attachicon.gifSans titre.jpg

 

Merci pour l'info, en effet je n'ai pas du tilter que le mode custom n'était pas sélectionné par defaut.

Je vais re-uploader le zip dans la journée avec le correctif.

 

Pour les paramètres, le déplacement se fait avec les flèches directionnelles et la validation avec ENTER.

Si tu as besoin de relancer l'utilitaire de configuration, ouvres une console avec CTRL+ALT+F3 (ou tu tapes [X] pour quitter le jeu et afficher une console) et lance la commande : tt-config

 

Pour le son le problème semble être exactement celui que j'ai rencontré.

Si le clic droit n'a pas marché, il faut trouver comment ouvrir les paramatres son de ton windows (ca change selon les windows et le mode d'affichage du panneau de confguration)

Moi c'est Demarrer -> Panneau de configuration -> Son

Ca peut être Demarrer -> Panneau de configuration -> Materiel et audio -> Son

Le but est d'avoir cette fenêtre pour continuer la manip du Readme (onglet enregistrement, clic droit dans le vide, etc....):

04fig34.jpg

 

Link to comment
Share on other sites

 

 

Thanks Argon! This game is way fun. 

 

https://i.imgur.com/rKYF3Xp.jpg

 

I keep getting this error where the loading game screen shows up but is cut out and then it just freezes.  Any thoughts? 

 

 

:blink: Not at all

All I can think of is,try to close the game with the [X] button (this will bring a terminal) and then run the following command : ./tt_daemon.sh

This should run the game with a lot of debug text visible...maybe by sharing the picture we'll see something interresting

Link to comment
Share on other sites

 

:blink: Not at all

All I can think of is,try to close the game with the [X] button (this will bring a terminal) and then run the following command : ./tt_daemon.sh

This should run the game with a lot of debug text visible...maybe by sharing the picture we'll see something interresting

 

Thanks. Here's a pic of the debug text.  Thoughts?

 

https://i.imgur.com/vqJaa6s.jpg

Link to comment
Share on other sites

 
 

Not the slightest clue..I've sent you a message

Sorry to bug you with this could this possibly work for VirtualBox instead?

Because I already have that set up with my other images.

 

20171110165337.jpg

 

Cheers for any help.

Link to comment
Share on other sites

 

Unfortunately no. VBox would have been better, VMWare caused me a lot of troubles

 

The game is not loading all textures and crashes quickly.

My guess is because VBox has not a good opengl support wheras VMware can do it.

 

But I may be wrong....I'm unfortunatelly not a graphic developper :-(

Link to comment
Share on other sites

 
 

Déformé dans quelle style ?

 

Le seul paramètre à ma connaissance est la ligne "max_intrate=1000" dans le fichier "/usr/lib/oss/conf/osscore.conf"

La valeur par defaut est 100, mais ça cause un léger retard pour le son.

La valeur 1000 supprime le délai, mais peut utiliser trop de ressources (suivant le CPU) et faire un son pourri

 

pour modifier le fichier, quitte le jeu avec X et utilise la commande suivante : nano /usr/lib/oss/conf/osscore.conf

CTRL+O pour sauvegarder

CTRL+X pour fermer le fichier

 

 

Link to comment
Share on other sites

 

Not the slightest clue..I've sent you a message

 

it was a bit of a pain but I finally got it working.  Just a few questions.

 

1.How do you remove the task bar up on top (see pic below)? It's a bit annoying being there in fullscreen.  Not sure how to remove it.

2. How do you get back in configuration utility settings? The reason I ask is because when I first played it was fullscreen and fullscreen worked fine.  But when I play a second time it was in windowed mode.  In your readme file it tells you how to go back to utility settings but I'm not sure what you mean in the settings.  Could you explain more how to get to utility settings?  Sorry, I'm not understanding your directions.

3.  Is there a way to do custom crosshairs? The ones they have in game are just a plus sign.  If not, no worries.  Just curious.

Thanks again.  This game is way fun. 

 

 

vHKKMxx.jpg

Link to comment
Share on other sites

 

1.How do you remove the task bar up on top (see pic below)? It's a bit annoying being there in fullscreen.  Not sure how to remove it.

2. How do you get back in configuration utility settings? The reason I ask is because when I first played it was fullscreen and fullscreen worked fine.  But when I play a second time it was in windowed mode.  In your readme file it tells you how to go back to utility settings but I'm not sure what you mean in the settings.  Could you explain more how to get to utility settings?  Sorry, I'm not understanding your directions.

3.  Is there a way to do custom crosshairs? The ones they have in game are just a plus sign.  If not, no worries.  Just curious.

Thanks again.  This game is way fun.

 

1) I think this is (in VMware main window)

Edit -> Preferences  -> Display -> Uncheck "Show Toolbar edge when unpinned in full screen"

You can uncheck everything I guess

 

And make sure you check Autofit guest for both "Autofit" and "Fullscreen" choices on top of that

 

2) The simples way is to press X to quit the game, this will bring a console on screen. Then just type : tt-config

 

3) I don't know for the crosshair, the current ones are just mouse cursor. And I don't think the original game had any crosshair

Link to comment
Share on other sites

 

bon je suis supercontent j'ai réussi à l'installer avec VMmare player 14 (free).

 

Effectivement il ne propose pas de choisir un disque existant de base j'ai donc supprimé celui crée avec la machine virtuel et créé un nouveau disque dur et là il me propose l'option d'utiliser un disque existant.

 

Au premier démarrage les 2 lights guns doivent êtres activés en haut à droites de l'écran sinon il ne sont pas détectés par l' utilitaire de configuration (lors du premier boot) .

 

Pour moi les deux lights guns sont détectés par cet utilitaire mais malheureusement ils ne fonctionnent pas durant le jeu ,bizarre! Le clavier fonctionne par contre.

 

Link to comment
Share on other sites

 
 

Hey,

 

Is there any conflict having both VMWare and Virtualbox on one computer? I already have VB installed running a few games and want to make sure adding VMWare won't mess anything up. :) Thanks.

 

You can safely use both programs :very-good:

 

 

bon je suis supercontent j'ai réussi à l'installer avec VMmare player 14 (free).

 

Effectivement il ne propose pas de choisir un disque existant de base j'ai donc supprimé celui crée avec la machine virtuel et créé un nouveau disque dur et là il me propose l'option d'utiliser un disque existant.

 

Au premier démarrage les 2 lights guns doivent êtres activés en haut à droites de l'écran sinon il ne sont pas détectés par l' utilitaire de configuration (lors du premier boot) .

 

Pour moi les deux lights guns sont détectés par cet utilitaire mais malheureusement ils ne fonctionnent pas durant le jeu ,bizarre! Le clavier fonctionne par contre.

 

J'ai eu ce soucis aussi à diverses occasions, Aimtraks reconnus pour le choix mais non fonctionnels en jeu....je ne sais pas d'où ça vient.

En général lors du reboot de la VM. Lors du 1er démarrage ça fonctionen bien 90% du temps

 

Parfois debrancher, rebrancher l'Aimtrak a suffit, parfois non

Link to comment
Share on other sites

 

Alors le problème est résolu il suffit de cliquer sur le bouton rouge du gun+trigger et les 2 guns sont ainsi reconnus.

 

Cela marche impeccable avec une petite nuance c'est que comme le jeu ne prend pas tout l'ecran cela créé un décalage du curseur.

 

Pendant que je te tiens j'ai une hyper sensibilité du gun dans music gungun2 et même avec le delay cursor sur 4 dans jcconfig cela reste trop sensible,il y a une solution?

J'ai réussi a intégrer quazi tout les jeux de ton Demulshooter (me reste à plancher sur far cry paradise et alien extermination) mais c'est le seul jeu ou je n'ai pas réussi :o(( 

Non seulement c'est trop sensible et en plus Demulshooter ne matche pas dessus.

 

Une dernière chose, même si je t'ai déjà pourri ta boite gmail pour ça, un grand "merci" pour avoir revolutionné le monde du lightgun avec ton programme et pour le travail que tu effectue encore. Grâce à toi des gens comme moi qui ne sont pas du tout informaticien peuvent créer un système dédié au jeu de tir .

Tu m'a permis de réaliser un rêve de gosse et j'ai pour cela j'ai une grande estime à ton égard.

Bon c'est sûr j'ai mis du temps .. :o)

Edited by lempereur290983
Link to comment
Share on other sites

 

it was a bit of a pain but I finally got it working.  Just a few questions.

 

1.How do you remove the task bar up on top (see pic below)? It's a bit annoying being there in fullscreen.  Not sure how to remove it.

2. How do you get back in configuration utility settings? The reason I ask is because when I first played it was fullscreen and fullscreen worked fine.  But when I play a second time it was in windowed mode.  In your readme file it tells you how to go back to utility settings but I'm not sure what you mean in the settings.  Could you explain more how to get to utility settings?  Sorry, I'm not understanding your directions.

3.  Is there a way to do custom crosshairs? The ones they have in game are just a plus sign.  If not, no worries.  Just curious.

Thanks again.  This game is way fun. 

 

 

vHKKMxx.jpg

 

I have the same problem. How have you managed to make it work?

it freezes on the loading screen and the game does not start. Can you help me please?

Edited by joeplay
Link to comment
Share on other sites

 
 

Hey Guys,

 

I got this game going great, except for the sound issue. No matter what I set, the "sound out of range" error occurs. I've followed everything in the readme and this thread.

I am running:

Motherboard : ASUS P8H77-I - Intel H77 Chipset

Audio : Onboard 8 channel + Optical S/PDIF

 

Here is what I see in my sound options, no stereo mix option shows up:

https://imgur.com/jlZAMPB

 

Any help is truly appreciated. Thanks.

Edited by pumpkinrat
Link to comment
Share on other sites

 

Hey Guys,

 

I got this game going great, except for the sound issue. No matter what I set, the "sound out of range" error occurs. I've followed everything in the readme and this thread.

I am running:

Motherboard : ASUS P8H77-I - Intel H77 Chipset

Audio : Onboard 8 channel + Optical S/PDIF

 

Here is what I see in my sound options, no stereo mix option shows up:

https://imgur.com/jlZAMPB

 

Any help is truly appreciated. Thanks.

You may have already tried, but I'm just answering because of your Screen Capture :

Did you look on the recording tab ?

Edited by argonlefou
Link to comment
Share on other sites

 
  • 7zxkv featured, unfeatured and unpinned this topic

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
  • Create New...