Jump to content
sky2310

[TUTO] Initial D Stage Zero Arcade - how to setup and play (Nvidia & AMD Cards working)

Recommended Posts

16 hours ago, llll55 said:

if i dont want any lan or online play...what steps i can skip? 

thanks.

You can't skip step, because you need online to save, not to play against other people.

Share this post


Link to post
Share on other sites
On 12/1/2019 at 9:00 AM, leonardombn said:

Unsuccessfully, none of the executed files worked for me.
I set the files to the root of drive k: \ would this be a problem?
Network 192.168.100.3 Sub 192.168.100.0 correct?

 

initialdzero_2.jpg

Cannot tell which Windows version you are on but if you are on 7, there could be issues. 

If you are on Windows 10.

The first error on opening Start.bat from the mimime installation, looks like you are unable to access the package.json location, this could be that you might be missing some dependencies. Have you installed the LTS version of nodes.js and during the installation check box for Chocolatey/other tools to install as well. Could take a bit to install. When finished, make sure you also install the vc_redist_x64.exe, and vs_community.exe; then confirm the permissions on the files for minime folder. Right click, properties, change permissions to be not-read-only.

 

Please confirm that your folders&files in K:\SDFF_1.31.0\ are set to not-read-only. Hard to tell from screenshot. Run as administrator once with the start.bat in K:\SDFF_1.31.0\, you should get the .\inject.exe error and then run it normally and see if it gets the same issue?

 

@subaru052003@yahoo.com.tw @segaoutrun123

That issue is still related to permission and possibly DNS issue. If I remember you changed your local network DNS to 8.8.8.8 and 8.8.4.4. Depends on your network and how you are setup, if you are setup on:

Computer --> router --> Modem: You may have to change your settings on the Router to use 8.8.8.8 and 8.8.4.4 for DNS.

Computer -->Router/Modem(1 device that is both router and modem): You will need to change it on this device to use 8.8.8.8 and 8.8.4.4. The new segatools might help this, but have heard mixed issues with it so this is one of the fixes.

 

Edited by Kobe46

Share this post


Link to post
Share on other sites
On ‎11‎/‎30‎/‎2019 at 11:20 AM, subaru052003@yahoo.com.tw said:

Cannot get accounting info.Cannot get accounting info.Cannot get accounting info.Cannot get accounting info.Cannot get accounting info.Cannot get accounting info.Cannot get accounting info.Cannot get accounting info

check the folders inside SDFF_1.31.0 folder as I found 1 was srill read only untick it and working

so even if folders says they are not read only check them 1 at a time

Edited by segaoutrun123

Share this post


Link to post
Share on other sites
15 minutes ago, segaoutrun123 said:

check the folders inside SDFF_1.31.0 folder as I found 1 was srill read only untick it and working

so even if folders says they are not read only check them 1 at a time

It is possible, but doing it at top level should adjust it. Windows also always reverts the selection back to it when you apply the change. If you open the properties again, it will seem like the files are read-only again. It is how Windows does it. If it missed out on something, it could have been something edited or was copied into the folder prior to your change. But if it is working for you @segaoutrun123 great.

Share this post


Link to post
Share on other sites
14 minutes ago, Kobe46 said:

It is possible, but doing it at top level should adjust it. Windows also always reverts the selection back to it when you apply the change. If you open the properties again, it will seem like the files are read-only again. It is how Windows does it. If it missed out on something, it could have been something edited or was copied into the folder prior to your change. But if it is working for you @segaoutrun123 great.

thanks just glad its working just the keys for up down left right not working with wheel yet :very-good:

Share this post


Link to post
Share on other sites

Ok finally got my game working after a lot of trouble with error 8008 and 8304. For those having similar trouble make sure you :

 

- Once you unticked your read only folders and applied them, go back to SDDF folder, app, package and make sure the start.bat is not in read only (mine stayed read only for some reason).

- Make sure all 3 files mentionned in firewall in sddf/app are allowed on yours.

- DONT run the start.bat in administator as it will make a inject error, run it normally even the first time.

- Running the inject files in administartor or not didnt change anything for me.

- Okay imporant part now and this what mess me up. I always had utorrent running in the background and it was causing trouble to the card saving. Once I quit utorrent, saves are now working fine.

 

I still need to get my wheel going but the game run and saves fines now with xinput. And getting the wheel running should be hard as I already have the value of my buttons on teknoparrot.

 

I'll report back once I get my T300RS alcantara working.

Edited by KimFD3S

Share this post


Link to post
Share on other sites
46 minutes ago, nikogamer233nk said:

Hello, could someone help me with a g25 wheel? gas is always on or brake is always on no matter how i change it.

In segatools.ini

What version of segatools are you using ?

Here the latest version is on the previous page

You set both to 1 ? 

 

; Invert the accelerator axis (Needed when using DirectInput for the Dualshock 4 for example)
; Set these to 1 if your axis are reversed (as in, not pressing the trigger or pedal will brake and accelerate fully, instead of not at all)
reverseAccelAxis=0
; Invert the brake axis (Needed when using DirectInput for the Dualshock 4 for example)
reverseBrakeAxis=0

Edited by petje

Share this post


Link to post
Share on other sites
il y a une heure, petje a dit :

In segatools.ini

What version of segatools are you using ?

Here the latest version is on the previous page

You set both to 1 ? 

 

; Invert the accelerator axis (Needed when using DirectInput for the Dualshock 4 for example)
; Set these to 1 if your axis are reversed (as in, not pressing the trigger or pedal will brake and accelerate fully, instead of not at all)
reverseAccelAxis=0
; Invert the brake axis (Needed when using DirectInput for the Dualshock 4 for example)
reverseBrakeAxis=0

thanks, was using old version

Share this post


Link to post
Share on other sites
il y a 15 minutes, petje a dit :

You can try version 8 of segatools for new steering options and a older version of minime for server functions

IT WORKS!!!! thanks man, but how do i create a character and save, because when i hit start at aime card registration it goes to the not saving game part, you know what i mean?

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, nikogamer233nk said:

IT WORKS!!!! thanks man, but how do i create a character and save, because when i hit start at aime card registration it goes to the not saving game part, you know what i mean?

 

 

1,2 are used in the service menu

3 is insert coin

Press and hold enter when it asks to use a aime card

Share this post


Link to post
Share on other sites
il y a une heure, petje a dit :

1,2 are used in the service menu

3 is insert coin

Press and hold enter when it asks to use a aime card

Do you know why there is like a very big deadzone when using wheel?

Its pretty dificult to control

Also, at what degrees should my wheel be turn at? 540, 250?

Thanks for the help

Share this post


Link to post
Share on other sites

idzio.dll determines the steering the original included version is probably more precise 

250 ?

i have no steering wheel so i can not test

Share this post


Link to post
Share on other sites
il y a 1 minute, petje a dit :

idzio.dll determines the steering the original included version is probably more precise 

250 ?

i have no steering wheel so i can not test

ok, the only thing that bothers me is the deadzone, but i can bear with it

 

Share this post


Link to post
Share on other sites

Hey! Thanks again for releasing all this info! I'm having a issue that I've run out of ideas to regarding the shifter(using a G29). I've noticed it seems to not even matter what I put in in the segattools.ini (perhaps hardcoded like the arrow keys?) for the shift options. The paddles always pick 5/6 gear and the Tri/Square/Sqr/X all goto a specific gear(even if I leave them unbound in segatools.ini)


; Button mappings for the simulated six-speed shifter.
shiftDn=6
shiftUp=7
; Button mappings for the positional shifter, if present.
gear1=
gear2=
gear3=
gear4=
gear5=
gear6=

 

Also the cars always switch back to AT from MT(if I goto a gear itll goto MT for a second or two and then go back to AT). I read earlier in the thread this was caused by autoNeutral=1, however I changed it to autoNeutral=0(assuming 0 is off) however the same thing happens. Cheers!

Share this post


Link to post
Share on other sites

I have the same problem as rabidduck but with a T300 RS it seems the value keep changing each time I boot the game. Like I found a value for Throttle but it was on break, so I switched the value in segatool to throttle but nothing happen in the throttle. Also if I go into test mode in the game and try the input settings, throttle and clutch are never recognized while paddle are recognized as gear 1 and 2 and some other buttons as other gears. No buttons works for up/down gear.

 

Not sure how to set the wheel up, any help is appreciated.

Share this post


Link to post
Share on other sites

@petje Stupid question but if I overwrite the minime folder in C: will I loose my save game ? Or is my save online tied to my ip ?

Share this post


Link to post
Share on other sites
16 minutes ago, KimFD3S said:

@petje Stupid question but if I overwrite the minime folder in C: will I loose my save game ? Or is my save online tied to my ip ?

No it is felica.txt in SDDF_1.31.00/app/package/DEVICE

Share this post


Link to post
Share on other sites
On 12/8/2019 at 10:10 AM, petje said:

No it is felica.txt in SDDF_1.31.00/app/package/DEVICE

Ok thanks, I'm guessing you dont know how to fix the paddle shifting with a t300rs by chance ?

Share this post


Link to post
Share on other sites

hi guys,i got the game all working and fine,but my only problem is the minimap so big and in the middle of the screen.and also the resolution so small when play fullscreen the graphics look so bad.anyone has solution?thanks 

Share this post


Link to post
Share on other sites
3 hours ago, petje said:

game only runs correct at 1920x1080 as far as i know

 

nevermind,i changed the res on initiald.ini and renderer.ini to 1360x768 and works like charm.

do you know how to increase the win point value after winning?pretty hard to grind the level and points :D

Share this post


Link to post
Share on other sites
21 hours ago, asu1235678 said:

 

nevermind,i changed the res on initiald.ini and renderer.ini to 1360x768 and works like charm.

do you know how to increase the win point value after winning?pretty hard to grind the level and points :D

As far as I know there's no cheat or save editor yet for ID0. You'll have to play the game (I know crazy right).

Share this post


Link to post
Share on other sites
12 hours ago, KimFD3S said:

As far as I know there's no cheat or save editor yet for ID0. You'll have to play the game (I know crazy right).

Actually there is. I am not familiar with how to do it, you have to edit the database so that things are unlocked. I know it can be done, like ID8 from what I recall, it is very similar.

 

Someone else might have some more insight, but it is possible to do so.

Share this post


Link to post
Share on other sites
9 hours ago, Kobe46 said:

Actually there is. I am not familiar with how to do it, you have to edit the database so that things are unlocked. I know it can be done, like ID8 from what I recall, it is very similar.

 

Someone else might have some more insight, but it is possible to do so.

You're right, I should have said there's no way to do it right. I've seen people adding different gauge on discord so it can be done but it's quite complicate atm from what I got.

 

Share this post


Link to post
Share on other sites

Heh, so I just learned it on the fly. Understand databases kinda. So here is a quick document on how to change Level, Fame, DPoints and unlock Gauges and cup... I wrote this like 20 minutes ago. Enjoy. This is all from Discord community :D I just compiled what I could find. Might add more later on if I guess feel like searching for more. I only play this seldomly lol.

 

Enjoy.

ID Zero Modify data.docx

Share this post


Link to post
Share on other sites
On 12/8/2019 at 1:46 AM, KimFD3S said:

I have the same problem as rabidduck but with a T300 RS it seems the value keep changing each time I boot the game. Like I found a value for Throttle but it was on break, so I switched the value in segatool to throttle but nothing happen in the throttle. Also if I go into test mode in the game and try the input settings, throttle and clutch are never recognized while paddle are recognized as gear 1 and 2 and some other buttons as other gears. No buttons works for up/down gear.

 

Not sure how to set the wheel up, any help is appreciated.

I am not familiar with T300 RS, but is there software for the device like Logitech does? I have the Logitech support application which actually allowed my Driving Force GT to function with my gear shifter. It has the up and down shifter, the Logitech software allowed the shifter to be assigned a button map.

@rabidduck are you using this software for your wheel?

 

With T300 RS are the button mappings changing under the set up USB game controllers config in Windows?

Share this post


Link to post
Share on other sites

@Kobe46 Thanks for the tuto, works wonder for credit. As for the 300 RS, I'm good now, didnt post on this thread but I got everything working. Kinda have a huge deadzone but other than that all buttons are working now as they should. And yes trick was to check value on the thrustmaster software. Before I was using value from Teknoparrot dinput test. But found out the hard way that it's not working that way. Once I used Thrustmaster values, everything worked. Oh and if you dont have a separate shifter and want to use paddle on the wheel, set up and down to 2 and 1 and dont forget to reassign gear after that are numbered from 1 to 6 to buttons other than 1 and 2 otherwise you'll have a conflict (took me way longer than I should have to figure that one out) as well as not using the same buttons on gear that you want on view/start).

@petje Can I upgrade from 7 ? or should I upgrade 7 to 8 and then 8 to 9 ?

 

 

Edited by KimFD3S

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×