Jump to content
linglang

[Tuto] Operation G.H.O.S.T. : Info and use

Recommended Posts

@sky2310 @petje @linglang

I am using the latest version of Demulshooter + TouchMote + Wii Motes + Latest TP version. I am not getting fullscreen (windowed) in Operation GHOST (running directly no loaders). I have to use "Borderless Gaming" app to maximize the window but I still can see the menu options on the top of the game window. Hence I do not get the perfect fullscreen hence I would like to know how it is achieved.

Secondly in the Test menu  I use the Y letter key on my keyboard to cycle through the main menu options but I cannot enter inside those options. Which key will be used to enter those options so that I can set the difficulty or set the coins to "Free Play".

Thirdly I would like to test the HD patch for the game and see if my wii motes work with it.

 

Awaiting for your response guys.

Thanks.

Share this post


Link to post
Share on other sites
3 ore fa, vitamina ha scritto:

Sorry why not work two player in teknoparrot? work single player... two player not work...

 

Here 2 players works good ( 2 xbox360 gamepad ).

 

Jn7Kd3Q.jpg

 

CHEERs

Share this post


Link to post
Share on other sites

How to work 2 player?

i start the game with teknoparrot and game loader rh all and second player not work....

i use two wiimote with mayflash bar and start second player not work

Share this post


Link to post
Share on other sites

You can use only TP, windowed was fixed

 

About wiimote, I don't know... I'm using xbox360 gamepad.

 

CHEERs

Edited by nohero

Share this post


Link to post
Share on other sites
Il 16/10/2020 Alle 23:55, vitamina ha scritto:

games run but crash when start..

 

Please help me i miss only this game:(:

000001.jpg

idem not work

Share this post


Link to post
Share on other sites
On 12/30/2020 at 6:29 PM, cois said:

idem not work

If you're using a laptop, try going to the gpu control panel and make sure the right graphics card is selected for this game. I.e. Make sure it's using the MXM 3 Nvidia or AMD gpu and not the one built in to the CPU.

 

I had that issue a few times with PC based arcade games. Also, limit it to 60fps if you don't have a display and a game that allows a variable refresh rate. 

 

When a game loads and then immediately crashes, this has usually been the issue in Teknoparrot. Other issues usually seem to prevent a game from loading at all. 

Share this post


Link to post
Share on other sites
Il 31/12/2020 Alle 01:53, xtremebuga ha scritto:

 

Il 31/1/2021 Alle 21:28, Zebra ha scritto:

If you're using a laptop, try going to the gpu control panel and make sure the right graphics card is selected for this game. I.e. Make sure it's using the MXM 3 Nvidia or AMD gpu and not the one built in to the CPU.

 

I had that issue a few times with PC based arcade games. Also, limit it to 60fps if you don't have a display and a game that allows a variable refresh rate. 

 

When a game loads and then immediately crashes, this has usually been the issue in Teknoparrot. Other issues usually seem to prevent a game from loading at all. 

with this patch it works

Share this post


Link to post
Share on other sites

hello

 

I have installed Operation Ghost, it seems to work without any loader

I want to up it in Launchbox

I want to create a .bat files  to launch the game with demulShooter and to be able to close the game via esc on my key board (it's already fullscreen)

how to write this please, i am new into .bat

 

THX

Share this post


Link to post
Share on other sites
On 3/11/2021 at 06:32, Drunkymaster said:

hello

 

I have installed Operation Ghost, it seems to work without any loader

I want to up it in Launchbox

I want to create a .bat files  to launch the game with demulShooter and to be able to close the game via esc on my key board (it's already fullscreen)

how to write this please, i am new into .bat

 

It is explained here: 

Taito Type X · argonlefou/DemulShooter Wiki · GitHub 

Look for Silent Hill the Arcade explanation to set it up with DemulShooter and Operation Ghost must be done the same way! 
Good luck! 

Script (put it in the Running Auto Hotkey Script tab) for closing game with ecs button: 

; This section closes Operation Ghost when pressing Escape
$Esc::
{
    Process, Close, {{{StartupEXE}}}
}
 

 

Share this post


Link to post
Share on other sites

hi,

 

I have made this  game to be launch thanks to game loader  but then my controlls are not recognized at all even if I lunch the game with teknoparrot. What have happened ? 

 

btw, it this game good ? (as good as time crisis for exemple)

Edited by DrAzTiK

Share this post


Link to post
Share on other sites

I got this game working perfectly now I just want to figure out how to enhance the resolution past 800x600 full screen 

Share this post


Link to post
Share on other sites
4 hours ago, tommiegunz said:

I got this game working perfectly now I just want to figure out how to enhance the resolution past 800x600 full screen 

Scroll down on above page until you find Operation Ghost and in the hidden contents there is a resoution changer zip file that you can download and then use.

 

 

Edited by Tiberius

Share this post


Link to post
Share on other sites

Ok I have managed to find where the problem come from : NEVER increase font style in windows because it is going to mess a lot with teknooparrot (and also EPSXE). Basycaly, you will end up with a off center screen.

 

So for operation ghost, I have to use the resolution changer patch and set a resolution witch is the same as my screen. But I have also to play the game "windowed' and tick the box in teknoparrot box and set fullscren =0 in the ini....

 

Finally it is work:!!!  the game is quite good

Share this post


Link to post
Share on other sites

aweesome thx guys it finally went straight to fullscreen on startup with the rez changer

Share this post


Link to post
Share on other sites

Hi,

 

For anyone that's struggling with this and TP. 

 

Download the OG resolution changer from the TP thread page 1.  Patch your exe file to your required resolution. In TP add OG game and choose to run in windowed mode. Then choose the test menu opinion in TP for OG and calibrate your mouse or Wii remote. Save the settings in the test menu. Go back into TP and choose hide cursor. Load the game as per usual and OG should load full screen.

Edited by chrisino

Share this post


Link to post
Share on other sites
On 5/24/2021 at 11:25 PM, chrisino said:

Hi,

 

For anyone that's struggling with this and TP. 

 

Download the OG resolution changer from the TP thread page 1.  Patch your exe file to your required resolution. In TP add OG game and choose to run in windowed mode. Then choose the test menu opinion in TP for OG and calibrate your mouse or Wii remote. Save the settings in the test menu. Go back into TP and choose hide cursor. Load the game as per usual and OG should load full screen.

I have never been able to enter inside any of the options in the Test Menu. All i can do is just cycle between the options on the main Test Menu screen. Can you tell me which keys to use to enter the test menu options?

Share this post


Link to post
Share on other sites

Hi. Set the test and service buttons for the game in TP controls.  I usually use F1 and F2 for test and service.

 

Whist in TP before launch select test with the slider.

 

Launch the game and it will boot into test mode. Use your service and test buttons as defined to scroll through the options and choose the option to calibrate or reconfigure the controls.

 

On each + point click on your mouse or Wii remote. Save your settings. The test menu might crash but it's already saved your recalibration settings.

 

Slide the test menu to off and launch the game. 

 

The game should now load in full screen and be calibrated.

Share this post


Link to post
Share on other sites
22 hours ago, chrisino said:

Hi. Set the test and service buttons for the game in TP controls.  I usually use F1 and F2 for test and service.

 

Whist in TP before launch select test with the slider.

 

Launch the game and it will boot into test mode. Use your service and test buttons as defined to scroll through the options and choose the option to calibrate or reconfigure the controls.

 

On each + point click on your mouse or Wii remote. Save your settings. The test menu might crash but it's already saved your recalibration settings.

 

Slide the test menu to off and launch the game. 

 

The game should now load in full screen and be calibrated.

Hi there. I tried with your given instructions but unfortunately the buttons that I set in TP for Test and Service (F1 and F2) do not seem to work in the test menu. The only button that works is the letter Y on the keyboard and that too just acts as a "Test" button by cycling through the main Test menu options from top to bottom. I changed and keys from F1 and F2 to something else and unfortunately that too didn't work.

Just test on your end and let me know.

Share this post


Link to post
Share on other sites

Weird. It doesn't matter which buttons you set as test and service, they can be anything. The reason for calibration on the test menu is that when you use the patch to make windowed mode full screen it messes with the calibration so you can't reach the edge of the screen with a mouse or Wii remote so you need to recalibrate the screen after the patch has been applied. Let's take it one step at a time. Leave calibration until later. Can you confirm that you have patched the game exe to your required resolution? If so then you just need to run operation ghost in windowed mode after applying your custom resolution (your full screen Res) and it should work full screen. If your not at this stage your not at the right stage to mess about with recalibration in the test menu.

 

Share this post


Link to post
Share on other sites

I don't understand how you can have a game working properly and then months later go to play it and it doesn't work anymore. That's the case with this game I can't enter coins yes I entered this in the .ini

 

EnableJvs=0
EnableAMLib=0
EnableLedBoard=0
EnableInputDevices=1

 

When I hit Ctrl + F1 nothing happens. I even tried it in Teknoparrot same thing. Hitting enter in the sound test works but nothing after that. I've had trouble before and I even made a note in the directory of Operation GHOST how to fix it

 

Operation G.H.O.S.T is running without Teknoparrot. Just open the gs2.ini file and change the following lines to :
EnableJvs=0
EnableAMLib=0
EnableLedBoard=0
EnableInputDevices=1
You can then run the game (gs2.exe) as a standalone or with GameLoaderAllRH to get it fullscreen.
As the game is handled as a stadalone, -parrotloader option will have no effect on this one. Operation G.H.O.S.T original keys control are :
Keyboard Key(s)    Action
CTRL+F1    Coin
ENTER    Start P1
NumPad [+]    Start P2
Y    Service

 

Yet, this doesn't work I even downloaded a new copy. It did before but not now I am out of ideas. Tried to set test and service keys in Teknoparrot they don't work.

Edited by JustinCredible81

Share this post


Link to post
Share on other sites
On 7/4/2021 at 2:31 PM, JustinCredible81 said:

I don't understand how you can have a game working properly and then months later go to play it and it doesn't work anymore. That's the case with this game I can't enter coins yes I entered this in the .ini

 

EnableJvs=0
EnableAMLib=0
EnableLedBoard=0
EnableInputDevices=1

 

When I hit Ctrl + F1 nothing happens. I even tried it in Teknoparrot same thing. Hitting enter in the sound test works but nothing after that. I've had trouble before and I even made a note in the directory of Operation GHOST how to fix it

 

Operation G.H.O.S.T is running without Teknoparrot. Just open the gs2.ini file and change the following lines to :
EnableJvs=0
EnableAMLib=0
EnableLedBoard=0
EnableInputDevices=1
You can then run the game (gs2.exe) as a standalone or with GameLoaderAllRH to get it fullscreen.
As the game is handled as a stadalone, -parrotloader option will have no effect on this one. Operation G.H.O.S.T original keys control are :
Keyboard Key(s)    Action
CTRL+F1    Coin
ENTER    Start P1
NumPad [+]    Start P2
Y    Service

 

Yet, this doesn't work I even downloaded a new copy. It did before but not now I am out of ideas. Tried to set test and service keys in Teknoparrot they don't work.

I got mine to work but WITH Teknoparrot. Have you tried that. Load GL and enable TP

Share this post


Link to post
Share on other sites

My issue is AHK is not being read while running the game with GL.

I want to be able to exit the game (Escape) by pressing two of the joysticks buttons. It works great with all my other games but not this one.

Share this post


Link to post
Share on other sites
3 hours ago, Friko said:

I got mine to work but WITH Teknoparrot. Have you tried that. Load GL and enable TP

 

I did try Teknoparrot too but I also had trouble with it couldn't enter coins with it either. 

 

I had to settle for one of the downloads that has file input etc.. in the top and there's an option under input to enter coins since I can't enter them with keyboard, so it's not true fullscreen. 

Edited by JustinCredible81

Share this post


Link to post
Share on other sites
7 hours ago, JustinCredible81 said:

 

I did try Teknoparrot too but I also had trouble with it couldn't enter coins with it either. 

 

I had to settle for one of the downloads that has file input etc.. in the top and there's an option under input to enter coins since I can't enter them with keyboard, so it's not true fullscreen. 

If you enable FreePlay in TP, then you don't need to enter coins

Share this post


Link to post
Share on other sites
31 minutes ago, Friko said:

If you enable FreePlay in TP, then you don't need to enter coins

 

Check it out it's so weird it still wants coins despite free play being checked and hitting start wont work without them. I've tried multiple copies of Operation GHOST and latest Teknoparrot. (or one of the latest) 

 

WAO0dZW.png

 

PC925Rj.png

 

Also if I choose fullscreen I can't see video after it says Sega. On both Teknoparrot or without Teknoparrot I can hit enter the first time after launching game but that's the only keyboard input I can do. Coins or hitting start doesn't work and yes I've mapped them correctly. 

Edited by JustinCredible81

Share this post


Link to post
Share on other sites

Can you point to which copy of the game you downloaded? I've tried 2 or 3, but I'll try another if there is any others. 

 

Edit: sorry for double post mods. 

Edited by JustinCredible81

Share this post


Link to post
Share on other sites
4 minutes ago, JustinCredible81 said:

Can you point to which copy of the game you downloaded? I've tried 2 or 3, but I'll try another if there is any others. 

 

Edit: sorry for double post mods. 

you can play it windowed 

or full screen  

u may need to change the dpi settings depending on ur setup                               I USE THE 1.0.0.325 VERSION OF TKPT THOUGH. WORKS BETTER FOR ME AS IT HAS THE 'USE MOUSE FOR GUN IN MENU,  the new versions are too complicated      teknoparrot is 'horses for courses' imo          

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×