Jump to content
emulate58

ARTAX TTX3 MEGA MULTI - Taito Type X3 Multi - [JVS] [FASTIO] [1080p] [v4] NEWEST VERSION

Recommended Posts

il y a 9 minutes, Lachlan a dit :

It's a full system image, why don't you just image an SSD with it and boot the PC from that as designed?

 

...ok need to make my PC boot drectly into this without boot my usual win 10 in first time ! i have read that but was thinking it is only possible with TTX3 .... great ! i need to change the setting boot into my bios to make it boot into this , am i right ?

But it creat 4 HD drive ( E: system- F: X3 multi system  - G : X3multi save H:X3multi Games )   wich one to boot on ? the F: as it have inside multiboot file?

Edited by Helicoy

Share this post


Link to post
Share on other sites
27 minutes ago, Helicoy said:

 

...ok need to make my PC boot drectly into this without boot my usual win 10 in first time ! i have read that but was thinking it is only possible with TTX3 .... great ! i need to change the setting boot into my bios to make it boot into this , am i right ?

But it creat 4 HD drive ( E: system- F: X3 multi system  - G : X3multi save H:X3multi Games )   wich one to boot on ? the F: as it have inside multiboot file?

 

Text file is in the original download, it has instructions, use balena etcher to write the image file to the 1tb or larger SSD, boot from the SSD.

In balena etcher choose Flash from File then select target and write.

 

 

Share this post


Link to post
Share on other sites
Il y a 13 heures, arcadeforty a dit :

 

Text file is in the original download, it has instructions, use balena etcher to write the image file to the 1tb or larger SSD, boot from the SSD.

In balena etcher choose Flash from File then select target and write.

I already do that , the Image is writing on 2 TO HD

 

 

 

Share this post


Link to post
Share on other sites

If you have multiple Win10 drives, set the drive you flashed with the multiboot image as first priority in the BIOS. It should be as simple as that.

Share this post


Link to post
Share on other sites
Il y a 6 heures, Lachlan a dit :

If you have multiple Win10 drives, set the drive you flashed with the multiboot image as first priority in the BIOS. It should be as simple as that.

yes ok ! i try but black screen when booting into this one

Share this post


Link to post
Share on other sites

Ok so update: I got everything working fine after upgrading to a i5 4460 and a msi gtx 660 twin frozr and switching the pc case of my small form factor optiplex 3647 to fit the gtx 660. I also had to upgrade the psu to a 500w. Street Fighter V type arcade doesn’t lag anymore and I’m able to play Tekken 7 now because I upgraded to a 4 core cpu. I wasn’t able to run tekken 7 on a i3 4160 that uses 2 cores that I had before upgrading. You will get a black screen if you try to run it on 2 core cpus. Everything works good now on my Namco noir cab. Just one game I really want to play is Carnevil. I saw it was posted on the forum but how do I add games to the ssd? Does it need to be in a specific folder? 

Share this post


Link to post
Share on other sites
On 9/18/2021 at 2:11 PM, murray said:

 

I tried apm3, not enough GPU horsepower for most games. GTX780 also doesn't run most of the 3d games properly. Everything works fine on my custom system but it has current gen specs.

 

 

Yeah, I got Senjin Aleste working so far, Guilty Gear Strive seems to run as well, but both have buttons mismatched.

Easier to fix on Aleste, on GGS I don't know why. Could the buttons be matched to keyboard keys by default and teknoparrot would be overlapping with these ?

 

Got the Steam version of GGS running as well, HW is alright it seems.

 

Will dig more and see.

Edited by jeston

Share this post


Link to post
Share on other sites
1 minute ago, jeston said:

Yeah, I got Senjin Aleste working so far, Guilty Gear Strive seems to run as well, but both have buttons mismatched.

Easier to fix on Aleste, on GGS I don't know why jump triggers kick+jump.

 

Got the Steam version of GGS running as well, HW is alright it seems.

 

Will dig more and see.

Can you share any basic

info how to get steam working on this images?

Share this post


Link to post
Share on other sites
Le 19/09/2021 à 04:17, Lachlan a dit :

If you have multiple Win10 drives, set the drive you flashed with the multiboot image as first priority in the BIOS. It should be as simple as that.

O Damn i just set the bios this morning and be able to boot into this compilation  ! It is so far the best things that i ever seen ! it is so like the Arcade was at my home ! For Left4dead i wasn't found a way to inverse Joystick from up to down ,i found a way to inverse mouse in settings but it not follow Joystick . About connecting an arcade JOystick could you show me what i will need to connect to my PC ? Does a Brook adapter usb could do the job as i have ? i have only 6 buttons , i will need 8 buttons to goes well ?

IMG_20210920_112833_169.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Helicoy said:

O Damn i just set the bios this morning and be able to boot into this compilation  ! It is so far the best things that i ever seen ! it is so like the Arcade was at my home ! For Left4dead i wasn't found a way to inverse Joystick from up to down ,i found a way to inverse mouse in settings but it not follow Joystick . About connecting an arcade JOystick could you show me what i will need to connect to my PC ? Does a Brook adapter usb could do the job as i have ? i have only 6 buttons , i will need 8 buttons to goes well ?

 

It doesn't need 8 buttons, only 6. I don't know what a brooks adaptor does, but if it emulates a keyboard then it should work.

 

All the games just use a keyboard to control, so if can make your brooks send keystrokes on button presses, then it should work for the most part. From memory, the key config is in the readme from the original download. If you get a JVS IO board it will just work. Get one of these if you have a jamma cabinet, they work well, make sure it's REV B.

 

dsc_0760xwu2k.jpg.871324947d007a6eca45ab74a2ec0352.jpg

Share this post


Link to post
Share on other sites
6 hours ago, DaddyGadget said:

Can you share any basic

info how to get steam working on this images?

 

Have fun with

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
(:

 

Quote

Steps to use :

1) Copy the content of this archive to the root of your TTX3 E: disk

WARNING !!! If you want to be more selective and maintain your gamelists, you might want to edit "E:\SYSTEM\AM\romlists\multi.txt" and "E:\SYSTEM\AM\attract.cfg" manually !!!

2) go to "E:\Tools" folder and install "ViGEmBusSetup_x64.msi" on your TTX3

#) go to "E:Tools" folder and launch "SteamSetup.exe", chose "E\GAMES\PC\Steam" as install directory.

3) launch Explorer from the TTX3 multi menu and go to "E:\GAMES\PC\Steam" and launch "steam.exe"

4) log-in with your account credentials and set steam to start as big picture mode.

5) exit steam

6) From now on, you can launch steam from the TTX3 multi menu and download whatever games you own in your steam library.

 

Share this post


Link to post
Share on other sites

I seem to have finally gotten it working on my NNC cab. Some fiddling with CRU seemed to force to the right resolution on boot, finally. Now I can go over and touch up the roms :D

 

I saw that good chunk of Naomi roms are included, but only  a subset are added to the frontend. Does anyone have a decent guide for launching Naomi roms through demul? I assume the multi makes use of the accompanied a3x scripts to tie it together? Or can I launch them some other way to see which ones work and which ones don't?

Share this post


Link to post
Share on other sites
4 hours ago, jeston said:

 

Have fun with

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
(:

 

 

I am sure the .a3x files hold the key to most of the setup for additional windows games but how do y oh edit, in notepad++ it’s like the file

is encrypted as unreadable?

Share this post


Link to post
Share on other sites
Le 20/09/2021 à 13:36, murray a dit :

It doesn't need 8 buttons, only 6. I don't know what a brooks adaptor does, but if it emulates a keyboard then it should work.

 

All the games just use a keyboard to control, so if can make your brooks send keystrokes on button presses, then it should work for the most part. From memory, the key config is in the readme from the original download. If you get a JVS IO board it will just work. Get one of these if you have a jamma cabinet, they work well, make sure it's REV B.

 

dsc_0760xwu2k.jpg.871324947d007a6eca45ab74a2ec0352.jpg

Brook adaptor make work Joystick 8 ways and mechanic buttons to a PC ,PS4 ,Switch , as Xbox 360 controller work on this ARTAX compilation i think it could work and need to try .

Share this post


Link to post
Share on other sites

Hey all, Got the new multi installed today and I've run into a couple hiccups.

For starters, here's my setup-

Vewlix cabinet with Fast I/O and an upgraded 1080p monitor using HDMI

Taito Type X3 board with i5 processor, 16GB RAM, and a GTX 780

Started up, let the drivers install, then added the listed custom resolutions in the Nvidia Control panel.

 

The problems I've hit-

Persona 4 Ultimax will not launch: the screen goes dark, I get a black window, then back to main menu.

Chaos Code will not launch: I get an error that it cannot find E:\Games\TTX2\Chaos Code - New Sign of Catastrophe\Launch.a3x (blindly, I copied a file with the same name from another game and placed it in there, the game will not launch that way either)

Persona 4 Arena: I get an error message from within the game that I cannot skip, but it goes away and lets me play after a while. It's in Japanese so I'm not sure what it's saying. Game is otherwise playable fine

Street Fighter 3 3rd Strike: The game is squished horizontally. game runs fine, but there are black bars (think like a widescreen movie on a 4:3 TV) on the top and bottom.

 

Any tips on what I should look at? everything else seems to run fine

Share this post


Link to post
Share on other sites
3 hours ago, bartre said:

The problems I've hit-

Persona 4 Ultimax will not launch: the screen goes dark, I get a black window, then back to main menu.

Chaos Code will not launch: I get an error that it cannot find E:\Games\TTX2\Chaos Code - New Sign of Catastrophe\Launch.a3x (blindly, I copied a file with the same name from another game and placed it in there, the game will not launch that way either)

Persona 4 Arena: I get an error message from within the game that I cannot skip, but it goes away and lets me play after a while. It's in Japanese so I'm not sure what it's saying. Game is otherwise playable fine

Street Fighter 3 3rd Strike: The game is squished horizontally. game runs fine, but there are black bars (think like a widescreen movie on a 4:3 TV) on the top and bottom.

 

Any tips on what I should look at? everything else seems to run fine

 

P4 Ultimax - it's the same for everyone, it's an issue with the original image.

Chaos Code - it's the same for everyone, it's an issue with the original image.

P4 Arena - that message you are seeing is part of the game, i guess it's saying something about not being online.

Sf3 3rd strike - I think you are talking about the TTX2 version with the banners on the left and right. It's like that on mine, it has the small black bars at the top and bottom. i guess it's just the way it is to keep the correct aspect ratio. If you screw around with the game settings i think you can turn off those banners on the sides not sure if it fixes the resolution though. Try the CPS3 version of the game, i believe it runs better than the TTX2 version anyways.

 

I have the exact same issues on my system so i'm guessing all your noted things are problems with the image. I think P4 and Chaos Code are just bugs that got missed. The Sf3 resolution i'm not even going to try on that one, try looking in the contents of the game folder and see if you can find anything that lets you manipulate resolution. Or just play the CPS3 version. If you don't like it with the scanline effect ( some people think it looks a littlle off on cps3 games), just disable HLSL on that game in mame. Google will tell you how to do this.

 

I made P4 ultimax work by going into the folder running jconfig and saving the settings again, it's possible i may have screwed around with some other settings, but i did make it work in the end and it had something to do with jconfig settings for that game, just can't remember exactly what i did.

Share this post


Link to post
Share on other sites

Any mame wiz got any idea how to set up input overrides for NeoGeo? Or optimally, for e.g. KoF, Garou and the like. I've tried applying suggestions online and adjusting the ctrlr files, but that has no effect. So not sure if it's configured differently/per game, or if I went about it wrong.

 

Now it's set to use 
1 2 3

4

 

which works fine for e.g. SamSho, but for KoF and similar you want

 

1 2

3 4

 

Any idea which config file I can adjust for this?

Share this post


Link to post
Share on other sites
46 minutes ago, Snufsen said:

Any mame wiz got any idea how to set up input overrides for NeoGeo? Or optimally, for e.g. KoF, Garou and the like. I've tried applying suggestions online and adjusting the ctrlr files, but that has no effect. So not sure if it's configured differently/per game, or if I went about it wrong.

 

Now it's set to use 
1 2 3

4

 

which works fine for e.g. SamSho, but for KoF and similar you want

 

1 2

3 4

 

Any idea which config file I can adjust for this?

 

Manually.

 

Plug your keyboard in, run the neogeo game you want to change, press tab, goto inputs for that game only, select the button you want to change and press the button you want to use on your cab control panel. I did this exact thing for vanilla KOF2k2 as i play that game a littele and since the UM kof games i'm just so used to their layout like you posted.

Share this post


Link to post
Share on other sites

Did anyone have a problem with playing racing games from ES3 section? For some reason, I can't play those games because it's not set to free play. Even if I tried to trigger the coin mech from my Vewlix Diamond Orange, it won't play. Another thing I've noticed is that games from the ES3 section need to reset in order to exit that section. Unlike all other sections, you press the first four-button plus player one button to go back. As for ES3 section, you need to press the last two buttons plus player one button which reset the system.

Share this post


Link to post
Share on other sites
26 minutes ago, suprawhite said:

Did anyone have a problem with playing racing games from ES3 section? For some reason, I can't play those games because it's not set to free play. Even if I tried to trigger the coin mech from my Vewlix Diamond Orange, it won't play. Another thing I've noticed is that games from the ES3 section need to reset in order to exit that section. Unlike all other sections, you press the first four-button plus player one button to go back. As for ES3 section, you need to press the last two buttons plus player one button which reset the system.

 

What gamepad are you using?

Share this post


Link to post
Share on other sites

I'm not using any gamepad. Is that the reason why? I play mostly fighting games and I saw there are lots of shooting games and racing games in this multi and wanted to try it out. 

Share this post


Link to post
Share on other sites

If it shows a gamepad in the menu when you are on the game tile, the game requires a game pad. It has a section in the multi readme about using a gamepad for games that show that. I can play all the ES3 games no problem... ES3 racing games all require analogue control, which you don't get from a digital cabinet joystick. From memory coinup on the wangan games is done via the left or right thumbstick on the gamepad.

Edited by murray

Share this post


Link to post
Share on other sites
On 9/23/2021 at 8:43 AM, bartre said:

Persona 4 Ultimax will not launch: the screen goes dark, I get a black window, then back to main menu.

Chaos Code will not launch: I get an error that it cannot find E:\Games\TTX2\Chaos Code - New Sign of Catastrophe\Launch.a3x (blindly, I copied a file with the same name from another game and placed it in there, the game will not launch that way either)

Persona 4 Arena: I get an error message from within the game that I cannot skip, but it goes away and lets me play after a while. It's in Japanese so I'm not sure what it's saying. Game is otherwise playable fine

Street Fighter 3 3rd Strike: The game is squished horizontally. game runs fine, but there are black bars (think like a widescreen movie on a 4:3 TV) on the top and bottom.

 

*Persona 4 Ultimax : Just use the launcher.au3 from BlazeBlueCSII, it works. There's an issue between the .bat and launcher.au3. So far I wasn't able to use NesicaUnlocker.exe with this game.

 

*Persona 4 Arena : yeah "communication Error, shit happens"

 

*Chaos Code : use

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
I made for HSFII etc (this was to allow to save options on Capcom TTX2 games), this will remove the Nesica message. Also, you want to open Jconfig and set the keys properly for this game (1,2,3,4,5,6) and disable the "save patch" option in Jconfig "settings" so you'll be able to set the game to freeplay. It doesn't work without disabling the patch.

 

*SF3.3 (or any other CPS based game): you can use the

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
.

 

Share this post


Link to post
Share on other sites

I understand that some games cant be played locally offline on 2 player control panel (Tekken7,SFV etc). has anyone tried to see if a simple cross over cable connected to two ttx3 unit's Lan port works on this multi? Can someone test this theory? 

In order for Tekken 7 to work, the ip range should be 192.168.138.xxx, so basically this means changing local ip on network adapter with an IP address like 192.168.138.100 for one machine and 192.168.138.101 for the second machine and subnet as 255.255.255.0 and leave everything else blank. 

 

Then try and ping the other pc ip address from a command prompt and see if successful. Then attempt to try and play 2 player Tekken 7 from the multi.

This will determine if i need to buy a second unit or not haha

Edited by Snes

Share this post


Link to post
Share on other sites
On 9/24/2021 at 3:19 AM, murray said:

If it shows a gamepad in the menu when you are on the game tile, the game requires a game pad. It has a section in the multi readme about using a gamepad for games that show that. I can play all the ES3 games no problem... ES3 racing games all require analogue control, which you don't get from a digital cabinet joystick. From memory coinup on the wangan games is done via the left or right thumbstick on the gamepad.

Do you happen to know what type of gamepad control I can use? Is there a specific controller I have to use or I can use any. The only controller I have is from my PS3. Thanks

Share this post


Link to post
Share on other sites
9 hours ago, suprawhite said:

Do you happen to know what type of gamepad control I can use? Is there a specific controller I have to use or I can use any. The only controller I have is from my PS3. Thanks

 

I can confirm the one listed in the first post works fine, outside of that you will need to test yourself to see if it works or get that one.

Share this post


Link to post
Share on other sites

Can someone explain how to extract the ttx3 multi file into an image. What format does the SSD need to be? I keep getting the disk is full error when trying to extract. Does it matter if I’m using winrar or 7zip? I’m using a blue wd 1tb ssd. 

Share this post


Link to post
Share on other sites

Just use 7zip to unzip. Open the .001 file in 7zip and extract the image to a different drive, not the WD blue ssd. Then use Balena etcher to write the image to the blue wd ssd.

Share this post


Link to post
Share on other sites
3 hours ago, arcadeforty said:

Just use 7zip to unzip. Open the .001 file in 7zip and extract the image to a different drive, not the WD blue ssd. Then use Balena etcher to write the image to the blue wd ssd.

Thanks for tip I guess I was doing it wrong.

Edited by cesar909
I post could’ve been misleading to others. The .001 file is the Winrar/7zip file

Share this post


Link to post
Share on other sites

On my second Asus Pc ,when inside the Bios i search to Boot on this compilation but it ask me to enter the File Path to Boot , Does someone know wich line to enter please .

Edited by Helicoy

Share this post


Link to post
Share on other sites
8 minutes ago, Helicoy said:

On my second Asus Pc ,when inside the Bios i search to Boot on this compilation but it ask me to enter the File Path to Boot , Does someone know wich line to enter please .

Is it in EFI mode ?
Disable it ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×