Jump to content
spiderzsoft

[Arcade PC] Street Fighter V Type Arcade (TTX4)

Recommended Posts

The game works but when I configure controls in jconfig and start the game and press medium punch, the character jumps and punches at same time. Is there a way to fix this?

Share this post


Link to post
Share on other sites
2 hours ago, sidlalami said:

The game works but when I configure controls in jconfig and start the game and press medium punch, the character jumps and punches at same time. Is there a way to fix this?

Remove all added files.

Jconfig and .dll files (so the game folder is "clean"), and add them again, reconfigure Jconfig again.

Edited by petje

Share this post


Link to post
Share on other sites

I was thinking if softwares like Aster multiseat can be used to play lan vs from same pc......If somebody can shed some light on this....

Share this post


Link to post
Share on other sites

Hey Guys. thanks to all those who worked on this game and shared it. I just finished downloading it and am hoping for a Windows 7 fix at some point. :) Thanks again.

Share this post


Link to post
Share on other sites
8 minutes ago, eljose said:

me too :( but do not think that this will happen :( because ttx4 was not made for windows 7

Windows 7, why ? 

Mainstream support ended on January 13, 2015.
Extended support ended on January 14, 2020.

Windows 10 was released July 29, 2015

Taito Type X4 was released in 2016

 

Windows 10 is still freely upgradable with a Win 7 / 8 key

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

it is a old post about old versions, but still usefull, just use the latest versions you can find

 

 

 

 

Share this post


Link to post
Share on other sites

Hello,

 

Je confirme en démarrant mon pc en Windows 7 ça ne marche pas, en démarrant sur le même pc mais en Windows 10 ça fonctionne.

Même matériel -> Windows 7 ça ne fonctionne pas et en Windows 10 ça fonctionne.

Share this post


Link to post
Share on other sites
29 minutes ago, inchkael said:

Hello,

 

Je confirme en démarrant mon pc en Windows 7 ça ne marche pas, en démarrant sur le même pc mais en Windows 10 ça fonctionne.

Même matériel -> Windows 7 ça ne fonctionne pas et en Windows 10 ça fonctionne.

 

I've not tried this one yet since I too built my cab off Win 7 but what is the issue Win 7 users are experiencing? It sounded like other have it working just with controls issues. (based on some prior posts)

Share this post


Link to post
Share on other sites
1 hour ago, petje said:

Windows 7, why ? 

Can't speak for the other Windows 7 users, but my arcade cab runs on Win 7 so I'd like to see this run on my cab. My main PC is running Win10 and I have the PC version of SFV running anyway so it's not a big deal to me if I get this running or not. 

Share this post


Link to post
Share on other sites
3 minutes ago, Mindwipe said:

Can't speak for the other Windows 7 users, but my arcade cab runs on Win 7 so I'd like to see this run on my cab. My main PC is running Win10 and I have the PC version of SFV running anyway so it's not a big deal to me if I get this running or not. 

I understand you on that I got the pc steam version myself and tekken pc version but I always wanted the real arcade style games on my arcade so to have them working would make my arcade Cab feel so authentic and legit but only me game eluded me thus far...

Share this post


Link to post
Share on other sites

I wonder whats the arcade version native resolution 720p? 1080P? 4k? There’s a difference playing it on the arcade with the screen that build for it and in pc with a 4k monitor who has to process the image although sfv type arcade looks great anyway 

Edited by R.R.Z.

Share this post


Link to post
Share on other sites
13 hours ago, tommiegunz said:

That’s what I meant...recook from the config files again and replace but that is odd mines worked out the box 

mines worked out of the box without modifying anything, but once i went into jconfig and started messing around, it saved a new files and the game would not longer boot after that and the controls would no longer function properly

Edited by haynguy68

Share this post


Link to post
Share on other sites
3 minutes ago, haynguy68 said:

mines worked out of the box without modifying anything, but once i went into jconfig and started messing around, it saved a new files and the game would not longer boot after that and the controls would no longer function properly

Yeah it sounds like you need to delete your j config file and re-add it back from the fix file and always remember to backup your original files just in case something like this happens if that doesn’t work delete the whole game and download again if you don’t have the .rar file or torrent still available 

Share this post


Link to post
Share on other sites

I am going crazy ... Why the .ini file where we can change the resolution does not affect?
From where does the game read the resolution to use (720p)?

Edited by Keroro

Share this post


Link to post
Share on other sites
7 minutes ago, Keroro said:

From where does the game read the resolution to use (720p)?

The sfv.bat file mentions

start /wait StreetFighterV.exe -resolution=720p

 

But making a .bat file or shortcut with start StreetFighterV.exe -resolution=1080p does nothing

No idea how to get the game at higher resolution than 720P

Share this post


Link to post
Share on other sites

For those who want to put the game in 1080p I've found a solution:

 

Create a shortcut file of "\StreetFighterV\Binaries\Win64\StreetFighterV.exe"

 

Right click on the shortcut and select properties, on the target field add this:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hit apply and Ok

 

Now run the game from the shortcut, the game will be in FullHD 1920x1080

 

Proof:

 

 

 


2vHdfjj.png

 

Edited by RubenDB

Share this post


Link to post
Share on other sites
4 minutes ago, RubenDB said:

For those who want to put the game in 1080p I've found a solution:

 

THANKS AWESOME !!! 

So "\Street Fighter V Arcade\StreetFighterV\Binaries\Win64\StreetFighterV.exe" -resx=1920 -resy=1080

Share this post


Link to post
Share on other sites
hace 8 minutos, RubenDB dijo:

For those who want to put the game in 1080p I've found a solution:

 

Create a shortcut file of "StreetFighterV\Binaries\Win64\StreetFighterV.exe"

 

Right click on the shortcut and select properties, on the target field add this:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hit apply and Ok

Now run the game from the shortcut, the game will be in FullHD 1920x1080

 

 

WOW!!!!!!!!!!

You are a genius, than easy like this! -resx=1920 -resy=1080
Thanks a lot! Everyone do it! Amazing :very-good:

Edited by Keroro

Share this post


Link to post
Share on other sites
hace 5 minutos, petje dijo:

THANKS AWESOME !!! 

So "\Street Fighter V Arcade\StreetFighterV\Binaries\Win64\StreetFighterV.exe" -resx=1920 -resy=1080

 

Yes, your folder is named "Street Fighter V Arcade" but mine is "SF5Arcade", that's why I only said " \StreetFighterV\Binaries\Win64\StreetFighterV.exe" cause people may have a different folder names :)

Edited by RubenDB

Share this post


Link to post
Share on other sites
3 minutes ago, RubenDB said:

 

Yes, your folder is named Street Fighter V Arcade but mine is SF5Arcade, that's why I only said " StreetFighterV\Binaries\Win64\StreetFighterV.exe" cause people may have a different folder names :)

It applies for 4k also?

Share this post


Link to post
Share on other sites

As the SFV is designed for run natively to 1080p, the graphical difference its amazing, wow the difference its brutal!
Again @RubenDB thanks for find the workaround.

Share this post


Link to post
Share on other sites
hace 10 minutos, R.R.Z. dijo:

It applies for 4k also?

 

You can go 2k or 4k but anything above 1080p will make the game bugged/glitched. Stages and some in-game menús doesn't display properly.

 

This game is made for a max resolution of 1080p so it's not recommended to go above 1080p.

Share this post


Link to post
Share on other sites
1 minute ago, RubenDB said:

 

You can go 2k or 4k but anything above 1080p will make the game bugged/glitched. Stages and some in-game menús doesn't display properly.

 

This game is made for a max resolution of 1080p so it's not recommended to go above 1080p.

Thanks

Share this post


Link to post
Share on other sites

SFV Fixes (50/100%)

 

1. SAVE (SOLVED)

Save Patch fixed, available #1 post. Thanks to @Fiybit

2. RESOLUTION (SOLVED)

Create shortcut, with -resx=1920 -resy=1080 on target file, Thanks to @RubenDB

3. CHARACTERS (PARTIAL)

The characters works if you change to Japanese the entire Win10 system language.

Too drastic solution, we need a workaround without changing the whole system.

 

4. VS 2 PLAYERS (TBA)

Working ... Hopefully avoiding modify the Win10 network properties, only the game .exe

Edited by Keroro

Share this post


Link to post
Share on other sites
18 minutes ago, Keroro said:

SFV Fixes (50/100%)

 

1. SAVE (SOLVED)

Save Patch fixed, available #1 post. Thanks to @Fiybit

2. RESOLUTION (SOLVED)

Create shortcut, with -resx=1920 -resy=1080 on target file, Thanks to @RubenDB

3. CHARACTERS (PARTIAL)

The characters works if you change to Japanese the entire Win10 system language.

Too drastic solution, we need a workaround without changing the whole system.

 

4. VS 2 PLAYERS (TBA)

Working ... Hopefully avoiding modify the Win10 network properties, only the game .exe

So what does that save patch do...can we save high scores now ?

Share this post


Link to post
Share on other sites

maxresdefault.jpg

Street Fighter V Costume Mod

Arcade version can also be used in the same way as the Home version.

 

2.jpg

 

3.jpg

 

1.jpg

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by spiderzsoft

Share this post


Link to post
Share on other sites
4 hours ago, tommiegunz said:

3. CHARACTERS (PARTIAL)

The characters works if you change to Japanese the entire Win10 system language.

Too drastic solution, we need a workaround without changing the whole system.

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Solved !! 

Easier solutoion here:

 

this is for people who still want to do it the hard way .....

 

Use Japanese locale on other language Win10

 

Create a new local user.

Log in with that user and change the Windows language of that account to which you needs. (Japanese)

Log out

Log in with your usual user.

Run the application you want to see in a different language with the “Run As” method.

 

Open File Explorer and browse to the executable file (shortcut works also) you wish to run as different user.

Simply hold down the Shift key and right-click on the executable file, select Run as different user from the context menu.

shift-run-as-different-user.png

Make sure secondary logon in on

 

Press Windows Key + R.

Type services.msc into the Run window.

Click OK.

In the Name column, locate and right-click Secondary Logon.

Select Properties.

Under the Startup Type dropdown menu, select Automatic.

Click OK.

 

Restart system if needed.

 

PERMANENT SHORTCUT

This is the target in my shortcut, works fine in Japanese and full HD

C:\Windows\System32\runas.exe /savecred /user:Japanese language account name "Location of your Street Fighter 5 game\Street Fighter V Arcade\StreetFighterV\Binaries\Win64\StreetFighterV.exe -resx=1920 -resy=1080"

It will pop up a DOS box to save your credentials / password for the Japanese language account.

 

Right click then Run As Administrator the first time you use the shortcut, enter your password in the cmd prompt and press enter.

Clicking the icon will then run as the user

 

If you did everything right next time, a simple double click on the shortcut will start Street Fighter 5 Arcade in Japanese and full HD resolution.

 

Edited by petje

Share this post


Link to post
Share on other sites
hace 41 minutos, petje dijo:

Use Japanese locale on other language Win10

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Thanks a lot @petje :very-good:

Works! and for complement your tuto I think we can do id directly whit the shourcut adding /user:"name" to the target file:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

This car work for the majority!

Unfortunately this method its not compatible with my "Windows hidden boot" and I still waiting for something related to the game files.

Edited by Keroro

Share this post


Link to post
Share on other sites

Im going to try this: 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
5 minutes ago, takuramone said:

 

....a solution for windows 7 64 bit.

download the 64-bit version of XInput1_4.dll and throw it to the same level of StreetFighterV.exe

Share this post


Link to post
Share on other sites
17 minutes ago, Keroro said:

Im going to try this: 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Won't work , StreetFighterV.exe will not get the right click option

Share this post


Link to post
Share on other sites
hace 3 minutos, spiderzsoft dijo:

descargue la versión de 64 bits de XInput1_4.dll y tírela al mismo nivel de StreetFighterV.exe

 tried it yesterday and it doesn't work, neither with the 32 and 64 file of the x360ce.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×