Jump to content
spiderzsoft

[Arcade PC] Friction Arcade (Friction Game Studios 2011)

Recommended Posts

I put the Ducon patch and the mouse stops working. Can you adjust this?

Is it possible to put it in full? Game Loader All Rh already solved this

Edited by punkdark2000

Share this post


Link to post
Share on other sites

Thanks to Ducon for his work on the patch.

But I have the same problem : the mouse is not working.

All the other assigned buttons are OK.

 

Any ideas ?

Cheers

Share this post


Link to post
Share on other sites

Yeah confirmed, patch is not working. No cursor or mouse. Other buttons seem fine.

 

Without the patch, I can see my cursor via mouse move but no buttons work/can't start game.

 

Thanks for the share though! I've never heard of this game before and it looks pretty cool (I'm a sucker for rail shooters).

Edited by LEGEND80

Share this post


Link to post
Share on other sites
3 hours ago, spiderzsoft said:

what Ducon's Patch do:

  1.     show cursor on screen
  2.     working with two joysticks and keyboard
  3.     support mouse again
  4.     support lightguns

For #4, Prefer to let demul shooter do it

 

Sorry, some information got lost in translation. With the current patch only #2 work. Working on 1 and 3 right now, and hope my friend @argonlefou can add support in demulshooter. Should be super easy. Also as usual the full source code is included.

 

Thanks to @spiderzsoft for sharing the dump publically.

Edited by ducon2016

Share this post


Link to post
Share on other sites
1 hour ago, punkdark2000 said:

I put the Ducon patch and the mouse stops working. Can you adjust this?

Is it possible to put it in full? Game Loader All Rh already solved this

 

In the config file, DInputDisable=0. Just make sure you are not mapping your credit and start keys to existing keys used by the game.

One of the config files has the graphics resolution, just change it there.

Edited by ducon2016

Share this post


Link to post
Share on other sites

Yeah was just going to post that. This fixes mouse:

 

;Set to 1 to disable the hardcoded input code
DInputDisable=0

 

THEN, you have to use LEFT MOUSE CLICK to start P1. After that, it's perfect - left click=shoot, right click=reload, key 1=Continue

 

IF you use key 1 to start initially, game will be broken - mouse will control camera instead of cursor. So the trick is to use LEFT MOUSE CLICK to start

Share this post


Link to post
Share on other sites
4 minutes ago, punkdark2000 said:

To enable blood, press the "O" key and go to the Game Settings option, the "Gore" option and change to Yes.

 

you can also change it in the service menu, just close game when it hangs and restart

 

Share this post


Link to post
Share on other sites

Awesome game!  Simple and fun to play over and over again!  Took me over 30 credits to beat it though!  That's almost 15$ if you played it at an arcade.

Everything works great.  I played with the mouse.  Only thing I had trouble with was putting my name in after I finished the game.

Definitely would recommend to anyone who loves light-gun shooters.

Share this post


Link to post
Share on other sites

Im waiting for HL3. Valveeeeeeeeeee.

 

Thanks for this. :)

 

Share this post


Link to post
Share on other sites

Have you seen the cabinet? They took the Time Crisis 2 SD cabinet and replaced the art work

Share this post


Link to post
Share on other sites

Question for the group that's a little off topic. Does anyone have the flyer/brochure for this game? All I can find on the web is a watermarked version from coinopexpress. I use the flyers(or box) along with the clear logos in my front end.

 

Thanks in advance!

Share this post


Link to post
Share on other sites

thanks...too bad i cant play it. those flashes when you shoot, hurt my eyes and head 0:, just like in the old crt era.

Share this post


Link to post
Share on other sites
1 hour ago, llll55 said:

thanks...too bad i cant play it. those flashes when you shoot, hurt my eyes and head 0:, just like in the old crt era.

 

What flashes??? I have not seen any flashes in this version.

Edited by ducon2016

Share this post


Link to post
Share on other sites
à l’instant, ducon2016 a dit :

 

What flashes??? I have not seen any flashes in this version.

ok, i watch the arcade version on youtube and saw it with flashes...maybe this one hasnt, didnt try it yet.

thanks:)

Share this post


Link to post
Share on other sites

hi, where to put the patch? in the main folder where the friction.exe is?

also, where is the config file? cant find it.

thanks:)

Share this post


Link to post
Share on other sites

@bojo5150 Dont know if this will do 

Below zip is arcade flyer for friction

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by eathearty1

Share this post


Link to post
Share on other sites

Thanks! It seems an amazing 2p lightgun game.

I tested in a win 10 with amd card and launched fine, while in my arcade  (win10 pc little older with amd hd6900 using Crt emudriver) I get this error:

Error code 13:

Function: functioncd3d9rendersystem :: CreateDirect3d9interface

Description: Unable to detect current video mode

 

I tried changing the resolution, windowed, in one of the game config files.

Tried changing system resolution but same result.

 

Any advise?

Thanks!

Share this post


Link to post
Share on other sites

Hi Everyone,

 

In a bid to ask the stupidest question of the day......

 

The VSIOBOARD.ini file states Valid xinput entries: XINPUT_A, XINPUT_B etc so I put P1_Left=XINPUT_LEFT_ANALOG_LEFT  etc and it works but if I use same for P2 then one controller does both.I cheated and had one player using Left and one using Right but that didn't carry across to demulshooter (which has had a release for this now) and work.

 

How do I change it to make player 2 have own controller. I tried a few variations of XINPUT_01_LEFT_ANALOG_LEFT and such but no luck.

 

Thanks in advance for the what I imagine will be a very simple and obvious answer

Share this post


Link to post
Share on other sites

Hi thanks for this game, it's really good and playable. Is there any way to make the mouse cursor larger please or to add your own at all? Thanks for any help in advance.

Share this post


Link to post
Share on other sites
3 minutes ago, erdoboy43 said:

Hi thanks for this game, it's really good and playable. Is there any way to make the mouse cursor larger please or to add your own at all? Thanks for any help in advance.

 

Not yet. Looking into it right now. But no the game does not have support for a larger cursor out of the box sadly. It needs to be added and that is some work, not sure I can do it but trying.

Share this post


Link to post
Share on other sites
11 minutes ago, ducon2016 said:

I need to add the support in my code. Will look into it.

Please feel free to ignore me - I am an idiot and just had made a mistake in my set up.

 

Having looked at it again and tried it I can get two wiimotes working and play a 2 player game - Sorry for being a numpty

 

Cheers

Share this post


Link to post
Share on other sites

Ok...a weird problems, if i get killed, i cant continue, is stuck on free play, mouse do nothing. and lol you can walk inside the level with the arrows.

Share this post


Link to post
Share on other sites
3 minutes ago, llll55 said:

Ok...a weird problems, if i get killed, i cant continue, is stuck on free play, mouse do nothing. and lol you can walk inside the level with the arrows.

Read the post above from Legend80. To continue you need to use the keyboard key associated with start.

Share this post


Link to post
Share on other sites
il y a 14 minutes, ducon2016 a dit :

Read the post above from Legend80. To continue you need to use the keyboard key associated with start.

thanks got it:)

now i will try to find some cheat codes for wepaons...they really dont give you a lot of machine gun bullets in this hehe.

Share this post


Link to post
Share on other sites
En 07/04/2020 a las 15:53, punkdark2000 dijo:

To enable blood, press the "O" key and go to the Game Settings option, the "Gore" option and change to Yes.

 

Hi, when I activate the blood option, I can't leave the menu, what to do?

I can only get out by deactivating the blood.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×