Jump to content

[TUTO] Initial D Stage Zero Arcade - how to setup and play (Nvidia & AMD Cards working)


sky2310
 Share

Recommended Posts

15 minutes ago, bryhud said:

Anyone have this working with a G27 wheel? If so could you share your segatools.ini please?

 

Thanks!

Try this possibly? Someone had used it before but I don't have a G27 but I believe this may work, you can check and confirm by confirming the keys.

[dinput]
; Name of the DirectInput wheel to use (or any text that occurs in its name)
; Example: TMX
;
; If this is left blank then the first DirectInput device will be used.
deviceName=G27
; Name of the positional shifter to use (or any subset thereof).
; Leave blank if you do not have a positional shifter; a positional shifter
; will be simulated using the configured Shift Down and Shift Up buttons
; in this case.
;
; Can be the same device as the wheel.
;
; Example: T500
shifterName=G27
; Pedal mappings. Valid axis names are:
;
; X, Y, Z, RX, RY, RZ, U, V
;
; (U and V are old names for Slider 1 and Slider 2).
; The examples below are valid for a Thrustmaster TMX.
brakeAxis=RZ
accelAxis=Y
; DirectInput button numbers to map to menu inputs. Note that buttons are
; numbered from 1; some software numbers buttons from 0.
start=18
viewChg=16
; Button mappings for the simulated six-speed shifter.
;shiftDn=1
;shiftUp=2
; Button mappings for the positional shifter, if present.
gear1=9
gear2=10
gear3=11
gear4=12
gear5=13
gear6=14

Some of this might be off, so please try this and or confirm the numbers to see if it works.

Link to comment
Share on other sites

 
  • Replies 720
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

 
6 hours ago, bryhud said:

Thanks I will try it

 

* Update *

This worked, changed the buttons to fit my needs but good to go, Thanks

Cool, glad that worked, yea I wasn't sure what buttons people use so that was just base.

Link to comment
Share on other sites

 
 
 

Paramètres pour volant Driving Force GT 

 

io3]
; Input API selection for JVS input emulator.
; Set "xinput" to use a gamepad and "dinput" to use a steering wheel.
mode=dinput
; Automatically reset the simulated shifter to Neutral when XInput Start is
; pressed (e.g. when navigating menus between races).
autoNeutral=1

[dinput]
; Name of the DirectInput wheel to use (or any text that occurs in its name)
; Example: TMX
;
; If this is left blank then the first DirectInput device will be used.
deviceName=GT

; Name of the positional shifter to use (or any subset thereof).
; Leave blank if you do not have a positional shifter; a positional shifter
; will be simulated using the configured Shift Down and Shift Up buttons
; in this case.
;
; Can be the same device as the wheel.
;
; Example: T500
shifterName=GT
; Pedal mappings. Valid axis names are:
;
; X, Y, Z, RX, RY, RZ, U, V
;
; (U and V are old names for Slider 1 and Slider 2).
; The examples below are valid for a Thrustmaster TMX.
brakeAxis=Y
accelAxis=RZ
; DirectInput button numbers to map to menu inputs. Note that buttons are
; numbered from 1; some software numbers buttons from 0.
start=3
viewChg=10
; Button mappings for the simulated six-speed shifter.
shiftDn=1
shiftUp=2
; Button mappings for the positional shifter, if present.
gear1=1
gear2=2
gear3=3
gear4=4
gear5=5
gear6=6
 

Link to comment
Share on other sites

 
 
 

@garfield63 I don't think that can be changed as far as I understand, it is hardcoded in segatools.ini. Maybe in a later version it might be available, but at the moment it is not.

 

@payarx Do you get the other small Direct 3D window with the All.Net stuff as well or does that not even load up? I assume that it is failing before this. Could you post the info from the command prompt that injects all the data? 

Link to comment
Share on other sites

 
 
 
 
6 hours ago, payarx said:

you mean this?

캡처.JPG

Can't see what you mean... Too small of image.

 

@gojirien

You need to disable your DVD drive. The system does not like it being enabled. Go to Start > type: device manager > Find your DVD Drive, right click it, and choose disable. After you disable it, rerun and that error should be gone.

Link to comment
Share on other sites

 

@Kobe46 mate i tried everything for the saving the game but i am unable to enable saving process. i cant find the enter button. i tried start button, view change insert coin nothing is working. i am using ps3 controller, can you help me how to use save option. thanks

Link to comment
Share on other sites

 
2 minutes ago, kamranijaz said:

@Kobe46 mate i tried everything for the saving the game but i am unable to enable saving process. i cant find the enter button. i tried start button, view change insert coin nothing is working. i am using ps3 controller, can you help me how to use save option. thanks

Press start on controller.

Press and hold the "Enter" key on the keyboard. Once the card is created, then to exit properly:

Press 1 on keyboard, then press 2 on the keyboard to navigate the menu, navigate to "System Test Menu" and then Press 1 again to accept. Select yes in next screen. This will exit the game properly.

Edited by Kobe46
Link to comment
Share on other sites

 
10 hours ago, Kobe46 said:

Can't see what you mean... Too small of image.

 

@gojirien

You need to disable your DVD drive. The system does not like it being enabled. Go to Start > type: device manager > Find your DVD Drive, right click it, and choose disable. After you disable it, rerun and that error should be gone.

Everything goes well, One thing is there comes ERROR 919 in comment prompt

Link to comment
Share on other sites

 
1 hour ago, payarx said:

Everything goes well, One thing is there comes ERROR 919 in comment prompt

I am not sure I understand?

 

Is it working, but you get that error 0919?

 

If you get that error, please follow the steps I provided to gojirien to fix that issue. If it is not a real DVD drive, and a virtual one. Just disable the virtual drive.

Link to comment
Share on other sites

 
9 hours ago, Kobe46 said:

Press start on controller.

Press and hold the "Enter" key on the keyboard. Once the card is created, then to exit properly:

Press 1 on keyboard, then press 2 on the keyboard to navigate the menu, navigate to "System Test Menu" and then Press 1 again to accept. Select yes in next screen. This will exit the game properly.

kool thanks mate now it is much more clear what to do :heart-pixel::timide:

Link to comment
Share on other sites

 
On 11/22/2019 at 8:29 PM, gojirien said:

I get error 0919 when loading the game, says "leave DVD drive connected" or something like that.

 

My DVD drive is connected^^.

20191122_160258.jpg

 

Go to Devices and click on DVD drives and disable any virtual drives then it will work. Remember to activate it again once done. 

Link to comment
Share on other sites

 
7 hours ago, Kobe46 said:

I am not sure I understand?

 

Is it working, but you get that error 0919?

 

If you get that error, please follow the steps I provided to gojirien to fix that issue. If it is not a real DVD drive, and a virtual one. Just disable the virtual drive.

If I run Start.bat, there comes 919ERROR on command prompt. and after few second, Direct 3D comes out. (black screen with  No response.) And It disapears after few moment:( 

Edited by payarx
Link to comment
Share on other sites

 
il y a 41 minutes, payarx a dit :

If I run Start.bat, there comes 919ERROR on command prompt. and after few second, Direct 3D comes out. (black screen with  No response.) And It disapears after few moment:( 

 

Probably same issue as me. You have to desactivate your DVD drive.

Link to comment
Share on other sites

 
 
34 minutes ago, gojirien said:

Ok, thabks Kobe and sky2310, Error 0919 gone :).

 

Now i'm getting Error 8114 (ALLNET connection failed). Just verified my IPV4 adress, I put the correct one.

 

 

20191123_125936.jpg

 

Make sure you are using the files from the Plugins package. 

Link to comment
Share on other sites

 

Nodejs seems to encounter issue when installing additionnel tools. It is stuck.

 

Also in minime, i still have the following(corresponding step 11 and 12 of the tutorial) :

 

app:switchboard HOST_EXT: 127.0.0.1 (Service host name sent to clients) +0ms
  app:switchboard HOST_INT: 0.0.0.0 (Bind address) +4ms
  app:switchboard Using default host names, change them from the .env file if necessary. +0ms
Startup OK
events.js:187
      throw er; // Unhandled 'error' event
      ^

Error: listen EACCES: permission denied 0.0.0.0:80
    at Server.setupListenHandle [as _listen2] (net.js:1283:19)
    at listenInCluster (net.js:1348:12)
    at doListen (net.js:1487:7)
    at processTicksAndRejections (internal/process/task_queues.js:81:21)
Emitted 'error' event on Server instance at:
    at emitErrorNT (net.js:1327:8)
    at processTicksAndRejections (internal/process/task_queues.js:80:21) {
  code: 'EACCES',
  errno: 'EACCES',
  syscall: 'listen',
  address: '0.0.0.0',
  port: 80
}

 

 

Édit : seems i have another issue, the game screen turns black as soon as i click on it. Weird.

Edited by gojirien
Link to comment
Share on other sites

 
 
 
5 hours ago, gojirien said:

Nodejs seems to encounter issue when installing additionnel tools. It is stuck.

 

Also in minime, i still have the following(corresponding step 11 and 12 of the tutorial) :

 

app:switchboard HOST_EXT: 127.0.0.1 (Service host name sent to clients) +0ms
  app:switchboard HOST_INT: 0.0.0.0 (Bind address) +4ms
  app:switchboard Using default host names, change them from the .env file if necessary. +0ms
Startup OK
events.js:187
      throw er; // Unhandled 'error' event
      ^

Error: listen EACCES: permission denied 0.0.0.0:80
    at Server.setupListenHandle [as _listen2] (net.js:1283:19)
    at listenInCluster (net.js:1348:12)
    at doListen (net.js:1487:7)
    at processTicksAndRejections (internal/process/task_queues.js:81:21)
Emitted 'error' event on Server instance at:
    at emitErrorNT (net.js:1327:8)
    at processTicksAndRejections (internal/process/task_queues.js:80:21) {
  code: 'EACCES',
  errno: 'EACCES',
  syscall: 'listen',
  address: '0.0.0.0',
  port: 80
}

 

 

Édit : seems i have another issue, the game screen turns black as soon as i click on it. Weird.

That first error indicates that it is either installed already or you are getting permission denied on accessing port 80 on your machine. Are you running any website from your machine as well? If not is this when you do it from scratch? or following steps overwriting old stuff?

 

Try running start.bat from minime with admin?

 

That 2nd part about the clicking on screen. Whenever you move your focus or click elsewhere, the screen goes black. That is normal for this game sadly. So usually leave the window alone, since it always brings that window upfront, I just leave it as is and let it load.

Link to comment
Share on other sites

 
4 hours ago, payarx said:

No.. I cant even run games.. Not 0919, just 919 error :(

that is the same error, the 0919 is the same as 919.

If you have a DVD, you need to disable it because the game see's it is enabled, it will not run. 

If you have a Virtual Drive for mounting ISO/images, you need to disable that since it is the same as a DVD drive. Commonly used is Daemontools or clonedvd. with virtual drive, you need ti disable it via the software.

 

Steps to disable DVD drive

You need to disable your DVD drive. The system does not like it being enabled. Go to Start > type: device manager > Find your DVD Drive, right click it, and choose disable. After you disable it, rerun and that error should be gone.

 

Disable this first then run start.bat and see if you get further.

 

Link to comment
Share on other sites

 
4 hours ago, subaru052003@yahoo.com.tw said:

error help

00.png

May need more information, that error can be a couple of things.

1. Permissions on your game folder is read-only. Make sure you make it not read-only.

2. before you get the accounting error text over and over again, you should have a bunch of stuff running. Can you take screenshot of everything before the Cannot get accounting info.....

3. Getting that info before that error will provide the initial error message.

4. What version of Windows are you on, Windows 10 build 1903?

 

Update: I saw your other post on main thread. I saw the error. looks like Error 800, that means IP Address and or subnet is incorrect in your Segatools.ini, if you could please post your segatools, and confirm IP Address?

Edited by Kobe46
Link to comment
Share on other sites

 
9 hours ago, Kobe46 said:

可能需要更多信息,該錯誤可能是兩件事。

1.遊戲文件夾上的權限是只讀的。確保您將其設置為非只讀。

2.一遍又一遍地獲得會計錯誤文本之前,您應該運行一堆東西。您能否在無法獲取會計信息之前拍攝所有內容的屏幕截圖.....

3.在該錯誤之前獲取該信息將提供初始錯誤消息。

4.您使用的Windows是哪個版本,Windows 10 build 1903?

 

更新:我在主線程上看到了您的其他帖子。我看到了錯誤。看起來像錯誤800,這表示您的Segatools.ini中的IP地址和/或子網不正確,如果可以的話,請發布您的segatools,並確認IP地址?

 

segatools.ini

Link to comment
Share on other sites

 
 
 
 
 

@subaru052003@yahoo.com.tw

I think you are having issues with permission, your screenshots are low resolution. You can try Snipping Tool to take screenshots.

 

Can you make sure the C:\SDFF_1.31.00\ folder is not read only?

I have not seen that one specifically so make sure that you can access the amdaemon.exe.

Link to comment
Share on other sites

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share


×
  • Create New...