Jump to content
Harry99710

[Arcade PC] Initial D Arcade Stage Zero (Sega Nu 2)

Recommended Posts

 

On 11/13/2019 at 2:41 AM, Legend_of_Street said:

image.png.8e634ce8e03324d3f38a719ed4bf22e3.png

HHow do I fix this error?
Error 0919
DVD drive remains connected

 

On 12/24/2019 at 2:27 AM, Kobe46 said:

Disable your DVD drive, if you have one. if not disable your virtual drive.

 

On 12/24/2019 at 2:19 AM, Kurokaze said:

Error 0919

 

For those with error 0919 who do not want to disable their DVD drive just for this, here is the fix: patch amdaemon.exe, offset 0x22553A, replace 0x74 by 0xEB. You can now play the game with a DVD drive enabled.

Edited by ducon2016

Share this post


Link to post
Share on other sites
On 11/19/2019 at 1:47 AM, petje said:

Fullscreen.exe is here

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

On 11/19/2019 at 10:56 AM, NoKey said:

For fullscreen gameplay, dont forget to use Borderless Gaming 6.5. I love this version. Easy to use. I forgot to include it in the archive file. :D

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

On 11/13/2019 at 11:03 AM, Mindtwista said:

it worked for me without download and install visual studio.. the only thing that doesn‘t work for me is fullscreen

 

There is no need for extra programs to make the game run in fullscreen. Patch InitialD0_DX11_Nu.exe: Offset 0x35E205, 01 becomes 03.  Offset 0xA3A05F, C8 00 becomes 00 10.

Edited by ducon2016

Share this post


Link to post
Share on other sites
7 hours ago, ducon2016 said:

 

 

For those with error 0919 who do not want to disable their DVD drive just for this, here is the fix: patch amdaemon.exe, offset 0x225534, replace 0x74 by 0xEB. You can now play the game with a DVD drive enabled.

Thanks, it's nice to not have to disable the DVD drive everytime.

Share this post


Link to post
Share on other sites

I have error 8306, so the game works but I cannot save. Everything else seem to work fine with minime 10 and segatools 4. I removed the read only on all files too. Not sure what is going on. Anyone can help?

Edited by ducon2016

Share this post


Link to post
Share on other sites
On 22/12/2019 at 7:59 AM, mell_tan said:

how can I change host ip adress on minime?

it is in the switchboard.js file in the minime folder.

 

Share this post


Link to post
Share on other sites

I don't like the new music style (pop rock Jap). I prefer the eurobeat it's more dynamic! And the driving is horrible compared to the other versions.

For me the best Initial D is the 6 for the music and the driving.

Share this post


Link to post
Share on other sites
vor 16 Stunden schrieb ducon2016:

 

 

 

There is no need for extra programs to make the game run in fullscreen. Patch InitialD0_DX11_Nu.exe: Offset 0x35E205, 01 becomes 03.  Offset 0xA3A05F, C8 00 becomes 00 10.

the game is now fullscreen, but it is too slow now and not playable :/

Share this post


Link to post
Share on other sites
16 hours ago, ducon2016 said:

 

 

 

There is no need for extra programs to make the game run in fullscreen. Patch InitialD0_DX11_Nu.exe: Offset 0x35E205, 01 becomes 03.  Offset 0xA3A05F, C8 00 becomes 00 10.

 

Thx. I will try as soon as possible.

Share this post


Link to post
Share on other sites
38 minutes ago, PolybiusExtreme said:

the game is now fullscreen, but it is too slow now and not playable :/

The patch only hides the title bar and shows the window maximized, it should not have an impact on performance. You must have other stuff running. If it does not work for you, just do not patch :D

Share this post


Link to post
Share on other sites
12 hours ago, ducon2016 said:

I have error 8306, so the game works but I cannot save. Everything else seem to work fine with minime 10 and segatools 4. I removed the read only on all files too. Not sure what is going on. Anyone can help?

 

If the game works without error, should ServerBoxD8_Nu_x64.exe be running in the background or something? It never runs for me.

 

Below is my minime log

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

My inject log

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by ducon2016

Share this post


Link to post
Share on other sites

@ducon2016

 

Do you not get the ServerBoxD8_Nu_x64.exe when the InitialD0_DX11_Nu.exe runs, it should run a smaller direct 3d window with the server information as to when your amdaemon does the download from there. What does your amdaemon.exe show you?

 

Update: Could you check your segatools to make sure your dipsw1=1 and not set to dipsw1=0?

Edited by Kobe46

Share this post


Link to post
Share on other sites
24 minutes ago, Kobe46 said:

@ducon2016

 

Do you not get the ServerBoxD8_Nu_x64.exe when the InitialD0_DX11_Nu.exe runs, it should run a smaller direct 3d window with the server information as to when your amdaemon does the download from there. What does your amdaemon.exe show you?

 

Update: Could you check your segatools to make sure your dipsw1=1 and not set to dipsw1=0?

 

Nope I do not have ServerBoxD8_Nu_x64.exe running on this PC. I added the amdaemon log. Yes confirming 

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Ok so it seems the problem is related to the ServerBox exe not running. Can you confirm you have it running in the background while the game runs?

Share this post


Link to post
Share on other sites

I do have it running in background.

My mistake, this happens like so intialD0_DX11.exe starts up (as in the Initializing) starts up. Right after I get stuff on the screen then the serverbox loads up at this time. It is a smaller direct3D window. The odd thing is it looks like it is downloading properly.

 

start NET deliver.
App Image    - Download Status: 100
Option Image - Download Status: 100

and also when  you get

Clock: Blocked timezone update
Clock: Blocked system time update
Clock: Blocked system time update

image.png.d751db00aebc01dd6039acc8a7537d27.png

 

It definitely loads this up.

Share this post


Link to post
Share on other sites
1 hour ago, Kobe46 said:

I do have it running in background.

My mistake, this happens like so intialD0_DX11.exe starts up (as in the Initializing) starts up. Right after I get stuff on the screen then the serverbox loads up at this time. It is a smaller direct3D window. The odd thing is it looks like it is downloading properly.

 


start NET deliver.
App Image    - Download Status: 100
Option Image - Download Status: 100

and also when  you get


Clock: Blocked timezone update
Clock: Blocked system time update
Clock: Blocked system time update

image.png.d751db00aebc01dd6039acc8a7537d27.png

 

It definitely loads this up.

 

Interesting. Can you check if the small window remains during the game too? I guess it does. Now I need to find out why it does not load or why it closes prematurely.

 

Share this post


Link to post
Share on other sites

So when you load the game and it actually starts like it does in my screenshot. When you alt tab, there is no 2nd Direct3D window? hmm that means it is not running. Check your start.bat to confirm if that line is still there that runs serverbox.exe if it is there, then start to bat seems to run. I wonder if there is an issue loading it. Just curious, what if you set the Serverbox executable to run as admin under the compatibility tab in properties. Then run start.bat to see if it loads or if you get an error?

Share this post


Link to post
Share on other sites
29 minutes ago, Kobe46 said:

So when you load the game and it actually starts like it does in my screenshot. When you alt tab, there is no 2nd Direct3D window? hmm that means it is not running. Check your start.bat to confirm if that line is still there that runs serverbox.exe if it is there, then start to bat seems to run. I wonder if there is an issue loading it. Just curious, what if you set the Serverbox executable to run as admin under the compatibility tab in properties. Then run start.bat to see if it loads or if you get an error?

 

No 2nd window no. I do NOT have anything in the bat that runs serverbox. Yes I tried to set Serverbox as admin, still the same.

 

My start.bat only runs InitialD0_DX11_Nu.exe and amdaemon.exe

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Share this post


Link to post
Share on other sites

@ducon2016 sorry, it is late here. my mistake. the start.bat should not have it there.

So i tried setting it as admin and it did not load for me. Though when i turned it run as admin off it worked. are you running stat.bat as admin? if so try normal.

 

last part is make sure you run inject.exe as admin once. then remove it.

 

then make sure serverbox exe is not running as admin and try again?

Share this post


Link to post
Share on other sites
On 2020. 1. 4. at 3:07 AM, piotr25691 said:

I did the tutorial.

Now minime launches and the game window appears and it stays black.

Meanwhile in the console it spams "Cannot get accounting info."

You should set your Window user name as 'English'

Share this post


Link to post
Share on other sites
On 14.1.2020 at 5:37 AM, ducon2016 said:

 

 

 

 

For those with error 0919 who do not want to disable their DVD drive just for this, here is the fix: patch amdaemon.exe, offset 0x22553A, replace 0x74 by 0xEB. You can now play the game with a DVD drive enabled.

How do I patch the exe?

Share this post


Link to post
Share on other sites
vor 18 Stunden schrieb ducon2016:

The patch only hides the title bar and shows the window maximized, it should not have an impact on performance. You must have other stuff running. If it does not work for you, just do not patch :D

can anyone send me working fullscreen patched InitialD0_DX_Nu.exe, please?

@NoKey did it worked for you? maybe you can send me the patched exe?

Edited by PolybiusExtreme

Share this post


Link to post
Share on other sites
9 hours ago, Kobe46 said:

@ducon2016 sorry, it is late here. my mistake. the start.bat should not have it there.

So i tried setting it as admin and it did not load for me. Though when i turned it run as admin off it worked. are you running stat.bat as admin? if so try normal.

 

last part is make sure you run inject.exe as admin once. then remove it.

 

then make sure serverbox exe is not running as admin and try again?

 

Can you confirm if the server window is still there during the game or just during the init? I could see a small window opening temporarily but then AIME in the log is shown closing. So that might be what triggers the termination of the process.

 

Yes I tried to add/remove admin rights to exes, still same problem

 

Do you have the following in your node log?

 

 app:aimedb:decoder Decode {"type":"goodbye"} +5ms app:aimedb:ops Goodbye +5ms app:aimedb:session Closing connection +22ms app:aimedb:session Connection closed +3ms

Edited by ducon2016

Share this post


Link to post
Share on other sites

unknown.png

 

Still same. I tried Boomslang Minime folder too, same issue. Tried minime-v007 and segatools v2. Same issue. I tried to disable the window firewall, same issue. Any suggestions welcome

Share this post


Link to post
Share on other sites
On 12/29/2019 at 1:24 AM, glth7258 said:

anywrong with these? i have error 8306 and cannot use card, i cannot solve it...beg your help, thx a lot

 

Fixed 8306!!!!

 

Thanks to @Boomslangnz and @Kobe46 I confirmed that ServerBoxD8_Nu_x64.exe was crashing on my machine. After looking into it, it was a dinput initialization issue!!!

 

So to fix Error 8306, I had to put the x64 version of dinput8.dll from devreorder (

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
) and hide the devices that I did not use.

 

Edited by ducon2016

Share this post


Link to post
Share on other sites

anyone got the fullscreen patch from ducon to work and want to share the patched exe to the community? it would be really nice if someone can help me and other members :) 

 

Offset 0x35E205, 01 becomes 03. works for me. 

Offset 0xA3A05F, C8 00 becomes 00 10. dont work for me - slowdown ingame :/ 

anyone have a solution, please?

Share this post


Link to post
Share on other sites
52 minutes ago, PolybiusExtreme said:

anyone got the fullscreen patch from ducon to work and want to share the patched exe to the community? it would be really nice if someone can help me and other members :) 

 

Offset 0x35E205, 01 becomes 03. works for me. 

Offset 0xA3A05F, C8 00 becomes 00 10. dont work for me - slowdown ingame :/ 

anyone have a solution, please?

 

To be clear C8 becomes 00, and 00 becomes 10.

 

Try 00 11, or 00 80, or 00 40. If you still have a slow down try the other fullscreen solutions posted in this thread.

Edited by ducon2016

Share this post


Link to post
Share on other sites
vor 28 Minuten schrieb ducon2016:

 

To be clear C8 becomes 00, and 00 becomes 10.

 

Try 00 11, or 00 80, or 00 40. If you still have a slow down try the other fullscreen solutions posted in this thread.

 

thank you :)
will try it

 

00 80 work for me :)  thanks again for your help
how did you find the hex values? is there a trick for it?

Edited by PolybiusExtreme

Share this post


Link to post
Share on other sites
52 minutes ago, PolybiusExtreme said:

 

thank you :)
will try it

 

00 80 work for me :)  thanks again for your help
how did you find the hex values? is there a trick for it?

 

If you disassemble the code with IDA or x64dbg, you can see that this is the place in the file where the value of dwStyle for the CreateWindow is stored. The numbers I gave you correspond to different windows styles documented here:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by ducon2016

Share this post


Link to post
Share on other sites
3 hours ago, ducon2016 said:

If you disassemble the code with IDA or x64dbg, you can see that this is the place in the file where the value of dwStyle for the CreateWindow is stored. The numbers I gave you correspond to different windows styles documented here:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Could this also work on Border Break Scramble ?

Because this game only works windowed

No idea what to edit in what file

 

Share this post


Link to post
Share on other sites
7 hours ago, petje said:

Could this also work on Border Break Scramble ?

Because this game only works windowed

No idea what to edit in what file

 

You can try. Open the .exe in IDA, go into the imports tab, search for CreateWindow flavors (there can be different ones). Press X to see the reference, then again X on the code itself to find calls to it. Look at the calls one by one and the values used for style. Then find the matching location in the .exe and try to patch.

 

Come chat on discord, I can teach you step by step

Edited by ducon2016

Share this post


Link to post
Share on other sites

question bête mais vaut mieux la poser quand même...  :rolleyes:

 

Quelqu'un aurait par hasard une version click & play prête à partager ?

 

sait on jamais ....  ^_^

 

 

big THX!

Share this post


Link to post
Share on other sites
Le 2020. 01. 14. à 07:27, ducon2016 a dit :

There is no need for extra programs to make the game run in fullscreen. Patch InitialD0_DX11_Nu.exe: Offset 0x35E205, 01 becomes 03.  Offset 0xA3A05F, C8 00 becomes 00 10.

 

can you make a patch for d3d11 so that it won't use reference mode? barely any overlays\wrappers work because of it :( (and also maybe it would speed up startup time, it maybe wouldn't recompile every shader at each run)

Share this post


Link to post
Share on other sites

idem ;-)

 

Quelqu'un aurait par hasard une version click & play prête à partager ?

 

Merki 

Share this post


Link to post
Share on other sites
On 1/18/2020 at 12:14 AM, hunterGray21 said:

Windows 10 is still required for running this?

No windows 8 has always worked fine for running it. In fact it seems to work in full screen natively without any fuckary on 8. The only versions that do not work is <7

 

You can also use a loopback adapter and run the entire thing without even having a network card. Just make up a static ip for it and bind it in stools config the same way you normally do. In fact I would recommend that method for most people as it is not reliant on a dhcp reservation, or even a network connection for that matter (ethernet or wifi). It is all self contained on your machine and even portable if you like so you can bring it to a friends house or public place without messing with their network.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×