Jump to content
palitroque

[Arcade PC] Dance Dance Revolution A20 (Konami)

Recommended Posts

2 hours ago, mrkruppy13 said:

I tried and it said, "system cannot find the file specified windows 10"

Check out step 6 here: 

I'm still working through a bunch of things myself so can't help too much more than that.

Share this post


Link to post
Share on other sites

Been having some difficulty getting everything running with Butterfly. Despite getting the server working and everything looking correct, when I hold "+" I get the "network is busy" error and cannot progress. Looking at the spice logs, I see the attached error. Is something going on with "cardmng"?

card issues.png

Share this post


Link to post
Share on other sites
On 1/11/2020 at 2:46 PM, Darkogazza said:

Been having some difficulty getting everything running with Butterfly. Despite getting the server working and everything looking correct, when I hold "+" I get the "network is busy" error and cannot progress. Looking at the spice logs, I see the attached error. Is something going on with "cardmng"?

card issues.png

Try restarting your butterfly.

Edited by johnjorell

Share this post


Link to post
Share on other sites
12 hours ago, johnjorell said:

Try restarting your butterfly.

No dice unfortunately. I've tried restarting butterfly, but I think what's going on is the server is up but the emulator isn't trying to connect to it for some reason. Despite changing all of the ea3-config parameters to have the server use http://localhost I'm not seeing any activity on the butterfly server that indicates it's being hit. Is there some config entry I'm missing? What's suspicious is that in the emulator it shows "ONLINE" but then every time I hit "+" it gives me the "network is busy" error. Pretty sure if I can get this step to work then that will be everything.

Share this post


Link to post
Share on other sites
2 hours ago, Darkogazza said:

No dice unfortunately. I've tried restarting butterfly, but I think what's going on is the server is up but the emulator isn't trying to connect to it for some reason. Despite changing all of the ea3-config parameters to have the server use http://localhost I'm not seeing any activity on the butterfly server that indicates it's being hit. Is there some config entry I'm missing? What's suspicious is that in the emulator it shows "ONLINE" but then every time I hit "+" it gives me the "network is busy" error. Pretty sure if I can get this step to work then that will be everything.

Did you modify the sqlite data? Make sure the card data is syntactically accurate or if you have a text file for the card ID, ensure it is in the correct format.

 

I am also curious about more up-to-date base a20 data as seen in these a20 special edition videos

Share this post


Link to post
Share on other sites
7 hours ago, Romboyz said:

Did you modify the sqlite data? Make sure the card data is syntactically accurate or if you have a text file for the card ID, ensure it is in the correct format.

I figured it out. It turns out, using the script included in the "File Fix" (titled "gamestart-spice") instead of using regular spicetools was somehow breaking the localhost connectivity of the entire setup. Using just vanilla spicetools got the job done.

 

7 hours ago, Romboyz said:

I am also curious about more up-to-date base a20 data as seen in these a20 special edition videos

I would love to see this as well. I very much enjoy the A20 build here but would love to see the Special Edition. A tutorial on how to add my own song data would also be amazing, since it seems like the ability to do so exists.

Share this post


Link to post
Share on other sites
hace 7 horas, Darkogazza dijo:

I figured it out. It turns out, using the script included in the "File Fix" (titled "gamestart-spice") instead of using regular spicetools was somehow breaking the localhost connectivity of the entire setup. Using just vanilla spicetools got the job done.

 

I would love to see this as well. I very much enjoy the A20 build here but would love to see the Special Edition. A tutorial on how to add my own song data would also be amazing, since it seems like the ability to do so exists.


I haven't had much time lately, I hope I can do the tutorial on how to add your songs, it's not that complex, but it should be well explained

Share this post


Link to post
Share on other sites
3 hours ago, polivosm said:


I hope I can do the tutorial on how to add your songs, it's not that complex, but it should be well explained

That would be awesome; thank you for that. Where did you get the blue a20 dump from though? Is it actually 2020 data?

Share this post


Link to post
Share on other sites
9 hours ago, polivosm said:


I haven't had much time lately, I hope I can do the tutorial on how to add your songs, it's not that complex, but it should be well explained

Add me to the list that would also greatly appreciate a tutorial here.

I'm also interested in the Blue A20 build. I'm not sure if people are just replacing certain assets with the A20 assets and simply using their own song data to make an "A20" folder or what.

Share this post


Link to post
Share on other sites
hace 13 minutos, Darkogazza dijo:

Add me to the list that would also greatly appreciate a tutorial here.

I'm also interested in the Blue A20 build. I'm not sure if people are just replacing certain assets with the A20 assets and simply using their own song data to make an "A20" folder or what.


real a20 blue, korean data

Share this post


Link to post
Share on other sites
17 hours ago, polivosm said:


real a20 blue, korean data

I assume that it's not publicly distributed? In the market for up-to-date data

Share this post


Link to post
Share on other sites

I would love to get the blue A20 build at some point as well, though I guess the best would be if I could create my own song data in the build. That would be incredible.

As an aside, how exactly are these dumps curated? I feel like cracking one of these cabs to get this data wouldn't be trivial.

Share this post


Link to post
Share on other sites

5-2503-0000

Please adjust the clock.


How to fix?

 

I have F1 as Test and F2 as Service however when I press F1 on this screen, nothing happens.

 

Problem fixed, had to run config.exe as admin.

Dance Dance Revolution 30.01.2020 18_17_10.png

Edited by piotr25691

Share this post


Link to post
Share on other sites

Do I need Butterfly?
It does not start.


C:\Users\piter\Desktop>java -Ddb_path="C:\Users\piter\Desktop\db.sqlite" -jar butterfly-1.1.0.jar
[INFO ] 2020-02-01 12:12:56.505 [main] KotlinDetector - Kotlin reflection implementation not found at runtime, related features won't be available.
[INFO ] 2020-02-01 12:12:57.150 [main] Version - HHH000412: Hibernate Core {[WORKING]}
[INFO ] 2020-02-01 12:12:57.152 [main] Environment - HHH000205: Loaded properties from resource hibernate.properties: {jdbc.username=, hibernate.dialect=com.buttongames.butterflydao.hibernate.SQLiteDialect, hibernate.show_sql=false, hibernate.bytecode.use_reflection_optimizer=false, jdbc.password=, hibernate.hbm2ddl.auto=update, jdbc.driverClassName=org.sqlite.JDBC}
[INFO ] 2020-02-01 12:12:57.358 [main] Version - HCANN000001: Hibernate Commons Annotations {5.1.0.Final}
[INFO ] 2020-02-01 12:12:57.804 [main] Dialect - HHH000400: Using dialect: com.buttongames.butterflydao.hibernate.SQLiteDialect
[INFO ] 2020-02-01 12:12:57.836 [main] LobCreatorBuilderImpl - HHH000423: Disabling contextual LOB creation as JDBC driver reported JDBC version [2] less than 4
[INFO ] 2020-02-01 12:12:58.727 [main] JtaPlatformInitiator - HHH000490: Using JtaPlatform implementation: [org.hibernate.engine.transaction.jta.platform.internal.NoJtaPlatform]
[Thread-1] INFO org.eclipse.jetty.util.log - Logging initialized @3141ms to org.eclipse.jetty.util.log.Slf4jLog
[Thread-1] INFO spark.embeddedserver.jetty.EmbeddedJettyServer - == Spark has ignited ...
[Thread-1] INFO spark.embeddedserver.jetty.EmbeddedJettyServer - >> Listening on 0.0.0.0:80
[Thread-1] INFO org.eclipse.jetty.server.Server - jetty-9.4.z-SNAPSHOT, build timestamp: 2017-11-21T22:27:37+01:00, git hash: 82b8fb23f757335bb3329d540ce37a2a2615f0a8
[Thread-1] INFO org.eclipse.jetty.server.session - DefaultSessionIdManager workerName=node0
[Thread-1] INFO org.eclipse.jetty.server.session - No SessionScavenger set, using defaults
[Thread-1] INFO org.eclipse.jetty.server.session - Scavenging every 600000ms
[Thread-1] ERROR spark.Spark - ignite failed
java.net.BindException: Address already in use: bind
        at sun.nio.ch.Net.bind0(Native Method)
        at sun.nio.ch.Net.bind(Unknown Source)
        at sun.nio.ch.Net.bind(Unknown Source)
        at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
        at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
        at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConnector.java:334)
        at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:302)
        at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80)
        at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:238)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.server.Server.doStart(Server.java:397)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at spark.embeddedserver.jetty.EmbeddedJettyServer.ignite(EmbeddedJettyServer.java:149)
        at spark.Service.lambda$init$2(Service.java:549)
        at java.lang.Thread.run(Unknown Source)

C:\Users\piter\Desktop>pause
Press any key to continue . . .

And the game will not me allow to start.

 

Dance Dance Revolution 01.02.2020 12_10_28.png

Share this post


Link to post
Share on other sites
En 30-01-2020 a las 14:17, piotr25691 dijo:

5-2503-0000

Please adjust the clock.


How to fix?

Dance Dance Revolution 30.01.2020 18_17_10.png

 

Go to service and adjust the clock (doesn't need to have an accurate time, just enter the option and save it) then go to GAME MODE to start normal. 

 

En 31-01-2020 a las 0:21, Darkogazza dijo:

Any word on getting a release for Blue A20?

I know some people have it, tbh in February could be a perfect date to leak some data 👀

 

hace 14 horas, piotr25691 dijo:

Do I need Butterfly?
It does not start.(...)

And the game will not me allow to start. 

Why are you people still having trouble get this working? I find it very weird, because it's not just one person, it's a bunch of people. 

 

Btw, without a server, you can't get the game working (you should try spice with " -ea " to play the game) The only difference with butterfly, is that's a local server which allows you to save your scores as a user. Hope you get butterfly working tbh ✌️

Edited by B4SH-T

Share this post


Link to post
Share on other sites
10 hours ago, B4SH-T said:

I know some people have it, tbh in February could be a perfect date to leak some data 👀

But we can't really tell much what update version are they going to leak it.

 

And if the A20 data their getting is it the blue A20 or the gold A20 is also what we don't know at all.

Edited by johnjorell

Share this post


Link to post
Share on other sites

I need help with the DDR A20 dump, when I go to the bemanipatcher and turn on Force Cabinet Type 6, the gold theme works but there is a black background. I already registered the dll files in the com folder and I installed ffdshow. Also, the music videos work fine, it's just the menu background is black instead of gold. (Without the cabinet type 6, DDR A has the typical cloud background)

Edited by ddrfan2020

Share this post


Link to post
Share on other sites
hace 5 horas, ddrfan2020 dijo:

I need help with the DDR A20 dump, when I go to the bemanipatcher and turn on Force Cabinet Type 6, the gold theme works but there is a black background. I already registered the dll files in the com folder and I installed ffdshow. Also, the music videos work fine, it's just the menu background is black instead of gold. (Without the cabinet type 6, DDR A has the typical cloud background)

The obvious reason why this happens is because you haven't registered the dlls. 

 

BUT if you say you can watch the background videos for songs during the game, maybe:

1) You haven't enabled the option in mon's patcher: "Force ENDYMION menu bg" and "Skip A20 menu bg loading"

*I think you need to check "Enable Cabinet lights for cabinet type 6" option too

2) The file doesn't exist in the movie/background (which references the one from Endymion). *Do you have the one which the clouds are red and they are super fast? 

3) The gamemdx is referencing another video for the cabinet type 6 which you don't have

Edited by B4SH-T

Share this post


Link to post
Share on other sites
18 minutes ago, B4SH-T said:

The obvious reason why this happens is because you haven't registered the dlls. 

 

BUT if you say you can watch the background videos for songs during the game, maybe:

1) You haven't enabled the option in mon's patcher: "Force ENDYMION menu bg" and "Skip A20 menu bg loading"

*I think you need to check "Enable Cabinet lights for cabinet type 6" option too

2) The file doesn't exist in the movie/background (which references the one from Endymion). *Do you have the one which the clouds are red and they are super fast? 

3) The gamemdx is referencing another video for the cabinet type 6 which you don't have

I can turn on force Endymion menu bg and the red background appears fine. I also tried enable cabinet lights.

Share this post


Link to post
Share on other sites
hace 2 horas, ddrfan2020 dijo:

I can turn on force Endymion menu bg and the red background appears fine. I also tried enable cabinet lights.

So what are you expecting? This data only has the ace - endymion background, this was just a beta for A20. The real golden bg just came in future releases 🤷‍♂️

Share this post


Link to post
Share on other sites
17 hours ago, B4SH-T said:

So what are you expecting? This data only has the ace - endymion background, this was just a beta for A20. The real golden bg just came in future releases 🤷‍♂️

Ok thanks for the help anyways.

Share this post


Link to post
Share on other sites
On 2/1/2020 at 11:13 AM, piotr25691 said:

Do I need Butterfly?
It does not start.

...
java.net.BindException: Address already in use: bind 

...

 

Sorry just noticed this....

You have some web server or something that is using port 80 and the error message tells you. That is why butterfly is not working. Don't run ealocal or spicetools -ea .

Share this post


Link to post
Share on other sites
On 1/13/2020 at 9:56 AM, polivosm said:


I haven't had much time lately, I hope I can do the tutorial on how to add your songs, it's not that complex, but it should be well explained

How are you able to add everything without the game crashing?  I'm assuming you have a workaround for the game not having enough memory I guess, eager to hear of any progress :very-good:

Share this post


Link to post
Share on other sites

arcana has all of konami 50th anniversary song and some ddr a20 legend music, but i using this i can't access that music. HOW to access somg music?(cartoon herose 20th mix...etc)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×