Jump to content
linglang

[Tuto] virtua Fighter 5C How to Install and full screen.

Recommended Posts

On 20/11/2020 at 7:57 AM, karadaniano said:

hi,

i see nobody talks about this but after beating dural and the end credits, the game crashes (it closes itself withouth a warning, message or log)

is this something common with this game or am i doing something wrong?

another bug i'm having is that the fences of some stages are invisible (i'm an AMD user)

Did you grab the AMD fix?

Share this post


Link to post
Share on other sites

I have to be dumb as a rock. I've done the following:

  • extraced the vf5c to "..\\teknoparrot\games\Virtua Fighter 5 Rev C\"
  • Created a folder within "disk0" titles "rom"
  • Extracted vf5c_rom to "rom"
  • Extracted the Nvidia shader fix to the game folder so it gets dropped into the rom folder and allowed it overwrite at the prompts
  • Added vf5 to TP
  • Test launched it and got the "Ack Sync Code" error

Then it launches to a black screen and nothing else happens. I have started from scratch twice now and...nada. Could someone clarify if I am doing this correctly or am I missing an important step?

Edit: I have gotten it to launch via TP

  • I am currently on 1.0.0.528.
  • attempting to use 1.0.0.122 as it is the closest version I could find going by the GLARH config screenshot from above (.125 and cannot find v.201 AT ALL)
  • Using GLARH v334

When I start the game using TP, I get pic and sound, however when I start using GLARH, I get only a black screen with the steam pop up in the corner.  If someone could provide me a link to TP .201, I would be ever so grateful. Thank you in advance and thank you OP for the work you have put into helping us.

Edited by Ctindell81
Updating info

Share this post


Link to post
Share on other sites

May I know how to set up VF5C correctly? I copied the shader fix amd to Disk0\rom\ and patched VF5 to disk0 but TKPT would always show "ACK SYNC Code Error" and just go back to Windows desktop. Any suggestion is highly appreciated.

Share this post


Link to post
Share on other sites

EDIT:

 

I finally got it to work in a correct ratio using fullscreen mode on my 4K TV! That's pretty weird but when I use vf5 files prepared with higher resolutions, image is considered too big and I only have a part of this on screen. Maybe it's linked to desktop resolution and signal resolution... I realized my computer is now just resizing by modifing desktop resolution but not signal resolution anymore, this way my signal resolution is always 3840x2160.... I think it's because the latest drivers update. Signal resolution was changed on other games prior to this (not changing in any game now).

 

So I finally used vf5 -wsvga 1280x720, -wxga2 1366x768, cause thread author talked about 1366x768 resolution.

Under Game Loader Config , on Loader settings 1 tab, I used wsvga parameter, indicated 1280x720 for resolution and clicked on patch and save.

Under Game Loader Config, on Window size tab, I didn't touch anything, setting is set to 0 and I did not tick full screen (Windowed is unticked under TeknoParrot).

 

In fact not completely, intro video is having vertical black bands, and seems like menus are having those bands too (but not blackened). Gameplay result in a clean fullscreen... seems like it is normal. Original screenshots are in 3840x2160 like I said resolution signal is always the same ( I add an external link hosting gameplay original screenshot).

000003.jpg.1d0bf065ac5a5c041ce4b6415119e580.jpg  000004.jpg.2fce6a647e2dc3bf57f0aecb28c8ba1b.jpg000001.jpg.fbcd3ac7c4440e8d2467a56faa49202f.jpg

 

Original gameplay screenshot :

https://ibb.co/rf7VX5t

 

No other way here to have a clean fullscreen, wxga2 parameter and 1366x768 resolution was giving me an image a little bit too big (so having a part over display).

 

Le 09/03/2021 à 15:29, stanleyyeh0205 a dit :

May I know how to set up VF5C correctly? I copied the shader fix amd to Disk0\rom\ and patched VF5 to disk0 but TKPT would always show "ACK SYNC Code Error" and just go back to Windows desktop. Any suggestion is highly appreciated.

 

I have Ack SYNC Code Error too, it doesn't really seems to be an issue as game is launching and playable. I see a lot of people using Disk0 folder, my archive wasn't having Disk0 folder so I just directly put shaderfix on rom folder, that worked.

 

That being said, I hope you understood TeknoParrot can't launch this game in fullscreen, to launch it directly using TeknoParrot you need to select windowed mode.

 

That's why people here are using Game Loader All RH to perform fullscreen (in that case windowed mode can be unchecked on TeknoParrot settings).

 

My game folder (simply was like it once uncompressed), just Patch folder wasn't a part of game archive (and Game Loader All RH files too of course, I use version 379 since links to older versions are dead, only have 378 and 330 too). So I just uncompressed shaderfix archive under rom folder.

Capture.PNG.1386316cbbc14712d6b3883aaf61b705.PNG

Edited by Kleyon
Fullscreen is nearly working

Share this post


Link to post
Share on other sites
Il y a 5 heures, Kleyon a dit :

EDIT:

 

I finally got it to work in a correct ratio using fullscreen mode on my 4K TV! That's pretty weird but when I use vf5 files prepared with higher resolutions, image is considered too big and I only have a part of this on screen. Maybe it's linked to desktop resolution and signal resolution... I realized my computer is now just resizing by modifing desktop resolution but not signal resolution anymore, this way my signal resolution is always 3840x2160.... I think it's because the latest drivers update. Signal resolution was changed on other games prior to this (not changing in any game now).

 

So I finally used vf5 -wsvga 1280x720, -wxga2 1366x768, cause thread author talked about 1366x768 resolution.

Under Game Loader Config , on Loader settings 1 tab, I used wsvga parameter, indicated 1280x720 for resolution and clicked on patch and save.

Under Game Loader Config, on Window size tab, I didn't touch anything, setting is set to 0 and I did not tick full screen (Windowed is unticked under TeknoParrot).

 

In fact not completely, intro video is having vertical black bands, and seems like menus are having those bands too (but not blackened). Gameplay result in a clean fullscreen... seems like it is normal. Original screenshots are in 3840x2160 like I said resolution signal is always the same ( I add an external link hosting gameplay original screenshot).

000003.jpg.1d0bf065ac5a5c041ce4b6415119e580.jpg  000004.jpg.2fce6a647e2dc3bf57f0aecb28c8ba1b.jpg000001.jpg.fbcd3ac7c4440e8d2467a56faa49202f.jpg

 

Original gameplay screenshot :

https://ibb.co/rf7VX5t

 

No other way here to have a clean fullscreen, wxga2 parameter and 1366x768 resolution was giving me an image a little bit too big (so having a part over display).

 

 

I have Ack SYNC Code Error too, it doesn't really seems to be an issue as game is launching and playable. I see a lot of people using Disk0 folder, my archive wasn't having Disk0 folder so I just directly put shaderfix on rom folder, that worked.

 

That being said, I hope you understood TeknoParrot can't launch game in fullscreen, to launch it directly using TeknoParrot you need to select windowed mode.

 

That's why people here are using Game Loader All RH to perform fullscreen (in that case windowed mode can be unchecked on TeknoParrot settings).

 

My game folder (simply was like it once uncompressed), just Patch folder wasn't a part of game archive (and Game Loader All RH files too of course, I use version 379 since links to older versions are dead, only have 378 and 330 too). So I just uncompressed shaderfix archive under rom folder.

Capture.PNG.1386316cbbc14712d6b3883aaf61b705.PNG

Thank you so much for sharing how to set up GLARH and folder. I run GLARH. After waiting for 2 minutes, it would not do anything except showing me an error "Time Out" and quit. But after comparing your folds with mine, I realized that I didn't have "Patch" so I just created one even though there's nothing there. Instead of using GLARH, I used TKPR to load the game and it worked like a charm. May I know what files you have in Patch folder? 

Share this post


Link to post
Share on other sites

Like I said in my message, Patch folder isn't part of game archive, I use Trymado's Hyperspin files (no games included, I have to add them manually, editing TeknoParrot and RocketLauncher configurations to match mine and sometimes differents configurations for games) and he added patches for games under that folder, when there's some. So under Patch folder for VF5C I have (you can see I added executables for Game Loader All RH by his date) :

Capture1.PNG.67dc6a6b6964972de1c30150c42c46a1.PNG

 

I don't see any relation. Only thing I think of concerning TeknoParrot is WIndowed mode like I said in my message. But launching it through GLARH solve issue (windowed mode can be unticked under TeknoParrot). Anyway if you want it fullscreen you'll have to deal with GLARH.

 

PS : I have shared my settings just in case some people are in the same situation. But like I said, sometimes known working configurations aren't working for me... sometimes I have to use a completely different one... so maybe it is the case for you here. For example some directly tick fullscreen mode on GLARH's Window size tab, I don't.

Edited by Kleyon

Share this post


Link to post
Share on other sites
Le 2021/3/26 à 02:58, Kleyon a dit :

For example some directly tick fullscreen mode on GLARH's Window size tab, I don't.

 

It's so funny that if I directly tick full screen mode on GLARH's Window size tab, I'd get a full screen windowed mode. I followed your setting like below and was able to see the exactly same result. I'm happy now. Thanks a million. 

 

Le 2021/3/25 à 23:24, stanleyyeh0205 a dit :

So I finally used vf5 -wsvga 1280x720, -wxga2 1366x768, cause thread author talked about 1366x768 resolution.

Under Game Loader Config , on Loader settings 1 tab, I used wsvga parameter, indicated 1280x720 for resolution and clicked on patch and save.

Under Game Loader Config, on Window size tab, I didn't touch anything, setting is set to 0 and I did not tick full screen (Windowed is unticked under TeknoParrot).

 

In fact not completely, intro video is having vertical black bands, and seems like menus are having those bands too (but not blackened). Gameplay result in a clean fullscreen... seems like it is normal. Original screenshots are in 3840x2160 like I said resolution signal is always the same ( I add an external link hosting gameplay original screenshot).

 

A few things that I'd never understand are:

1. I've downloaded the game from multiple sources, (MotherLoad of DumpsTeknoParrot RomsVirusMan, and Trymadobut none of them contains a folder called Patch (For those that still can't get the game going, please check if you have this folder under root folder. You don't need to put anything there)

2. When it comes to full screen on at least a FHD monitor, we'd just think of 1920 * 1080 but in VF5C's case, you have to go with 1280 * 720.

3. It's also possible that what works for me doesn't work for others. 

Share this post


Link to post
Share on other sites
Il y a 8 heures, stanleyyeh0205 a dit :

 

It's so funny that if I directly tick full screen mode on GLARH's Window size tab, I'd get a full screen windowed mode. I followed your setting like below and was able to see the exactly same result. I'm happy now. Thanks a million.

 

Man, I only tells what I encountered! For me, if I tick Fullscreen mode on GLARH, fullscreen isn't matching display and I lost a part of image on the right, but not using settings I posted.... on my case! My comment is all about explaining sometimes common settings aren't working for everybody! Ah and you're welcome!

 

Or did I badly understood and you are telling you have the exactly same result as me?! So not the same result as fullscreen mode?!

 

Il y a 8 heures, stanleyyeh0205 a dit :

A few things that I'd never understand are:

1. I've downloaded the game from multiple sources, (MotherLoad of DumpsTeknoParrot RomsVirusMan, and Trymadobut none of them contains a folder called Patch (For those that still can't get the game going, please check if you have this folder under root folder. You don't need to put anything there)

2. When it comes to full screen on at least a FHD monitor, we'd just think of 1920 * 1080 but in VF5C's case, you have to go with 1280 * 720.

3. It's also possible that what works for me doesn't work for others. 

 

1 - I explained the Patch folder.... it's just because I use Trymado's Hyperspin pack, there's no dump on this pack but he included existing patches.... Why making a fixation on it?! Game isn't even looking for that folder, once again, it only contains existing patches for concerned dump (HD patches, fixes, etc). In some rare case, games are containing a patch folder even on sources you listed... Again, it isn't needed for the game to work, just usefull to patch it.

2 -  Surely linked to internal resolution. Some game are originally using 720p. Some modern arcade games are just 720p.

3 - I don't understand that point too. Of course we all have different computers but I thought only difference on loading arcade dump will be GPU support (AMD/Nvidia/Intel). Seems like it's more specific than just GPU support.

I'll add a 4 - I realized sometimes, some applications can cause issues. Discord can bug and remains displayed in the foreground. So I just kill Discord when I work on TeknoParrot install. Steam can cause issues too. Some dump are including a SteamID.txt and interact with it. We can see Steam notifications when launching those games. On one of them, game was working the very first I launch it, then was crashing after that each time I pressed a button.... Finally asked myself about Steam launching pad configuration... Killed Steam, solved issue!

 

Fact you created this patch folder doesn't have any relation with the game working!

 

ERROR, CONCERN TEKKEN 7! :

Like I said, in my case, seems like this game is randomly working! I need to launch it multiple times before it launch succesfully. With exact same configuration of course. I need to understand what happens.

Edited by Kleyon

Share this post


Link to post
Share on other sites

I just wanna say that the below setting gave me the best experience. Thanks a million. Who would know 1366x768 turned out to be full screen on a FHD tv? I also saw the vertical black bands but I wouldn’t worry about it. 

 

Le 2021/3/25 à 23:24, stanleyyeh0205 a dit :

So I finally used vf5 -wsvga 1280x720, -wxga2 1366x768, cause thread author talked about 1366x768 resolution.

Under Game Loader Config , on Loader settings 1 tab, I used wsvga parameter, indicated 1280x720 for resolution and clicked on patch and save.

Under Game Loader Config, on Window size tab, I didn't touch anything, setting is set to 0 and I did not tick full screen (Windowed is unticked under TeknoParrot).

 

In fact not completely, intro video is having vertical black bands, and seems like menus are having those bands too (but not blackened). Gameplay result in a clean fullscreen... seems like it is normal.


Up until I created a Patch folder, the game hadn’t never worked. Not sure if it’s just me. Can you run the game without a Patch folder? With a Patch folder and your GLAR setting, the game always launches full screen without disappointing me.

Share this post


Link to post
Share on other sites

Ok sorry so, I misunderstood your comment, I'm happy if my comment helps someone!

 

Topic's author was talking about 1366x768 resolution but I didn't succeed to have a clean fullscreen using that one. I suppose it is because of respective displays. Here I am on a 4K 58" TV. I use the same executable but asking for wsvga mode so 1280x720.

 

Sorry I realized I mixed VF5 and Tekken 7 issues. The one randomly working for me is Tekken 7 not VF5! You can easily try, just delete Patch folder and launch game again using very same GLARH parameters ^^

Edited by Kleyon

Share this post


Link to post
Share on other sites
Il y a 1 heure, Kleyon a dit :

Ok sorry so, I misunderstood your comment, I'm happy if my comment helps someone!

 

Topic's author was talking about 1366x768 resolution but I didn't succeed to have a clean fullscreen using that one. I suppose it is because of respective displays. Here I am on a 4K 58" TV. I use the same executable but asking for wsvga mode so 1280x720.

 

Sorry I realized I mixed VF5 and Tekken 7 issues. The one randomly working for me is Tekken 7 not VF5! You can easily try, just delete Patch folder and launch game again using very same GLARH parameters ^^

 

You're right that Tekken 7 doesn't always launch smoothly. I sometimes have to try several times before it launches. I just removed the Patch folder from VF5 folder and it launches. Sorry for my ignorance and thanks for everything you've shared. 

Share this post


Link to post
Share on other sites

Don't worry about it, I understand you could have misinterpreted patch folder, I am new to Arcade dumps too so to be honest I don't know that much.

You're welcome, honestly, my pleasure if it helps! I only have posted my experience for this dump, I didn't do that much (originally I was asking for help too but finally found a way by myself... after hours of "going nuts" parameters testing lol).

You don't really have to thanks me for that. ^^

 

EDIT : In fact IT'S ME that thanks you! I am not the only one having this weird issue concerning Tekken 7.... Why nobody is talking about it on Tekken 7 tutorial?! I was asking myself if it was an issue on my side... How something can possibly randomly works?! I could understand it on console hack scene, since it use specific exploits that can sometimes be unstable and needs multiples tries to be triggered. But in that case?! I highly doubt we are hacking game each time it is launched... "Hack" here is more about decrypting dump and adding support for it on emulator, eventually a dongle hack. So "hack" part has already been done I suppose... Well, sounds like we can't do anything about it. Or maybe is it a compatibility issue that concern emulator and we can hope for a better support one day or another?!

Edited by Kleyon

Share this post


Link to post
Share on other sites
16 minutes ago, Hatsune Tomoya said:

Is there anyway to run the Virtua Fighter 5 Final Showdown?

 

Unfortunately no there isn’t any loader that support it(the arcade version)

Edited by R.R.Z.

Share this post


Link to post
Share on other sites

I would like to know is there a fix for the last stage graphical issue? NV fix copied, and still happens on a gt630...
Also in starting the dhcp search can not by bypassed other way then service button? Because that way the game creats service credits too :( 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×