Jump to content

[Tuto] Mario Kart DX Arcade GP 1.10, including banapassport save and online play, QR codes and LAN versus play !


linglang
 Share

Recommended Posts

 
  • Replies 266
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

On 12/26/2019 at 6:01 AM, iAno said:

where must the sav file be saved?  I saved the file in the root folder, nothing is unlocked

 

Does anyone know? I am also having this issue. I even created a sv folder in mkdx10 folder and placed the profile.sav file there. Thanks in advance

Link to comment
Share on other sites

 
 
  • 1 month later...

hey guys i need help to run LAN my machine (2 teknoparrot with MKDX)

87938932_241514603540459_786906934262366208_n.jpg.9294610ab3abbd983624e5f8276fd3f3.jpg

i follow the tutorial and its get worst when i assign fix ip adress

i stay at dhcp automatic

 

1st cab 

everything looks fine but see only 1 unit connected

88047500_617749428799657_2572672014301003776_n.jpg.29e7a81055e24af0378f3d2969f8d3a7.jpg88237073_207019697349578_3007291450179190784_n.jpg.e2f02517e501564b72d786b52603cab9.jpg

 

2nd cab

gateway is not write in MKDX , but in teknoparrot yess, have check manually the config files

but they see there 2 units connected....

88276959_215808909608173_645441861267226624_n.jpg.cfc5654a492a0d6564f629cf8f3e0a63.jpg89005044_3095371617174073_6440682379546722304_n.jpg.3381afe31b6afe5c0863bbeae6a20061.jpg

 

ether the two cabs start in normal mode, they never wait for the other players, 

85179657_695470667860641_7308839379106004992_n.jpg.7deb030714734d2e853977f0b9eb3992.jpg

and there a bunch of error on main screen (setup) is it normal ?

88424892_2590605614398339_6788135256584093696_n.jpg.22d2d7f8b7ed3980532428474c22dc76.jpg

 

thanks in advance, people love this games, but they always ask me to play together :P

 

Link to comment
Share on other sites

 
36 minutes ago, sebasterdie said:

i stay at dhcp automatic

 

Nice setup

At home ?

Do not use dhcp on PC's / network

Use a static IP 192.168.1.x   

x=2 or 3 

Where it says 25 put 2 or 3

mceclip6.png

 

Cross link network cable or switch / router / hub ? 192.168.1.1 ?

Link to comment
Share on other sites

 
il y a 35 minutes, Onkel a dit :

Nice setup

At home ?

Do not use dhcp on PC's / network

Use a static IP 192.168.1.x   

x=2 or 3 

Where it says 25 put 2 or 3

mceclip6.png

 

Cross link network cable or switch / router / hub ? 192.168.1.1 ?

 an asus router, tested with ethernet cable, and now im on wifi each cab

the router is not connected to internet, maybe there an impact??

 

i will try again to assign port and give you result     see ya thanks

Link to comment
Share on other sites

 

I would not use wifi

Not connected to internet ..... only if you do not want to use the game save function

No port assign, IP address !

If using internet for save function set windows dns to router ip address that will take of the rest to the internet

Allow in windows firewall tcp and udp or disable firewall permanently

Edited by Onkel
Link to comment
Share on other sites

 
il y a 10 minutes, Onkel a dit :

I would not use wifi

Not connected to internet ..... only if you do not want to use the game save function

No port assign, IP address !

If using internet for save function set windows dns to router ip address that will take of the rest to the internet

Allow in windows firewall tcp and udp or disable firewall permanently

i work on windows 10,    so ip adress is set         192.168.1.2  1stcab            192.168.1.3     2ncab

 

does i leave dns blanked???20200228_011817.jpg.ad24f10cac88e747b4542f35d67e2648.jpg

Link to comment
Share on other sites

 
 
 
Il y a 7 heures, Onkel a dit :

subnet 255.255.255.0

DNS 192.158.1.1 (I guess it is your router address)

Otherwise try crosslink cable direct between PC's keep same settings except dns (clean)

perfect i will order crossover cable right now, just in case of..     

 

i give you some news, thanks for the help     if it work i will add another pair cabinet indi500....for a total of 4 player :fiesta: 

Link to comment
Share on other sites

 
Am 17.6.2019 um 20:04 schrieb butflash:

Thank you so much for this guide. All up and running with my wheel on teknoparrot. Awesome game. However. I cannot jump drift. Any clue what I'm doing wrong? Running 1.10.22, using thrustmaster wheel, tried accelerate on buttons and also pedals. Press down on brake while holding accelerate as approaching a corner, but don't jump or drift. Got a feeling I'm missing something obvious. Perhaps the earlier cars don't drift?

 

I've got the same issue. I'm playing with a Logitech Momo Racing USB wheel and everything works fine, but the character does not jump when brake pedal is pressed while accelerating. It only works when AutoAccelerate is on. Do you have any ideas?

Link to comment
Share on other sites

 
Le 01/03/2020 à 05:27, Torquemada a dit :

 

I've got the same issue. I'm playing with a Logitech Momo Racing USB wheel and everything works fine, but the character does not jump when brake pedal is pressed while accelerating. It only works when AutoAccelerate is on. Do you have any ideas?

probably pedal are set for combined pedal in thrusmaster software ???    and check the options in teknoparrot

 

Link to comment
Share on other sites

 
  • 4 weeks later...
 
 
 
 
 

I am having trouble with the online, i seem to keep getting errors to do with AMAuth + MuchCd

 

muchaut/muchaut_nipc_tcp.c:288
Apr  7 15:10:35  WARN 17F8 A1: Connecting daemon failed: MUCHA_ERROR_SYSTEM_NET
Apr  7 15:10:35  INFO 17F8 A1: Starting daemon
Apr  7 15:10:37  INFO 17F8 A1: Connecting daemon
Apr  7 15:10:37  INFO 17F8 CTL: Daemon connected.
Apr  7 15:10:37  INFO 17F8 CTL: Library ident: 2.1-release-0088-9e7a6a10
Apr  7 15:10:37  INFO 17F8 CTL:  Daemon ident: 2.1-release-0088-9e7a6a10
Apr  7 15:10:37  INFO 17F8 A1: state.state_cd = MUCHA_STATE_CD_CONNECTED
Apr  7 15:10:37  INFO 17F8 A1: Connected daemon
Apr  7 15:10:37  INFO 17F8 A1: state.state_tt = MUCHA_STATE_TT_STARTED
Apr  7 15:10:37  INFO 17F8 A1: state.state_dt = MUCHA_STATE_DT_STARTED

 

Apr  6 13:21:49 INFO  : AMUpdater wakeup... Ver:3.1.1-0248-568f263b-Win32-Final
Apr  6 13:21:49 INFO  : AMAuthdConfig section Contents
Apr  6 13:21:49 INFO  :   title         = COCO
Apr  6 13:21:49 INFO  :   lang          = JP
Apr  6 13:21:49 INFO  :   countdoun     = 15
Apr  6 13:21:49 INFO  :   v_resol       = 768
Apr  6 13:21:49 INFO  :   h_resol       = 1360
Apr  6 13:21:49 INFO  :   logfile       = amupdater.log
Apr  6 13:21:49 INFO  :   game_rev      =
Apr  6 13:21:49 INFO  : Load INI File succeed.
Apr  6 13:21:49 INFO  :   File    : M:\Hyperspin\Emulators\TeknoParrot\Games\Mario Kart GP DX\AMCUS\AMConfig.ini
Apr  6 13:21:49 INFO  :   Section : AMAuthdConfig
Apr  6 13:21:49 INFO  : Load INI File succeed.
Apr  6 13:21:49 INFO  :   File    : M:\Hyperspin\Emulators\TeknoParrot\Games\Mario Kart GP DX\AMCUS\AMConfig.ini
Apr  6 13:21:49 INFO  :   Section : MuchaDtModeConfig
Apr  6 13:21:49 INFO  : Load INI File succeed.
Apr  6 13:21:49 INFO  :   File    : M:\Hyperspin\Emulators\TeknoParrot\Games\Mario Kart GP DX\AMCUS\AMConfig.ini
Apr  6 13:21:49 INFO  :   Section : MuchaAppConfig
Apr  6 13:21:49 INFO  : Load INI File succeed.
Apr  6 13:21:49 INFO  :   File    : M:\Hyperspin\Emulators\TeknoParrot\Games\Mario Kart GP DX\AMCUS\AMConfig.ini
Apr  6 13:21:49 INFO  :   Section : MuchaSysConfig
Apr  6 13:21:49 INFO  : Load INI File succeed.
Apr  6 13:21:49 INFO  :   File    : M:\Hyperspin\Emulators\TeknoParrot\Games\Mario Kart GP DX\AMCUS\AMConfig.ini
Apr  6 13:21:49 INFO  :   Section : MuchaCAConfig
Apr  6 13:21:49 ERROR : Change resolutions... width = 640, height = 480
Apr  6 13:21:50 INFO  : Start Main Loop
Apr  6 13:21:51 IWindowControl‚̎擾‚ÉŽ¸”s‚µ‚Ü‚µ‚½B80040154
Apr  6 13:21:51 Compress Info  : log file 3 - open failed.
Apr  6 13:21:51 INFO  : End Main Loop
Apr  6 13:21:51 INFO  : AMUpdater good-bye...

 

any help would be grateful :)

Link to comment
Share on other sites

 
Il 2/4/2020 Alle 21:36, ShaolinMonk ha scritto:

Can anybody tell me. Does the 100 percent save file work with version 1.10. And if so how do you use it. I tried putting the file in the main directory and it does nothing... Can't find this information anywhere...

 

Here it works but not with TeknoParrot.

I'm using JConfig ( there's a pack for mkdx that has everything you need ) and I run the game from its .exe with admin right.

I placed the profile.bin file from the pack mentioned before in the sv folder created by JConfig.

There are many tracks not unlocked but it's not s problem because I'm having fun to unlock these by myself, then the game save progress on the profile.bin file.

All items, characters and cars are unlocked.

 

Hope this help!

 

CHEERs

Edited by nohero
Link to comment
Share on other sites

 
  • 2 weeks later...
 
 
 
 

Guys, I need a little help with a DInput wheel, it's a T500RS.

 

I can't use boost with it and it's configurated well at least with JConfig and TeknoParrot ( in DInput because in XInput it's not recognized by both ).

 

Any help is highly appreciated.

 

 

CHEERs

Edited by nohero
Link to comment
Share on other sites

 

I'm back, and I've encountered a new error:

"Runtime Error!

Program:

 

This application has requested the Runtime to terminate it in an unusual way.

Please contact the application's support team for more information."

I'm running it with admin privileges and an NVIDIA graphics card.

Link to comment
Share on other sites

 
On 4/23/2020 at 3:00 PM, nohero said:

I can't use boost with it and it's configurated well at least with JConfig and TeknoParrot ( in DInput because in XInput it's not recognized by both ).

 

You got MKDX version 1.10 ?

Link to comment
Share on other sites

 
 
44 minutes ago, Distray said:

Even with a bootable Linux Mint drive, the wireless is no longer working.

Well it looks like not a problem on the windows side, if a seperate O.S. also has that problem 

Build-in, USB or PCI ?

What did you do to get into this situation ?

Edited by petje
Link to comment
Share on other sites

 
 
1 hour ago, Distray said:

I tried to get to the titlescreen, using the super-admin account.

Title screen of what, MKDX ?

Run teknoparrot and the MKDX .exe (MK_AGP3_FINAL.exe) as admin (set in file properties right click) 

https://www.top-password.com/blog/make-your-program-always-run-as-administrator/

 

Remove USB wifi drivers, remove usb wifi, restart system, insert usb wifi (in other usb slot if needed) reinstall drivers again ?

 

Link to comment
Share on other sites

 
 
23 minutes ago, nohero said:

 

Yes with english translation.

 

 

Drift boost works fine for me on my DInput Logitech Momo Red

I asked for the version number, because as far as i know version 1.00 has no drift boost

 

Link to comment
Share on other sites

 

How did you do it?

In TeknoParrot last version if I set a DInput controller drift boost doesn't work, same thing for JConfig.

Using TeknoParrot I can't setup a DInput controller if I keep XInput option checked but when I remove the check I can setup the buttons but in game drift boost doesn't work, no jump when I push the brake.

Here only in XInput drift boost works both in TP and JConfig.

 

Can you tell me more about how you set it up? 

 

Thanks

Link to comment
Share on other sites

 
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share


×
  • Create New...