Jump to content

[Tuto] House of the Dead 4: Alternative install

Recommended Posts

This procedure is probably not needed anymore since Teknoparrot !!!

According to the changelog:

- [Reaver] [TeknoParrot] House of the Dead 4 now has the hidden cursor.

- [Reaver] [TeknoParrot] The House of the Dead 4 now throws grenades with the mouse 3.



Still does not work ?

You want to add your own cursors ?


Keep reading.


House Of The Dead 4 (Lindbergh)

Works fine on Window$ 10 (1803) and TeknoParrot 1.86 (straight loaded)

I run it with GameLoader ( and TeknoParrot 1.81 X-MAS Special.


Run HOTD4_MouseFix.exe as administrator.

Run GameLoader All RH as administrator.


Edit 14-02-2019


The fault in "version 1" of these instructions was:

I forgot to mention,

Run HOTD4_MouseFix.exe as administor.

Run Gameloader All RH.exe as administrator. 


I got House Of The Dead 4 working with Gameloader All RH !


(as far as I know, just tested it on version 1.90 no go !


So run 1.81 X-MAS Special !


Just played it to the "end", "James", I won't spoil it ....


I can get it to work with the mouse ,crosshair, dead centre.

I have no idea how to configure it for a second player, second mouse on 1 system.

At the moment,  I can connect a second mouse to the PC, Ds_Diag sees it as a second device.

But in game, both mice, control the player 1 crosshair. 

And I am missing the sound effects of the guns and zombies.

There is only music and dialogue.


OK, here is my documentation to get it working.


I use a three button mouse a keyboard and a wireless XBox 360 controller, 

to get the mouse working to aim, shoot, reload and throw grenades.

It should also be possible with only a keyboard and mouse, use Direct Input in TeknoParrot Emulation settings.

For Xbox 360 controller input use XInput in TeknoParrot Emulation settings.

Disable the headphone outputs of the Xbox 360 controllers in Window$ 10.

Set the default output to the correct audio output device.


Otherwise the Xbox 360 controllers switch the audio output to their headphone outputs everytime.

Extract the HODT4 .bin file with 7zip or PowerISO



Then you need these files.


Characters look corrupted ?
Use the shader fix files, place in HOD4/disk0/fs

Files needed for the test menu, place in HOD4/disk0/elf



GameLoader All RH, place the three .exe files in HOD4/disk0/elf/


Warning about "virus" ? (before version

Edit the file TTX.ini in C:\Users\"Your User Name"\ AppData\Roaming\Game Loader All RH\

And change

Warning = Agree


Seeing green version number of Gamleoader All RH at bottom of screen ?

Edit the file setting.ini in C:\Users\"Your User Name"\AppData\Roaming\Game Loader All RH

and change:

[FileVersion] Show=0

Different resolution hod4M.elf files, place in HOD4/disk0/elf/

Use the one needed for the native resolution of your monitor / TV.


Read the readme.txt files included in the compressed files !


Out of this thread, thanks to 7zxkv.



First open 2 - HOTD4 game.exe for Game Loader All RH with 7Zip.

In your HOD4/disk0/elf folder change the extension of you original hod4M.elf to hod4M.elfo


Can not see extensions of your files ?



Drag the correct resolution hod4M.elf from 7Zip into your HOD4/disk0/elf folder.

Choose the one with the correct native resolution for your monitor.

For the Gameloader All RH  to work, you must:


1. Put the 3 exe in the folder of a game, in this case, HOD4/disk0/elf


2. Launch the Game Loader Installer.exe file (do it once)


You will get a Virus warning to see, FAKE !!





(Old news, not anymore since version of GameLoader ALL RH)

3. Go to C: \ Users \ USER NAME \ AppData \ Roaming \ Game Loader All RH \ TTX.ini

4. Edit TTX.ini and change the line 


Warning= Agree


5. Run Game Loader Installer.exe once again, and install the necesary files


6. Run the Game Loader Config.exe file, follow the instructions in the video below


On to the next step.
This video shows how to config GameLoader All RH for HOTD4.

HOTD4_MouseFix.zip can be found here, place in HOD4/disk0/elf/


"HOTD4_MouseFix.exe" can be start minimalized in the task bar by running the command : "HOTD4_MouseFix.exe -minimized".


Crosshair mouse cursors can be found here.
The filename has to be CrossHair.cur
This file needs to be installed in disk0/elf/sv


Onto the next step.

In Game Loader Config on the Update rate Tab, uncheck Update rate mouse cursor hide.

On the Loader Settings 1 Tab, click on Select Folder, and link it to your TeknoParrot folder location.

This should start TeknoParrot.


1. In TeknoParrot go to "EMULATION SETTINGS" and uncheck "Use Mouse for gun Games".  
That way you can set whatever keyboard key you want for START, TEST and SERVICE.

2. Go to HOTD4 game settings, set your START, TEST, SERVICE keys in "input Mapping" and check "General - OffscreenReload Hack".

Others options are not important so do as you wish.

3. Make sure you link the correct path to hod4M.elf in TeknoParrot.

.....\HOD4\disk0\elf\hod4M.elf for game mode.
......\HOD4\disk0\elf\hod4testM_HD.elf for testmode.


4. Now just run "HOTD4_MouseFix.exe" before starting the game.

"HOTD4_MouseFix.exe" can be start minimalized in the task bar by running the command : "HOTD4_MouseFix.exe -minimized".


Configure your game settings in TeknoParrot for House Of The Dead 4.


Onto the next step.




DemulShooter needs.
.NET 3.5 (includes .NET 2.0 and 3.0)



Do you get error 0x800f081f, like I did ?

Here is the solution.




Copy the file microsoft-windows-netfx3-ondemand-package.cab to the root of C:


At the Command prompt (run as admin) paste this text, it will install .NET 3.5 if you have error 0x800f081f


Dism.exe /online /enable-feature /featurename:NetFX3 /source:C:\ /LimitAccess



DOES NOT RUN CORRECTLY ON 1.88 or higher !


So run 1.81 X-MAS Special !


My settings which work for me, on window$ 10 1803 (April) revision, and TeknoParrot 1.81 XMAS Special, XInput joysticks.



Onto the next step.

TeknoParrot still shows the Window$ mouse cursor ?

You can use GameLoader All RH ( in conjunction with TeknoParrot (1.93) to suppress the Window$ mouse cursor.

"Update rate mouse cursor hide", enable and set to 0.



Onto the next step.


This step is probably optional !

Demulshooter 8.5.2 can be found here.



Here is the DemulShooter Wiki.


I extracted the DemulShooter files in HOD4/disk0/elf


Launch Ds_Diag.exe and change, select a device at the top, it should be your Xbox 360 controller.

Move your mouse it should change the raw input values, test your mouse buttons.

In DemulShooter choose your P1 Device, it should be your Xbox 360 controller.



On to the next steps.

7. Launch HOTD4_MouseFix.exe as administrator.


8. Launch Game Loader All RH.exe as administrator.

Wait a few moments, you get a black screen, with green v0.3.2.4 at the bottom.


Patients ......


Right mouse click is start or 1 on keyboard, or start on the joystick ?


Enjoy !!



I hope that this tutorial helps other people out.

It takes you a few moments to read, but it took me all night to figure it out.

When you get the game working, thanks to this "manual", please give a thanks at this post.



And a BIG thanks for the people who originally uploaded the games, we all can enjoy (if you do it right) !!!

And of course all the people involved in, the game loaders and JVS I/O emulation applications we use, and all the people I "forgot".


Also look at the posts below, some members / people add helpful information, thank them also .....

Edited by linglang
proof read, added info, added link demulshooter , what is start button ?
  • Like 3
  • Thanks 5

Share this post

Link to post
Share on other sites

same installation with teknoparrot 1.93 and sound the guns.....WORKS VERY FINE...

Share this post

Link to post
Share on other sites

After clicking the game loader installer, nothing happens. What should I do?


Also, using the resolution patched elf results in the pre-rendered cutscenes to run in 4:3 aspect ratio or did I do something wrong?


Edit: Got the installer to work but the mousefix is not working at all.

Even after doing exactly as shown on that video, mouse doesn't work, at all.


If I disable mouse input in tekno parrot settings, only keyboard works. Nothing else works.

Edited by Riasat Salmin Sami

Share this post

Link to post
Share on other sites

Thanks @linglang for this tuto. 

It seems I have another problem, still no mouse detect.

Same steps on my other laptop and works fine.


My hardware: NUC 8i5 16 GB and eGPU 1060 6 gb. Others shoot games works fine, Transformers, LGJ...its going me crazy.

I have wireless keyboard and mouse, but with an USB mouse the same, dont detect de mouse.


Dammmm . Anyway, thanks.

Share this post

Link to post
Share on other sites

First I want to give u my thanks and your disposal to ever help @linglang


Yes, In Demulshooter works fine the mouse test, and selected xinput. Tested on TP 1.82 Xmas edition and Demulshooter 8.5.2 and game loader 334. All my options are the same as the pics. and TP options same as the YouTube video.


...completly lost.


Thanks anyway

Share this post

Link to post
Share on other sites
En 12/9/2019 a las 0:38, linglang dijo:


Teknoparrot (TP) had some good improvements lately.

Try to load it straight with TP 205, I use these settings.



i hope this works out for you.


Will try again later. Thank again


Edited: @linglang Executed first time with last TP and last GLoader...works!!...but cannot aim, ESC, check if USeMouse is checked on TP, is already on, Exit TP, nothing changed, start again Game Loader...Not work anymore, mouse not detected.


Its a completly nighmare.


Finally decide to pass this game. Thanks anyway.


Edited by Gwyllion

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now