Jump to content

[Tuto] Initial D5: How to Install


linglang
 Share

Recommended Posts

Initial D5 Export

initial_d_arcade_stage_5_by_pooterman-dc8016c.png

Runs fine on Teknoparrot 1.93

Does not run on version 1.0.0.125 (at least for me)

But the steering is very sensitive, and there are still audio glitches.

Lindbergh support is still experimental.

 

You can extract the .rar and the resulting .bin with 7zip.

https://www.7-zip.org/

Ignore the errors about symbolic links, these can not be created on a Window$ 10 file system.

I use "No to all", works fine for me.

 

AMD GPU fixes thanks to @Nezarn

https://github.com/Nezarn/IDShaderfix/releases

 

Added information !

 

Two .bin files in a rar ?

The second bins file name mentions where it needs to be extracted.

initiald5.bin

id5_data.bin

So the files contained in id5_data.bin needs to be extracted into disk0/data

 

thanks to @viperone2020 and @roman1990 to bring this vital step to my attention !

 

Executable file is, disk0/id5.elf

 

You see a blue message box ?

Press change view, to skip.

It has to do with the card reader, which works fine.

 

Enjoy

https://ibb.co/w4J3wfH

 

I hope that this tutorial helps other people out.

It takes you a few moments to read, but it took me all night to figure it out.

When you get the game working, thanks to this "manual", please give a thanks at this post.

:very-good:

 

And a BIG thanks for the people who originally uploaded the games, we all can enjoy (if you do it right) !!!

And of course all the people involved in, the game loaders and JVS I/O emulation applications we use, and all the people I "forgot".

 

Also look at the posts below, some members / people add helpful information, thank them also .....

Edited by linglang
added information.
Link to comment
Share on other sites

 
 
 
22 hours ago, roman1990 said:

there is 2 bin files.

initiald5.bin

id5_data.bin

so please explain after extracting both bin files then any folder move into disk0 or other folder or not?

--> no files you mentioned, no disk0 folder (all just like my attached image)

is that cgGL.7z  filer move into TeknoParrotU 1.90  or game folder ?

--> same, no file that you mentioned, already find..result 0

 

still can play, but demo crash look not perfect to me,
any suggestion or give me that files will try it

MERCi DON!

 

id5.jpg

Link to comment
Share on other sites

 

@viperone2020 Budgieloader / lindberg games is still experimental in Teknoparrot.

There wil be sound glitches and steering in ID4 and ID5 is oversensitive !

 

@roman1990

Two .bin files in a rar ?

The second bins file name mentions where it needs to be extracted.

initiald5.bin

id5_data.bin

So id5_data.bin needs to be extracted in disk0/data

Link to comment
Share on other sites

 
  • 3 months later...

Hey, I've tried all of the options. For some reason, I can't get Initial D 5 to work. The error I keep getting in the budgieloader command prompt is this.
Note, I will be replacing some private stuff with lines
 

BudgieLoader - loading C:\Users\__________\Downloads\id5exp\initiald5\disk0\id5.elf
Unimplemented sound emulation API: SEGAAPI_SetSynthParamMultiple
Unimplemented sound emulation API: SEGAAPI_SetGlobalEAXProperty
Unimplemented sound emulation API: SEGAAPI_GetSynthParam
Unimplemented sound emulation API: SEGAAPI_GetUserData
Error Invalid Status.
Error Invalid Status.
Error: amDongleRecvI2C
Error: amsDsReadUniqueNo
Not Access Security Device.
libams: Init - -1
LocalHost IPAddr: ________

Link to comment
Share on other sites

 
17 hours ago, darkphoenix980 said:

BudgieLoader - loading C:\Users\__________\Downloads\id5exp\initiald5\disk0\id5.elf
Unimplemented sound emulation API: SEGAAPI_SetSynthParamMultiple
Unimplemented sound emulation API: SEGAAPI_SetGlobalEAXProperty
Unimplemented sound emulation API: SEGAAPI_GetSynthParam
Unimplemented sound emulation API: SEGAAPI_GetUserData

These "errors" have to do with sound emulation.

At the moment, just ignore these errors, there is nothing you can do about it. (can you program?)

 

17 hours ago, darkphoenix980 said:

Error Invalid Status.
Error Invalid Status.
Error: amDongleRecvI2C
Error: amsDsReadUniqueNo
Not Access Security Device.
libams: Init - -1
LocalHost IPAddr: ________

 

I think these errors have to do with not starting the correct executable file ?

gamefolder/disk0/id5.elf

 

Link to comment
Share on other sites

 
 
 
15 hours ago, linglang said:

@darkphoenix980

Try to load it from another location.

Do you run TP as admin ?

Where did you download, download again ?

https://mega.nz/#F!tNY2nCwS!637xGzNRBd787yCnwYXAGg

Strange you get a dongle security error.

 

That's where I downloaded it from. I always run TP as admin. And I'll see if that helps.

Update: Doesn't work. Guess my PC doesn't like lindbergh games or elf files. Which sucks.

Edited by darkphoenix980
Tried everything at this point.
Link to comment
Share on other sites

 
  • 6 months later...
 
  • 1 year later...
 
  • 1 month later...
 
  • 4 months later...
 
  • 2 weeks later...
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
  • Create New...