Jump to content
7zxkv

[Emu] Sega Model 3: Supermodel r783

Recommended Posts

Hoping someone can help... running svn777 I am trying to calibrate guns for lost world. I believe I have the ini file correct as I get 2 crosshairs moving with 2 aimtrak lightguns. However when I go into service mode I don't get the correct config screen as it is only showing input for 'center' and not left, right, top, and bottom. Also the screen is blue when I think it should be black. Anyone know what the deal is on this?

 

20191020001034.png.985352a918a0be618eb020d3098bca53.png

Share this post


Link to post
Share on other sites

Gun Settings - Mouse adjustment SVN 740

 

 

Gun Settings - Mouse adjustment SVN 775/777

 

 

In newer versions of SVN 7xx the calibration screen has changed but is working correctly..

 

Share this post


Link to post
Share on other sites
On 10/22/2019 at 3:50 AM, Tomek.. said:

Gun Settings - Mouse adjustment SVN 740

 

 

Gun Settings - Mouse adjustment SVN 775/777

 

 

In newer versions of SVN 7xx the calibration screen has changed but is working correctly..

 

 

Not sure what I am doing wrong.. when I point my aimtraks dead center the crosshairs wont reposition themselves to the red and green indicators.... as you can see in the video its wayyyy off. Do I have to have a specific resolution set maybe or??

 

 

Share this post


Link to post
Share on other sites

AREA CODES FOR ANYONE WHO WANTS TO CHANGE THAT .😍 had it for ages but never dawned on me till now as iv been mostly on the teknoparrot page .

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites

New svn778

 

My assembly, actually, with no crackling sound


64 bit build


FIX: Ian

 

Ocean hunter in the middle of the game is passing a few matrices with FLT_MAX inside them, which blows apart our near / far calculation. The hardware must have some method to sanitize near / far for instance if you render something extremely close to the origin you will also blow apart near / far calc.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
Il y a 5 heures, GeraBlackHnd a dit :

I was testing svn778 and the gun stopped to works in this version.I dont know what happened, i tried the lost world, someone do knows a solution for this problem?

 

What I compiled is a clean version without customization

just had it compiled

 

All gun games work for me ..

 

Ian (Developer Supermodel) only made changes to the correction distance calculation ..

 

You may have a badly set file (Games.xml)

 

I do not know in which revision (r7 ??) supermodel were changed controls in the game (Lost World) from analog to Lightgun 

Try Change in Games.xml

 

 <game name = "lostwsga">
    <Identity>
      <title> The Lost World </title>
      <version> Japan, Revision A </version>
      <Manufacturer> Sega </ manufacturer>
      <Year> 1997 </ year>
    </ Identity>
    <Hardware>
      <platform> Sega Model 3 </platform>
      <Stepping> 1.5 </ stepping>
      <Inputs>
        <input type = "common" />
        <input type = "gun1" />
        <input type = "gun2" />
 

-------------------------------------------------------------------------------------------------

If  you use (Demulshoter, PPjoy and Vjoy, Aimtrack as Gun)


So these programs use anologian input

 

Actually - Gamepad controls Mouse using IR sensor


Inputs must be set to:

 

analog_gun1
analog_gun2

 

Edited by sonic323

Share this post


Link to post
Share on other sites
Il y a 5 heures, sonic323 a dit :

 

What I compiled is a clean version without customization

just had it compiled

 

All gun games work for me ..

 

Ian (Developer Supermodel) only made changes to the correction distance calculation ..

 

You may have a badly set file (Games.xml)

 

I do not know in which revision (r7 ??) supermodel were changed controls in the game (Lost World) from analog to Lightgun 

Try Change in Games.xml

 

 <game name = "lostwsga">
    <Identity>
      <title> The Lost World </title>
      <version> Japan, Revision A </version>
      <Manufacturer> Sega </ manufacturer>
      <Year> 1997 </ year>
    </ Identity>
    <Hardware>
      <platform> Sega Model 3 </platform>
      <Stepping> 1.5 </ stepping>
      <Inputs>
        <input type = "common" />
        <input type = "gun1" />
        <input type = "gun2" />
 

-------------------------------------------------------------------------------------------------

If  you use (Demulshoter, PPjoy and Vjoy, Aimtrack as Gun)


So these programs use anologian input

 

Actually - Gamepad controls Mouse using IR sensor


Inputs must be set to:

 

analog_gun1
analog_gun2

 

Thanks! Works nice!!!

Share this post


Link to post
Share on other sites

New svn779

 

My assembly, actually, with no crackling sound


64 bit build


FIX: Ian

 

 

Thanks to our anonymous contributor who managed to patch a model 3 game and run it on real h/w, we were able to obtain some timing values we had been long been missing for correct emulation. The h/w polls something called the ping_pong bit at start-up to sync the GPU with the CPU. Unfortunately we didn't have the correct values and just manually used some per game hacks to get games to run. This mostly worked, but some games were writing more or less frames than they should have been for a given time period. When the ping_pong bit flips at 66% of the frame time, games were writing data for a new frame, which meant writes were often straddling 2 separate frames. We aren't 100% sure if IRQ2 or the ping_pong bit is vblan

 

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by sonic323

Share this post


Link to post
Share on other sites
Il y a 2 heures, maximumstyle a dit :

hello

With this new SVN 779 i have graphic bugs in sega rally 2

I am alone ??

I have un gtx 750 with a i7 860

thx

 

For srally2 set PowerPCFrequency = 70 , for srally2x set PowerPCFrequency = 100  graphic bugs will disappear

 

Share this post


Link to post
Share on other sites
New SVN 781
 
64 bit build
 
 
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 committed 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Optimise Games.xml (Krom)
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 committed 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Stretch the time the ping_pong bit flips a bit to bump writes into correct frame. Otherwise they end up getting written at like 99.8% of the frame and overlapping with...
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
49 minutes ago, sonic323 said:
New SVN 781
 
64 bit build
 
 
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 committed 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Optimise Games.xml (Krom)
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 committed 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Stretch the time the ping_pong bit flips a bit to bump writes into correct frame. Otherwise they end up getting written at like 99.8% of the frame and overlapping with...
 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Sega Bass Fishing and Virtual On Oratorio Tangram no longer work since svn 779 t up to present svn 781hey just black screen and do nothing.

 

Edited by eathearty1

Share this post


Link to post
Share on other sites
Il y a 7 heures, eathearty1 a dit :

Sega Bass Fishing and Virtual On Oratorio Tangram no longer work since svn 779 t up to present svn 781hey just black screen and do nothing.

 

 

These games work. I use the compiled version by sonic323 , if you delete old files "von2.nv , von254g.nv " from the nvram folder the game will start sooner

Maybe you do not have the correct Games.xml file?

 

 

Edited by Tomek..

Share this post


Link to post
Share on other sites
Il y a 11 heures, Tomek.. a dit :

 

For srally2 set PowerPCFrequency = 70 , for srally2x set PowerPCFrequency = 100  graphic bugs will disappear

 

Work good

thx so much

Edited by maximumstyle

Share this post


Link to post
Share on other sites
Il y a 4 heures, Tomek.. a dit :

 

These games work. I use the compiled version by sonic323 , if you delete old files "von2.nv , von254g.nv " from the nvram folder the game will start sooner

Maybe you do not have the correct Games.xml file?

 

 

Where can you find the correct Games.xml file?

Share this post


Link to post
Share on other sites

The question which (Games.xml) is up to date is difficult to answer.

More versions (Games.xml)

 

1.Games.xml - Spindizzi added forcefedbeack for all racing games

Attention is necessary to edit rom, insert rom from Model 2 Emulator etc ..
Because it starts to announce - missing rom etc ..

 

----------------------------------------------
2.Games.xml - Bart Corrected Correct Input (Lightgun)

 

----------------------------------------------

3.Games.xml - I do not know exactly but it has been repaired Game Star wars prototype

 

-----------------------------------------------------------

Etc ..

 

Games work like Tomek wrote, just delete the necessary NVRAM

Share this post


Link to post
Share on other sites

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

 

Edited by 7zxkv

Share this post


Link to post
Share on other sites
Il y a 5 heures, holmes a dit :

Where can you find the correct Games.xml file?

 

Games.xml - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
Il y a 4 heures, Tomek.. a dit :

 

Games.xml - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Thanks

Share this post


Link to post
Share on other sites

Does anyone have a config file that would work with 2 xbox 360 controllers for all games?

I keep having the games not detect them like in Lamachine guns the analog and controls do not work.

Thanks if anyone has a config file they can share or test out.

Share this post


Link to post
Share on other sites
21 hours ago, talnova said:

Does anyone have a config file that would work with 2 xbox 360 controllers for all games?

I keep having the games not detect them like in Lamachine guns the analog and controls do not work.

Thanks if anyone has a config file they can share or test out.

 

+1 i can't get to 2 xbox 360 controller to work, maby any one have a supermodel.ini config

Share this post


Link to post
Share on other sites

New svn 782

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Commit Ian:

 

Really should cull against 5 frustum planes.

Share this post


Link to post
Share on other sites
Le 12/11/2018 à 15:56, delo a dit :

en effet...

d'ailleurs je remets ma dernière question :timide:

est-ce que sega rally 2 pourra voir le jour en mode network ou 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
  est-ce que cela pose trop de difficultés ???

ça serait cool....avec scud race et daytona 2 ça donnerait bien tout de même :bravo:

Suite à la suppression de l'ancien sujet (par on ne sait qui mais bien joué :very-good:) on reprend les mêmes et on recommence.

Edited by ELIOTYRA

Share this post


Link to post
Share on other sites

Does anyone know of a supermodel build that has Scud Race sound working without any weird loud noises/crackling sound that appears after a couple of races? I'm currently using the latest build from the 1st page, and all the games work fine with sound etc except Scud Race. It's very annoying when all of a sudden the sound gets really loud, engine and/or music etc. Thanks in advance! 

Share this post


Link to post
Share on other sites

Guys how do I configure the rawinput for he latest supermodel version. I generally use a .bat config file to configure my games but it my xinput controller seems to control the targeting cursor not my mouse. Any suggestions? I want to be able to play light gun games via mouse.

Share this post


Link to post
Share on other sites
Le 22.11.2019 à 19:09, ark216 a dit :

Guys how do I configure the rawinput for he latest supermodel version. I generally use a .bat config file to configure my games but it my xinput controller seems to control the targeting cursor not my mouse. Any suggestions? I want to be able to play light gun games via mouse.

 

I have these games in exe format with mouse support. If you want, I can share them

Share this post


Link to post
Share on other sites
1 minute ago, Tomek.. said:

 

I have these games in exe format with mouse support. If you want, I can share them

Please do so

Share this post


Link to post
Share on other sites
il y a 39 minutes, ark216 a dit :

Please do so

 

64bit 1920x1080

L.A.Machineguns.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Star Wars Trilogy.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Star Wars Trilogy-swtrilgyp-Prototype.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Lost World.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Lost World-lostwsgo-Prototype.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Ocean Hunter.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Share this post


Link to post
Share on other sites
On ‎11‎/‎29‎/‎2019 at 12:47 AM, Tomek.. said:

 

64bit 1920x1080

L.A.Machineguns.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Star Wars Trilogy.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Star Wars Trilogy-swtrilgyp-Prototype.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Lost World.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Lost World-lostwsgo-Prototype.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

The Ocean Hunter.exe - 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

can you make 4k resolutions ones also?

 

Share this post


Link to post
Share on other sites
Le 22.11.2019 à 14:23, arcade_power a dit :

Does anyone know of a supermodel build that has Scud Race sound working without any weird loud noises/crackling sound that appears after a couple of races? I'm currently using the latest build from the 1st page, and all the games work fine with sound etc except Scud Race. It's very annoying when all of a sudden the sound gets really loud, engine and/or music etc. Thanks in advance! 

This emulator has various sound problems that have not yet been fully repaired..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×