Jump to content
Boomslangnz

[Arcade PC] FFB Arcade Plugin

Recommended Posts

Wow thats great but maybe if it needs to be finetuned, i like to wait ...

Others maybe want it right now

Share this post


Link to post
Share on other sites
Le 30/07/2018 à 09:57, Boomslangnz a dit :

Here's new update to FFB Arcade Plugin to 0.1a

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Read FFBPlugin.txt for changes

 

Le 31/07/2018 à 09:10, Boomslangnz a dit :

Sorry guys, fixed version for Daytona Championship USA. Change button numbers in ini for gears if necessary, or ShowButtonNumbersForSetup=1 to check button layout. Popup boxes will show button numbers when you press buttons or use shifter. Turn off after setup complete

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Le 03/08/2018 à 14:26, Boomslangnz a dit :

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Sonic & Sega All Stars Racing Force Feedback added



thank you to edit and repack systematically files in post 1.

I did it for this time. This avoids searching on multiple pages. thanks ;)

Edited by 7zxkv

Share this post


Link to post
Share on other sites

All the force feedbacks and rumble etc works with my xbox360 pads and steering wheel and hooks perfectly with a beep except Sonic and Sega All-Stars Racing. When I put the  d3d9.dll in the game folder the game throws an unable to load dll error through Teknoparrotui.exe. If I remove the d3d9.dll from the folder the game runs fine but obviously the ffb / rumble effect doesn't work as I get no beep to indicate hooking etc. Like I said Ive set up all the others and added my Pad id into the FFBPlugin.ini any ideas greatly appreciated. Cheers 

Share this post


Link to post
Share on other sites
15 hours ago, fire10 said:

All the force feedbacks and rumble etc works with my xbox360 pads and steering wheel and hooks perfectly with a beep except Sonic and Sega All-Stars Racing. When I put the  d3d9.dll in the game folder the game throws an unable to load dll error through Teknoparrotui.exe. If I remove the d3d9.dll from the folder the game runs fine but obviously the ffb / rumble effect doesn't work as I get no beep to indicate hooking etc. Like I said Ive set up all the others and added my Pad id into the FFBPlugin.ini any ideas greatly appreciated. Cheers 

 

That's wierd. try rename the d3d9.dll to xinput1_3.dll and see while in game folder

Share this post


Link to post
Share on other sites
5 hours ago, Boomslangnz said:

 

That's wierd. try rename the d3d9.dll to xinput1_3.dll and see while in game folder

That did the trick mate thankyou

Share this post


Link to post
Share on other sites

Thanks a lot. Your plugin works great.  But I'm wondering why my Logitech G920 steering wheel has no ffb effect with Teknoparrot 1.61hf force feedback ticked. Teknoparrot doesn't support G920 ffb?

Edited by netsonic

Share this post


Link to post
Share on other sites

if you use FFB driver Dont tick FFB TP option that's all...

 

 

Share this post


Link to post
Share on other sites
18 hours ago, WildWolf said:

if you use FFB driver Dont tick FFB TP option that's all...

 

 

Thanks. I mean this plugin does work while the original FFB of Teknoparrot doesn't. I don't know why?

Share this post


Link to post
Share on other sites

Unlucky i try to see what's going wrong in my configuration but really not found 

Here two video for explain you the problem

First with your plugin you can see wheel turn left but not right

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Second with teknoparrot , going left and right for the first step and right and left for the second step 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hope you can help me 

 

Edited by bandicoot

Share this post


Link to post
Share on other sites

Great program, many thanks for it. Is there any chance you can make this compatible with Outrun Coast to Coast please. Thank you.

Share this post


Link to post
Share on other sites

Hello, The force feedback is not working on the steering wheel, any tips on what I might be doing wrong?

 

Steering wheel

Thrustmaster T300RS Racing Wheel 

Windowns 10


Daytona USA
FFBPlugin.ini

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Log.txt

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by AlexArcade

Share this post


Link to post
Share on other sites
6 hours ago, AlexArcade said:

Hello, The force feedback is not working on the steering wheel, any tips on what I might be doing wrong?

 

Steering wheel

Thrustmaster T300RS Racing Wheel 

Windowns 10


Daytona USA
FFBPlugin.ini

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Log.txt

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

 

Welcome guys,

 

Are you sure you have the hex edited exe which contains the ffb changes?

Share this post


Link to post
Share on other sites
On 19/07/2018 at 11:03 AM, segaoutrun123 said:

thanks works now with Logitech driving force and l2m2 on cab

great work all involved :thankyou:

 

Mate, I think I've got the same wheel as you (Logitech Driving Force GT - GUID: 6d049ac2000000000000504944564944) but I cannot get the FFB working. Boomslang's been giving me advice over at BYOAC forum, and I've got to a point where I can now get the game running from a patched version of the original Daytona Championship EXE (as opposed to one of the launchers) with manual gears working and the wheel turning properly through the menus by just keeping it turned, but no FFB, even though everything looks configured correctly and I've got all the x360ce options for FFB turned off. Is there any chance you could PM me a copy of your x360ce dll file or files (the ones that look like 'xinput9_1_0.dll'), x360ce config ini file and your log from the plugin, please? I was hoping that maybe translating them into my folder with the game might help. Thanks in advance! 

  • Sad 1

Share this post


Link to post
Share on other sites
7 hours ago, MrThunderwing said:

 

Mate, I think I've got the same wheel as you (Logitech Driving Force GT - GUID: 6d049ac2000000000000504944564944) but I cannot get the FFB working. Boomslang's been giving me advice over at BYOAC forum, and I've got to a point where I can now get the game running from a patched version of the original Daytona Championship EXE (as opposed to one of the launchers) with manual gears working and the wheel turning properly through the menus by just keeping it turned, but no FFB, even though everything looks configured correctly and I've got all the x360ce options for FFB turned off. Is there any chance you could PM me a copy of your x360ce dll file or files (the ones that look like 'xinput9_1_0.dll'), x360ce config ini file and your log from the plugin, please? I was hoping that maybe translating them into my folder with the game might help. Thanks in advance! 

hi m8 try setting your centering & friction values both to 1

and feedback 0 to 55 and delete xinput file 4 I think it was would not work with that in folder

Share this post


Link to post
Share on other sites
On 19/08/2018 at 6:10 PM, segaoutrun123 said:

hi m8 try setting your centering & friction values both to 1

and feedback 0 to 55 and delete xinput file 4 I think it was would not work with that in folder

It's ok man, cheers for the advice. I somehow managed to get it working using a copy of x360ce in a different folder to the Daytona one. Don't ask me why that's done it, but it has. Thanks for getting back to me though.

Share this post


Link to post
Share on other sites

Spent last night trying to help Bandicoot with a L2M2 issue where rotation worked incorrectly for all games. We solved the issue so new option is coming in new release soon for any other users who have same problem 

 

Plus a bunch of other things so expect 0.2 very soon

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

New update for FFB Arcade Plugin v0.2 posted on first page

 

--0.2 Changes--

- Added support for California Speed, Cruis'n World, Cruis'n USA & Off Road Challenge on Mame 32 or 64bit Binary OR MameUI64 ONLY for Mame 0.199.

- Added support for Sega Rally Championship,Daytona USA,Indy 500,Sega Touring Car Championship,Over Rev & Super GT 24h on M2 Emulator 1.1a (just alternative to built in FFB)
 (Disable FFB in Emulator.ini if you want to use FFB Plugin instead of M2 Emulator's built in FFB support. Set hardware type to STCC for OverRev & I/O board to A or B for Super GT 24h in test menu!! )

- Added support for Initial D4 Japan, Initial D5,Sonic & Sega All Stars Racing & Outrun 2 Special Tours Deluxe for Teknoparrot

- Added strength options in ini for most effects in Mario Kart 1.10. Wheels can only use MAX of 100, Controller can go higher
Multiplier option is if you want to raise the strength of Water and Drift effects, 200 would double the strength etc. Set to 100 by default

- Added option to certain games in ini to give a bit more strength to lower forces. FFBMode=0 is the standard and FFBMode=1 is the new mode 
(BE WARNED ON CERTAIN WHEELS THIS COULD CAUSE OSCILLATION TO OCCUR)

- Added option to Daytona Championship USA ini to hide mouse cursor

- Added AlternativeFFB option to ini which is for wheels such as PWM2M2 or certain direct drive wheels etc which use constant effect incorrectly ingame.
eg Roll left and Roll Right doesn't work correctly, Enable Alternative FFB to modify this and added strength options for it

  • Thanks 3

Share this post


Link to post
Share on other sites

@Boomslangnz,

 

Thank you very much for this!!!!

Can't wait to test it!!

Thank you for Outrun Sp dx!!!!

It's the one i was expecting the most!!

:crazy-monkey-nani:

Share this post


Link to post
Share on other sites
Le 19/8/2018 à 06:23, Boomslangnz a dit :

 

Welcome guys,

 

Are you sure you have the hex edited exe which contains the ffb changes?

 

im also missing the hex edited exe with ffb changes.

 

anybody got a copy i can get?

Share this post


Link to post
Share on other sites

@Boomslangnz

 

i just went to give a try with the new ffb plugin v2.

 

i have done tests with Outrun2 SPDX  : something strange : every 5 to 7 seconds, my wheel is turning hard on the right whatever the surface on which i drive. :wacko:

 

i tried the plugin on Model2 emulator v1.1 , i test Daytona Usa, Indy 500 and Overrev (modelC)

It's working good with Daytona and Indy 500, but i haven't any ffb effect  with overrev... any clues?

I notice a weired effect also  when playing Daytona Usa and Indy 500, there is a 'Wangan's Road effect'  :ptdr: ,  i explain it : it is like when you play at Wmmt5, you know ?, the lines we cross on the wangan higway everytime (like a slighty regular bump), i have this effect amplified when i turn the wheel too...  :blink:

 

 A last thing : i gave an other try with Sr3 (but with the old plugin V1), and i forgot  about an unwanted effect i already have, and maybe  you know what to do to supress this unwanted effect:

when the cars is stopped, (begining and even after the end of a race, the wheel is balancing very slightly left and right continuously... (more like a tremor) 

hope you understand what i would like to explain... i don't know even if my english is correct too. :etudiant:

 

thanks

 

 

 

some advices would be appreciated.

Share this post


Link to post
Share on other sites

Hm wheel is turning hard to right on or2? 

 

I'll have to look into why this would be

 

Make sure you calibrate wheel in test menu

 

For Daytona, when does this bump effect occur?

 

As for overrev, did you read the readme and follow it? Gotta change stuff in test menu

Share this post


Link to post
Share on other sites

Ok,

 

oh sorry about overRev, i read what you wrote, but i forgot to set it up correctly first, i will test as soon as i can.

 

For daytona , i speak of the M2 emulator version of Daytona Usa. the effect is present everytime, if the wheel is perfectly centered, the effect is null or nearly (same with Indy 500)

 

For Or2, before i use the plugin, i can tell you that it was perfectly calibrated already.

 

EDIT: maybe  i have to re calibrate the wheel for Or2...

Edited by ginzu

Share this post


Link to post
Share on other sites

@Boomslangnz

Just tested v0.2 with Mame , i dont get FFB

v0.1 worked fine with San Francisco Rush

I using MameUi64 like before , now it isnt working with any of the supported games

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Share this post


Link to post
Share on other sites
7 hours ago, Moksi said:

@Boomslangnz

Just tested v0.2 with Mame , i dont get FFB

v0.1 worked fine with San Francisco Rush

I using MameUi64 like before , now it isnt working with any of the supported games

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

sorry forgot to include Mame 64bit folder

Edited by Boomslangnz
  • Thanks 1

Share this post


Link to post
Share on other sites
8 hours ago, ginzu said:

@Boomslangnz

 

i just went to give a try with the new ffb plugin v2.

 

i have done tests with Outrun2 SPDX  : something strange : every 5 to 7 seconds, my wheel is turning hard on the right whatever the surface on which i drive. :wacko:

 

i tried the plugin on Model2 emulator v1.1 , i test Daytona Usa, Indy 500 and Overrev (modelC)

It's working good with Daytona and Indy 500, but i haven't any ffb effect  with overrev... any clues?

I notice a weired effect also  when playing Daytona Usa and Indy 500, there is a 'Wangan's Road effect'  :ptdr: ,  i explain it : it is like when you play at Wmmt5, you know ?, the lines we cross on the wangan higway everytime (like a slighty regular bump), i have this effect amplified when i turn the wheel too...  :blink:

 

 A last thing : i gave an other try with Sr3 (but with the old plugin V1), and i forgot  about an unwanted effect i already have, and maybe  you know what to do to supress this unwanted effect:

when the cars is stopped, (begining and even after the end of a race, the wheel is balancing very slightly left and right continuously... (more like a tremor) 

hope you understand what i would like to explain... i don't know even if my english is correct too. :etudiant:

 

thanks

 

 

 

some advices would be appreciated.

 

hm I'm a bit confused by this, I just tested out Outrun 2 and I have no hard turning right at all happening unless I hit walls etc. Does anyone else have this issue?

 

I also tested out Daytona USA and again I am not having any issues such as above, turning the wheel works fine and there is no bumps like you were saying

 

Restart pc etc and get back to me and we will try work out what's going on

Share this post


Link to post
Share on other sites

@Boomslangnz 

 

Ok, maybe this evening.

Thank you anyway for the help.

It's maybe relative to my peripheral or a bad setting somewhere.

Share this post


Link to post
Share on other sites

Little info (off topic):

FFB Arcade Plugin v0.2.zip: 11mo

compressed in 7z solid mode (or rar with solid) = 1,24mo

^_^

/eof

Share this post


Link to post
Share on other sites
34 minutes ago, 7zxkv said:

Little info (off topic):

FFB Arcade Plugin v0.2.zip: 11mo

compressed in 7z solid mode (or rar with solid) = 1,24mo

^_^

/eof

 

I get your point, but not everyone wants to install 7zip or winrar etc and zip works natively on windows.

 

We are talking a 11mb file here, if it's really taking up valuable harddrive space I do apologize

  • Haha 2

Share this post


Link to post
Share on other sites

J'informe juste pour les connexions de merde qui télécharge les files, ici on en a plein en france. Pas de soucis après, c'était juste au cas ou. Je te laisse traduire^^

Edited by 7zxkv

Share this post


Link to post
Share on other sites

@Boomslangnz

 

Ok it's working perfectly with Outrun2.

The problem was , i didn't understand well the instructions .

 

To make it work you must put the opengl32.dll inside the tp version you are using .inside the Jennifer folder you have to put the SDL2.dll and the ffbplugin.ini files.

 

Then , you must add your guid (the one  from your wheel), inside ffbplugin.ini

But, i don't know why,  the guid from the log.txt was wrong.... and indicated well the right device.... 

 

When i copied the good guid it was working fine.

 

Share this post


Link to post
Share on other sites
1 hour ago, ginzu said:

@Boomslangnz

 

Ok it's working perfectly with Outrun2.

The problem was , i didn't understand well the instructions .

 

To make it work you must put the opengl32.dll inside the tp version you are using .inside the Jennifer folder you have to put the SDL2.dll and the ffbplugin.ini files.

 

Then , you must add your guid (the one  from your wheel), inside ffbplugin.ini

But, i don't know why,  the guid from the log.txt was wrong.... and indicated well the right device.... 

 

When i copied the good guid it was working fine.

 

 

Glad you got it working correctly now. Perhaps I need to make the instructions a bit more clear on readme

Share this post


Link to post
Share on other sites
Il y a 5 heures, Boomslangnz a dit :

 

Glad you got it working correctly now. Perhaps I need to make the instructions a bit more clear on readme

Yes,

 

I also redo tests with ID8, SR3, and Model2 Emulator.

 

I succeeded with SR3 , i adjust the setting correctly in the ffbplugin.ini file. :very-good:

 

ID8 , ok too. 

 

The only weired effect i can't remove is that 'wangan'sroad' effect i talked when playing M2 emulator ( test made with daytona usa).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×