Jump to content
Boomslangnz

[Arcade PC] FFB Arcade Plugin

Recommended Posts

On 5/13/2020 at 2:07 PM, lukudo said:

Hello , first, thanks to @Boomslangnz for FFB arcade plugin, i use it on my cabinet crt monitor, it's just amazing!

Can someone give me his 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
 for Demul Naomi? I'd like to use FFB with but I can't configure my inputs with my Thrustmaster TMX. I just need the alternative settings part (jamma).Thx !

Hi there,

 

Supported FFB for Demul only works on version Demul v: 180428. You can find it here on Emuline "Demul section". Don't bother searching for it on the official website since it is a private build.

Share this post


Link to post
Share on other sites
57 minutes ago, naderkadd1981 said:

Hi there,

 

Supported FFB for Demul only works on version Demul v: 180428. You can find it here on Emuline "Demul section". Don't bother searching for it on the official website since it is a private build.

Uh no that's incorrect now

 

Latest FFB Plugin released today supports any demul version now

Share this post


Link to post
Share on other sites
Il y a 6 heures, Boomslangnz a dit :

Uh no that's incorrect now

 

Latest FFB Plugin released today supports any demul version now

Thanks for the new Demul plugin, I'm going to test this tomorrow. :very-good:

Share this post


Link to post
Share on other sites
9 hours ago, Boomslangnz said:

Uh no that's incorrect now

 

Latest FFB Plugin released today supports any demul version now

Booms i have tested your recent package on the latest Demul version downloaded from the official site and i received no feedback. It only worked for me using 180428. 

Share this post


Link to post
Share on other sites
13 minutes ago, naderkadd1981 said:

Booms i have tested your recent package on the latest Demul version downloaded from the official site and i received no feedback. It only worked for me using 180428. 

 

What version did you try please?

 

I tested a few and all worked on mine

Share this post


Link to post
Share on other sites
40 minutes ago, Boomslangnz said:

 

What version did you try please?

 

I tested a few and all worked on mine

Demul v 0.7 Version 111117 

Edited by naderkadd1981

Share this post


Link to post
Share on other sites
10 minutes ago, naderkadd1981 said:

Demul v 0.7 Version 111117 

 

That version works fine here

 

are you sure you have set it up correctly?

Share this post


Link to post
Share on other sites
8 minutes ago, Boomslangnz said:

 

That version works fine here

 

are you sure you have set it up correctly?

Strange. I unzipped all of the contents in the root folder of Demul. Enabled logging, and set the Guid serial number in ffb.ini as should.I Will repeat the attempt and give you my confirmation. Thanks for the follow up.

Edited by naderkadd1981

Share this post


Link to post
Share on other sites
3 minutes ago, naderkadd1981 said:

Strange. I unzipped all of the contents in the root folder of Demul. Enabled logging, and set the Guid serial number in ffb.ini as should.I Will repeat the attempt and give you my confirmation. Thanks for the follow up.

Make sure you have removed old dinput8.dll if its there

Share this post


Link to post
Share on other sites
16 minutes ago, naderkadd1981 said:

Strange. I unzipped all of the contents in the root folder of Demul. Enabled logging, and set the Guid serial number in ffb.ini as should.I Will repeat the attempt and give you my confirmation. Thanks for the follow up.

 

wait I see the problem

 

I added something just before release which i see is different on 11117 

 

I said it worked fine cos that's the version I was testing with before release

 

lemme fix this up

Edited by Boomslangnz

Share this post


Link to post
Share on other sites

Hotfix for FFB Arcade Plugin v1.9a

 

Changed files to new update

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Edited by Boomslangnz

Share this post


Link to post
Share on other sites
Il y a 18 heures, Boomslangnz a dit :

Hotfix for FFB Arcade Plugin v1.9a

 

Changed files to new update

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Thanks! I tested Sega racing Classic it's much better!

I can't test Demul, impossible for me to configure my TMX properly. 

I tested some of the Model 2 games,  on Daytona i can feel better when the car hit another one.

Great job!

And i read on arcade controls you're working on Rave Racer for new Mame plug in, i play it Old mame plugin but it's a great news .Can we hope for ridge racer will one day have the ffb? :fiesta:

Share this post


Link to post
Share on other sites
4 hours ago, lukudo said:

Thanks! I tested Sega racing Classic it's much better!

I can't test Demul, impossible for me to configure my TMX properly. 

I tested some of the Model 2 games,  on Daytona i can feel better when the car hit another one.

Great job!

And i read on arcade controls you're working on Rave Racer for new Mame plug in, i play it Old mame plugin but it's a great news .Can we hope for ridge racer will one day have the ffb? :fiesta:

 

No as Ridge Racer doesnt have force feedback

Share this post


Link to post
Share on other sites
Il y a 9 heures, Boomslangnz a dit :

 

No as Ridge Racer doesnt have force feedback

oh you're right, I played on the arcade cabinet in 1993,my memory got me :triste:

Share this post


Link to post
Share on other sites
hace 3 horas, Boomslangnz dijo:

New Version of FFB Arcade Plugin. Now Version 2.0

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

Hello, i have a T300 and i suffer this EXACT bug, please can fix? (other users reported the same).

 

"With Daytona usa 3 when i push start my wheel moves a little to the left and he stays on that position so he does not center, I don't know why i have this only on this game all other are good".

 

Thanks for your amazing work.

Edited by edb79

Share this post


Link to post
Share on other sites

Hi @Boomslangnz, with the plug in version 2.0, i have no effects on Rave racer and Super Chase.

I'm on MameUI 0.221, the force spring effect work but without all the effects . All the other games have effects like Outrun, V.R ...

I tried power mode on this two games without results. Thanks :very-good:

 

Edited by lukudo

Share this post


Link to post
Share on other sites
2 hours ago, lukudo said:

Hi @Boomslangnz, with the plug in version 2.0, i have no effects on Rave racer and Super Chase.

I'm on MameUI 0.221, the force spring effect work but without all the effects . All the other games have effects like Outrun, V.R ...

I tried power mode on this two games without results. Thanks :very-good:

 

Hm ok strange.

 

have you enabled ffb in test menu? Its required on rave racer

 

Could you let me know rom names please 

 

Only those 2 games aren't working? I'll check it again here

Edited by Boomslangnz

Share this post


Link to post
Share on other sites
Il y a 9 heures, Boomslangnz a dit :

just double checked both games on mame 0.221 and mame 0.117 and both worked fine here

 

Hi, the ffb is enabled on the menu of Rave racer.

Yesterday, i said that V.r has effects, i checked it. With this plug-in version i lost the effects :triste:Run fine with the first version of the plug-in i've tried, the 1.7b.

So,a weird thing, i said you i have only the spring effect with Rave Racer and Super chase (and now V.r) BUT not the spring effect per game setting, it's the main spring effect setting in ffbarcadeplugin.ini. Per game setting with this games don't work.

I've been looking for a solution since yesterday I don't see what's wrong. Rave racer worked for me with the old mame 64 plug-in and Mame 206.

Finally, my roms name are raveracw and superchs. It's a 0.221 romset.

Thanks for your helping .

 

EDIT: Ok i've found a issue.I created a separate folder for Rave racer and Super chase.

Mame 0.221 (not Mameui) with the roms and bios for these games.

If I start the games, no ffb, no problems. If I put Output windows in mame,ini, mame crash. For these two games. :gene:

Edited by lukudo

Share this post


Link to post
Share on other sites

Lukudo - by any chance do you have a specific game .ini file? For instance, raveracw.ini, superchs.ini in your MAME folder? If so, you need to change the OSD Output from 'Auto' to 'Windows' there as well. 

Share this post


Link to post
Share on other sites
14 hours ago, lukudo said:

 

Hi, the ffb is enabled on the menu of Rave racer.

Yesterday, i said that V.r has effects, i checked it. With this plug-in version i lost the effects :triste:Run fine with the first version of the plug-in i've tried, the 1.7b.

So,a weird thing, i said you i have only the spring effect with Rave Racer and Super chase (and now V.r) BUT not the spring effect per game setting, it's the main spring effect setting in ffbarcadeplugin.ini. Per game setting with this games don't work.

I've been looking for a solution since yesterday I don't see what's wrong. Rave racer worked for me with the old mame 64 plug-in and Mame 206.

Finally, my roms name are raveracw and superchs. It's a 0.221 romset.

Thanks for your helping .

 

EDIT: Ok i've found a issue.I created a separate folder for Rave racer and Super chase.

Mame 0.221 (not Mameui) with the roms and bios for these games.

If I start the games, no ffb, no problems. If I put Output windows in mame,ini, mame crash. For these two games. :gene:

 

Yea i don't understand. I haven't even touched VR so i don't see how that could stop working 

 

and the other 2 games work fine for me across different builds of mame

 

*EDIT*

just tried VR and works fine, obviously same as always you need to set cabinet to upright

 

problems are at your end

Edited by Boomslangnz

Share this post


Link to post
Share on other sites
On 5/28/2020 at 1:53 AM, edb79 said:

 

Hello, i have a T300 and i suffer this EXACT bug, please can fix? (other users reported the same).

 

"With Daytona usa 3 when i push start my wheel moves a little to the left and he stays on that position so he does not center, I don't know why i have this only on this game all other are good".

 

Thanks for your amazing work.

 

I have a t300rs here too but I dont have this issue happening 

Share this post


Link to post
Share on other sites

@Boomslangnz your plug in works great but I am having an issue with MAME. Any non FFB game makes the wheel have zero resistance when I turn. So I have to turn the sensitivity way down and even then some games are unplayable. Not sure if it's the plug in, MAME or my wheel. Other emulators that don't have FFB still have some resistance. I am using a G920.

Share this post


Link to post
Share on other sites
il y a 42 minutes, mrbrightside80 a dit :

@Boomslangnz your plug in works great but I am having an issue with MAME. Any non FFB game makes the wheel have zero resistance when I turn. So I have to turn the sensitivity way down and even then some games are unplayable. Not sure if it's the plug in, MAME or my wheel. Other emulators that don't have FFB still have some resistance. I am using a G920.

Hi, set EnableForceSpringEffect to 1 in ffbplugin.ini in your Mame folder for the non FFB games :very-good:

Share this post


Link to post
Share on other sites
9 minutes ago, lukudo said:

Hi, set EnableForceSpringEffect to 1 in ffbplugin.ini in your Mame folder for the non FFB games :very-good:

You are the man! Works perfectly! Thank you

Share this post


Link to post
Share on other sites

@Boomslangnz  

Trying out the latest vesion with MAME

i seem to be getting no FFB with Outrun and after i close Mame i get an dinput8.dll crash

(For now only Outrun seem to be the cause)

So Far i tested PowerDrift / Virtua Racing / Cruisn World  they work fine

one thing with Cruisn World are you supposed to get FFB when bumping into cars , walls or should you only get Spring effect with the wheel

Share this post


Link to post
Share on other sites
2 hours ago, Boomslangnz said:

New Version of FFB Arcade Plugin. Now Version 2.1

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Wow. I am dreaming. You are my Champion.

Share this post


Link to post
Share on other sites
54 minutes ago, naderkadd1981 said:

Wow. I am dreaming. You are my Champion.

mame 203, 0.199, and 0.219 hang with 2.1 ffb setup. any ideas> OSD

output set to windows. error log ;appcrash.   of course if i either delete dinput or mame64.dll from mame folder games work again but no ffb.

Edited by naderkadd1981

Share this post


Link to post
Share on other sites

Yeah, same for me, if i try to play Ace driver, Mame crash (or symply freeze). The other games (all the games before 2.0 version) are Ok. Mame version 0.221.

And thanks for the plugin input Demul , that's great !

Here's my log when i try to launch Ace driver :

 

DLLMAIN ENTERED
process name:
C:\Hyperspin\Emulators\Mameracing\mameui64.exe
default centering & friction values:
0
0
dll process attach:
C:\Hyperspin\Emulators\Mameracing\mameui64.exe
0
100
loading original library...
C:\Windows\system32\dinput8.dll
library loaded
creating ffb loop thread...
Before CreateThread
After CreateThread
In FFBLoop
in initialize
numJoysticks = 
1
Joystick: 0 / Name: Thrustmaster TMX Racing Wheel / GUID: 030000004f0400007fb6000000000000

Haptic joystick found: 0 / Name: Thrustmaster TMX Racing Wheel / GUID: 030000004f0400007fb6000000000000

Rumble Init
disabling all current FFB effects
setting haptic gain to 100
setting haptic auto center to 0
creating base effects...
Initialize() complete
Setting DefaultCentering & DefaultFriction forces...
Entering Game's FFBLoop loop
 

 

Edited by lukudo

Share this post


Link to post
Share on other sites
7 minutes ago, lukudo said:

Yeah, same for me, if i try to play Ace driver, Mame crash. The other games (all the games before 2.0 version) are Ok. Mame version 0.221.

And thanks for the plugin input Demul , that's great !

Moreover, its not only ace Driver , all other games that support ffb (dirt dash, rave racer, sega rally , ext) crash when attempting to select one of these games. I suspect that there might be a bug in the dinput8.dll! .

Edited by naderkadd1981

Share this post


Link to post
Share on other sites

Trying the new 2.1 with Demul.  Hydro Thunder works which has always worked with FFB, but no rumble with ATV or Faster than Speed.  Any trick?

Share this post


Link to post
Share on other sites
il y a 1 minute, naderkadd1981 a dit :

Moreover, its not only ace Driver , all other games that support ffb (dirt dash, rave racer, sega rally , ext) crash when attempting to select one of these games. I suspect that there might be a bug in the dinput8.dll! .

I had no problem with the plug-in before 2.0 version in my case and yes i said Ace driver but rave racer, super chase etc don't work for me too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×