Jump to content
7zxkv

[Arcade PC] Justice League - Heroes United (Global VR)

Recommended Posts

JUSTICE LEAGUE - Heroes United
justice league.png

CRACKED by MOHKERZ and FIXED by DUCON2016


Here is a new dump from a GLOBAL-VR Arcade Game.
A beat-em-all released in year 2009.

Dongle crack, I/O-bypass and some other tweaks done by MOHKERZ.
D3D9 Wrapper and some fixes done by DUCON2016.

Great thanks to DUCON2016 for his help, his knowledge and his niceness!!! MERCI DUCON!
Thanks to 1CC, Emuline and every arcade lovers.

Enjoy!!! or not…

Oh and read the fucking READ-ME!

————————————————–

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.


Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

(pass: MOHKERZ)

————————————————–

jl.jpg

About this release:

-Resolution and Fullscreen are set in JLH.ini so edit this file with your settings.
Set FULLSCREEN to TRUE to play in fullscreen.
Edit this lines for your desired X resolution: ScreenResolutionX and DisplayWidth.
Edit this lines for your desired Y resolution: ScreenResolutionY and DisplayHeight.

 

In _CODECS_SETUP folder you will find everything to get audio and video cutscenes working.
-For audio to work, it seem you must have installed OpenAL sound engine.
-For videos to work, you will have to install some INDEO codec pack.
Their installer is apprently going wrong, so you will maybe have to install files manually.

 

-Just unzip the archive anywhere you want.
Then run the game by launching JLA.exe.
To quit the game, just press ESC.

 

-Controls are DINPUT so find an Xbox pad or anything else that is DInput.
You can use some software to fake a dinput pad to be able to play with anything (keyboard or else...)
4 action buttons + START button and 1 analog stick (X+Y) are required.

 

-The test menu can be triggered by some keyboard key, then you can tweak some settings that are all in JLH.ini.
Game is FREEPLAY and I suggest you leave it like that, because it can break if you change to COINS settings.

 

 

source:

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
Edited by 7zxkv
new link + icon (pooter)
  • Like 5
  • Thanks 5
  • Haha 1

Share this post


Link to post
Share on other sites

slt , merci pour le up

j'arrive pas a le lancer en fullscreen

en mode fenetre ca lance mais bloque a initialising patienter ;-)

 

qui peut aider

merci

tchuss

Share this post


Link to post
Share on other sites

idem

Share this post


Link to post
Share on other sites

Merci :very-good: je connaissais pas du tout ce jeux en arcade.

Apres avoir vus la video :(bof chacun ces gouts).

 

Share this post


Link to post
Share on other sites
1 hour ago, Bruce said:

Merci :very-good: je connaissais pas du tout ce jeux en arcade.

Apres avoir vus la video :(bof chacun ces gouts).

 

 

C'est un bon jeu pour les enfants ou pour les fans de DC. Mais oui on a vu mieux.

Share this post


Link to post
Share on other sites

Game was tested on Win7 x64…

As it is an old game designed for XP, expect problems on newer OS… we'll try to fix this if you tell us precisely…

Begin to help by telling the graphic card and OS you use.

Edited by Mohkerz

Share this post


Link to post
Share on other sites
hace 13 minutos, Mohkerz dijo:

what graphic card? what OS?

how can we help if you don't help?

 

GTX 1080Ti, windows 10 64 bits

Share this post


Link to post
Share on other sites

OK thanks, what is the error?

Please turn LogOutput to true in JLH.ini.

Then launch the game, it must create a Heroes_log.txt in root.

What errors are in this file?

Edited by Mohkerz

Share this post


Link to post
Share on other sites
hace 3 minutos, Mohkerz dijo:

Well, try to add these dll to game root.

Wasn't needed for win7, but maybe help on Win10.

Then you can try to create a shortcut to JLA and add -nohardware parameter in command.

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

 

It worked, thanks

Edited by beatlep
  • Haha 1

Share this post


Link to post
Share on other sites

Turn fullscreen to true in JLH.ini.

Try turning AutoDetectKitMonitors=true.

What is your screen res?

And resolution supported are in JLH too (1360x768, 1366x768, 1365x720, 1280x720, and 1600x900) maybe some more like 640x480 and 800x600, but highest possible is 1600x900 (without patching).

Then for game stuck in windows mode, try using DXwnd as i got it working with this, learn it (not difficult), try some tweaks, it should work.

 

Edited by Mohkerz

Share this post


Link to post
Share on other sites

It is not a supported resolution.

Try using 1600x900 and turn fullscreen to true.

Also change all lines concerned in JLH as instructed in read-me.

Share this post


Link to post
Share on other sites

Hi Mohkerz

 

First, thank you for sharing you work with us. It is greatly appreciated.

 

I run it on win 7 64 bits (with service pack 1 installed) with Geforce GT520 and it needs the physxdll to work.

Before to add this dll to the game root, I have the same problem as others here.

 

So thanks for your help.

Edited by scooby

Share this post


Link to post
Share on other sites

i run this game in win 10 with win 7 compability mode, add

Hidden Content

    Give reaction or reply to this topic to see the hidden content.
. and edit JLH.ini delete Fullscreen=true and ScreenResolutionX=1600
ScreenResolutionY=900 my problem is audio is not macth with game and always disappear.

Edited by july2779

Share this post


Link to post
Share on other sites

@Scooby: is it working OK now?

 

@july2779: firstly did you read the Read-Me?

then did you install openOAL from codec folder?

try running this without compatibility, or better try XP...

maybe you need to try some other openAL installers for windows10, i don't know about this and can't test under win10?

Share this post


Link to post
Share on other sites

@Mohkerz: i run this with no compability is running but same problem audio is always disapper. i already install openAL installers but same problems in win 10

Share this post


Link to post
Share on other sites

Ok so i don't know about this issue.

Maybe try some openAL installer that is better for Win10 or tweak your audio settings.

That's a problem with your system and openAL or maybe OGG vorbis as the game uses it as well.

Can't help more with this, sorry...

Share this post


Link to post
Share on other sites

@Mohkerz: Thanks  my OpenAl32.dll for win 10 this running good for this game. Delete old and replace with this.

 

Hidden Content

    Give reaction or reply to this topic to see the hidden content.

Edited by july2779
  • Thanks 1

Share this post


Link to post
Share on other sites

runs fine thanks 4 work inputs are already mapped to usb controller 

mov cutscenes r missing win7 - oh well 

audio fine 

gfx 60fps cell shading 

tidy 

 

Share this post


Link to post
Share on other sites

Thanks Mohkerz for this game :)

 

The game boot fine in windows 7 64bits. (i haven't played it for now)

Core i3 and gtx750ti.

 

I have enabled the log and i found this :

ERROR: CGFXApp::InitRenderer: 27 adapter modes detected.
ERROR: GUI object Size could not be created from instance.
ERROR: GUI object Size could not be created from instance.
ERROR: MEMORY: Current Physical = 6052311040
ERROR: Error in lua Script scripts/game.lua: Line: unknown

 

 

EDIT : I move the game on another DD  (from c: to k:) and the log have more information:

 

ERROR: CGFXApp::InitRenderer: 27 adapter modes detected.
ERROR: Could not render source output pin!  hr=0x80040266ERROR: GUI object Size could not be created from instance.
ERROR: GUI object Size could not be created from instance.
ERROR: MEMORY: Current Physical = 6809010176
ERROR: MEMORY: Current Physical = 6868008960
ERROR: Error in lua Script scripts/game.lua: Line: unknown

 

Just for information if this help ;)

 

Edited by bonky0013

Share this post


Link to post
Share on other sites

Game is logging lots of things.

Please only report logs if the game is not working, else if working, then everything's fine!

I don't have much time to debug things that seems to work...

 

The line in log file: ERROR: Could not render source output pin!...... refers to some codec errors while loading audio or video files, so you certainly have no sound or video cutscenes when this occurs.

To fix this just install the good version of openAL audio thing for your OS, and the video codecs included.

As mentioned in read-me, the old indeo installer is buggy with most recent OS and doesn't register DLL properly, so it's needed to perform a manual install (very easy).

 

Then, this line must disappear from the log as you have working audio & video.

Edited by Mohkerz

Share this post


Link to post
Share on other sites
Here the game works well, both audio and video are ok.
But I can not configure the controls, I have already used the x360ce programs and also
the Xoutinput but it does not work.
Edited by punkdark2000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×